Roon Backups have suddenly started failing [Solved]

Roon Core Machine

Intel NUC8i3BEH1 core i3, 8GB RAM, 120GB SSD Roon ver 2,0 (1223)

Networking Gear & Setup Details

Wired Ethernet

Connected Audio Devices

Number of Tracks in Library

800 albums

Description of Issue

After several years of flawless service my Roon server has suddenly become unable to perform any database backups.

The backup location has always been on the same Windows 10 shared folder that also has all of my music files. Nothing has changed (the Windows 10 PC acting as a server does not get any Windows updates at all).
To see if it was some kind of trouble with the network I inserted a 16GB USB drive into the NUC. I restarted Roon and the USB drive appeared as available location to use as a backup. But I get the same error with the USB drive. So, what happened?
I pulled the log file, but I don’t see how I can upload it here.

What format is the USB drive that you added as a test to your NUC?

The backup procedure started and ran for about a minute before failing.

Try defining a new Backup location on the drive and see what happens?

Yeah, I tried that. I even deleted the backup folder and tried starting “fresh”. I still get the same error.
It does the “Snapshotting of Database”, then switches to “preparing” and that’s where it fails.
How do people upload the log files? I kind of think it’s going to some examination of the logs to see why it’s failing.

I’ve put a copy of the log on my google drive. The entries for the backup should be near the end.
Log file

Um, does this mean that you don’t have any backups any more? If so, that a pity, because the symptoms sound as though your Roon database has recently become corrupted - that’s probably why Roon is now refusing to take a backup of it.

I also have offline backups of Roon.
But, how can I confirm that a corrupt database is the culprit?

Try restoring an older backup and then seeing if you can make a new backup.

Roon now checks for database integrity before taking a backup, so in principle the last good backup should reflect an uncorrupted database, but you could try one slightly earlier just to be sure…

Nope, looks like I’m out’a luck.
It refuses to restore from the last good backup.
I get “error retrieving backup listing (invalid root)”
I tried selecting different folders and sub folders but I always get the same error.
Seems like the entire backup/restore routine is messed up.

You’ve navigated too far - you need to select the Roon_Backups folder, which should then open the Backup Manager… I think?

Er - hang on a minute; that \\nexus\music wouldn’t also be a Roon Watched Folder, would it?

No, the Roon watched folder is another sub folder on this “Music” share.
It’s like this:
\MUSIC\MP3 → this is the Roon watched folder (I have just double-checked this to be sure)
\MUSIC\Roon_Backups → is the backup folder

I’ve tried every folder to initiate the restore and no luck. Always invalid root.

OK, then we’d better wait until @support has had a chance to examine the logs. Once last shot in the dark - rebooting your Core changes nothing, right?

Yeah, rebooting both the NUC and the Windows server didn’t help.

I just exported the database to an excel sheet. So, if I have to start over from scratch I can al least recreate some of details like tags.
Thanks for your help.
Hopefully support will be able to figure out what’s going on.

I just updated Roon to build 1232 - and that made no difference.

Same problem though. My backups all fail.

To recap:
This has been backing up weekly just fine for 3 years.
I normally backup to a windows 10 share.
I also tried a USB stick plugged into the NUC (exFAT formatted) - same error.
I tried backing up to a different share on the Windows server - same error.
I am not backing up a watched folder.
I rebooted the NUC and the Windows server.
I posted the log file earlier in this thread.

The backup starts fine with the message about performing a snapshot. Then when it shifts to “preparing” it fails with a non-helpful “Error backing up database”.

I’ve seen other posts here with the same issue. I think there’s a bug.

Hmmm, we have now big problem with local libraries (not see, not playlable) and now… backups?!

Whats wrong with you Roon dev.? Please fix core functionality pronto!

And ARC…a lot wrong with it.

I performed the update to build 1234 today. I tried the backup again (even though there was no mention of addressing backups in the change log).
I still get the same backup error. I decided to look into this some more. After scanning the log info (below), I noticed that it was getting a SystemIO error on a particular file - abhaaaaa.jpg.
I went and followed that path to that file on the server. The jpg opened fine and it was a picture that I had added by editing the metadata (in the Roon app) on a particular obscure jazz quartet that Roon was unable to add any information on it’s own. So, I deleted the file and ran the backup again.

IT WORKED! The backup completed.

For some reason that jpg was crashing the backup. It would have been nice if the backup error could have included some more info, like the filename it was choking on.

03/17 14:55:58 Trace: [broker/backups] [8e3cb3ac-ff17-42fb-a288-c6660dfaee45] checked 2000 files, planning to upload 1999 files
03/17 14:55:58 Debug: [broker/filebrowser/volumeshare] Use dispose, id: \nexus\music
03/17 14:55:58 Warn: [broker/backups] unexpected error doing backup on FileBrowser.Entry: \nexus, music : \Roon_Backups\RoonBackups: System.IO.IOException: Input/output error : ‘/roon/data/RoonServer/Database/Core/e69a8d27b4404687b3ed90d9c655cf17/images_1/ab/ha/abhaaaaa.jpg
at System.IO.Strategies.OSFileStreamStrategy.Read(Byte[] buffer, Int32 offset, Int32 count)
at System.IO.Strategies.BufferedFileStreamStrategy.ReadByteSlow()
at Sooloos.Broker.BackupCompute.<>c__DisplayClass12_1.b__1(String file,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.