Roon Backups with New Windows 10 Upgrade


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Home Network connected using LAN & Wi-fi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Main end point an Auralic Altair pre-amp

Description Of Issue

I used to regularly back up to a Windows 10 laptop (which I also use as a remote). Yesterday the brand new version of Windows 10 (v 8.22992.0) - a significant change to previous versions - was installed on my laptop

The Roon back-up will not now work to the laptop.

Microsoft’s guidance notes say that the Homegroup functionality has now been removed from Windows 10

I can not now see a way to back up to a Windows device

Am I missing something?

Any ideas?

This looks like a Windows 8 version number.

I use WIN10 Home. It tells me it’s up to date. My WIN10 version is 10.0.18363.


Are you sure you even need a Homegroup? I 've never needed to use it.

Major Windows upgrades have a habit of turning off the network discovery service, so that the PC can’t see (or, I think, be seen by) other devices.

Open up the Windows File Explorer, and click on the Network icon at the bottom of the navigation pane. If you get a message saying the service is turned off, you will also be able to tell Windows to turn it back on.

Thank you Slim and Geoff

I am not very IT savvy and have always struggled with file sharing in Windows

The current situation is that Roon says the file path is not available, the same file path that worked before the upgrade

I have checked and ensured that network sharing is on

I do not know if it is anything to do with changes to home group but now the file is not accessible when it used to be. Only change is the Windows upgrade

Thanks again

It could have something to do with the share permissions, now that Homegroup is being ignored.

This is the successful way I share files -

In the link, ignore the bit about logging in.

I think we’ve all been there… :roll_eyes:

The next thing to check, I think, would be whether Windows has removed SMB for file sharing during the upgrade. If so, you’ll need to turn it back on.

Or, if you don’t want to fool with Windows, grab a USB HDD and plug that into your music server device for backups.

That was removed in version 1803 released in the fall of 2018. So unless you have not been updating, HomeGroup has been long gone. As, Slim linked to above.

Thank you all for your tips and guidance

However, the situation seems to be going from bad to worse

I did, as suggested, check the status of SMB and it had been disabled, so I enabled it again.

Shared all appropriate files but the back up would still not work

Today Windows can no longer find my ROCK device (by typing \ROCK as usual), even though it is there on my network and Roon is using it fine

Any ideas?

Hmm. That’s odd. Windows File Explorer will often lose a ROCK NUC from its list of network devices, but typing in \\ROCK\ into the address field of File Explorer will always get it back for me.

Many thanks Geoff

I have re-installed the previous version of Windows 10 and rather miraculously the problem has gone away!

Backing up again fine


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.