Roon Bridge not showing up on desktop

Roon Core Machine

|OS Name|Microsoft Windows 11 Pro|
|Version|10.0.22621 Build 22621|
|Other OS Description |Not Available|
|OS Manufacturer|Microsoft Corporation|
|System Manufacturer|Gigabyte Technology Co., Ltd.|
|System Model|Z590 AORUS XTREME|
|System Type|x64-based PC|
|System SKU|Default string|
|Processor|11th Gen Intel(R) Core™ i9-11900K @ 3.50GHz, 3504 Mhz, 8 Core(s), 16 Logical Processor(s)|
|BIOS Version/Date|American Megatrends International, LLC. F9, 11/3/2021|
|SMBIOS Version|3.3|
|Embedded Controller Version|255.255|
|BaseBoard Manufacturer|Gigabyte Technology Co., Ltd.|
|BaseBoard Product|Z590 AORUS XTREME|
|BaseBoard Version|Default string|
|Platform Role|Desktop|
|Secure Boot State|Off|
|PCR7 Configuration|Elevation Required to View|
|Windows Directory|C:\WINDOWS|
|System Directory|C:\WINDOWS\system32|
|Boot Device|\Device\HarddiskVolume1|
|Locale|United States|
|Hardware Abstraction Layer|Version = 10.0.22621.819|
|User Name|DESKTOP-RNFBOEO\Freeze|
|Time Zone|Central Standard Time|
|Installed Physical Memory (RAM)|64.0 GB|
|Total Physical Memory|63.9 GB|
|Available Physical Memory|54.0 GB|
|Total Virtual Memory|67.9 GB|
|Available Virtual Memory|53.5 GB|
|Page File Space|4.00 GB|
|Page File|C:\pagefile.sys|
|Kernel DMA Protection|Off|
|Virtualization-based security|Not enabled|
|Windows Defender Application Control policy|Enforced|
|Windows Defender Application Control user mode policy|Off|

Networking Gear & Setup Details

Windows PC (Running Windows 11 Pro) Uptone Audio Ethernet switch

Connected Audio Devices

USB from PC to PSAudio DSD DAC

Number of Tracks in Library

16,642 Tracks

Description of Issue

If I understand correctly, Roon Bridge allows the user to listen to Roon on other devices such as my Office PC.

Once downloaded, the software does not come up on the desktop. When Task Manager is opened it shows Roon Bridge is running but nothing comes up on the desktop.

@Leighton_Freeze, this is the correct behavior of Roon Bridge. It is lightweight and runs in the background on Windows PCs, Macs, and Linux devices, and does not have a user interface. It strictly allows users to connect to devices using Roon’s RAAT protocol using that computer. Control is performed by the Roon Core or other Remotes (phones, tablets, other PCs or Macs) that have the full user interface.

If you need to control the audio directly on the device on which the Bridge is installed, you may want to download the full Windows application that includes the full Roon interface onto that PC.


I would like to control it on my office PC. I have the full Roon interface installed but didn’t find anything that facilitated play back on my PC.
A bit of further information, I’m using an Audioquest Cobolt Dragonfly on that PC.

While I’m not averse to technology, I am at the set it and forget it stage. So perhaps I am not seeing something that is right in front of my face.

You don’t want Roon bridge if you want to control Roon on the same PC as it has no interface it’s controlled by any Roon remote app it’s dumb bridge that’s all. For it to be seen by other Roon remotes you need to enable it in then Audi settings of Roon as it will show up.

If you want local control Uninstall Roon bridge and install the main Roon windows app when it asks if it’s to be a core or remote choose remote. Then goto audio settings and the enable the DAC. Ensure Roon and RAATServer are exceptions in your firewall.

1 Like

Hey @Leighton_Freeze,

Following up on this thread, both @Robert_F and @CrystalGipsy are correct here with proepr next steps.

Let me know if you’ve hashed things out already, or if you’re still running into issues :+1:

I’ve uninstalled then reinstalled Roon, however, there was not a direct option to choose remote. after installation I went to Audio settings, selected my DAC, and clicked on Device setup. Within Device setup there is an option to select yes for a private zone. Alas it did not work. any other thoughts? I am also running into tracks loading slowly issues. Is this on your end or mine?

Hey @Leighton_Freeze,

Can you please share a screenshot of your Roon Settings> About?

This may be because you are running a network switch in between your core device and router. I would test out hardwiring your core directly to your router and see if you run into similar issues :pray:

@Leighton_Freeze, on your office PC are you running a VPN to get into your work network? Is your office PC and your Roon Core on the same network at home?

I have a VPN available but not in use. Yes, all my PC’s are on the same network. There is also the Uptone network switch. With the network switch removed there is still an issue with tracks loading slowly.
That started with one of the recent updates.

Can you provide any more details about your network, including the brand and model of your router, how devices are connected, how and where the Uptone switch is connected and located, etc.?

Router is Comcast X1 Gig speed, Connections from router to A side of Uptone switch, B side is out (via Wireworld Starlight Ethernet cable to computer. I am using USB to connect to my PSAudio DSD.

I’ve found an Ethernet signal issue when using the network switch. At the moment I’ve taken it out of the system. Also, I uninstalled Roon then reinstalled it and set it up as new. Since reinstalling Roon the slow loading issue so far has not been a problem. I was also having an issue when I would pause Roon for any length of time. It would take several seconds before starting up again. That also seems to have been resolved.

@Leighton_Freeze, do you believe you are stable now with the switch removed and the reinstall working?

I waited for a few days to make sure things worked as they should. So, yes, I’m stable. Still can’t get it to play on my office computer though.

@Leighton_Freeze, I marked this as solved. It may be worthwhile to open a new thread regarding your office computer. Is your office computer a home office-based setup or actually in an offsite office?

It’s in a home office and on the same LAN.

@Leighton_Freeze, why don’t you create a new thread specific to the your office PC, listing its configuration, network connection type, etc. as this may be a different issue. We can link to this thread for reference.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.