Roon Bridge on DietPI: impossible to update from build 164 to 167 [Resolved by Dan_Knight (DietPi Creator)]

My dietPis are all on much older builds (it ain’t broke…) 157-159 from memory. Is it safe to update to the latest Roon release?

(Before anyone asks, updating DietPi from 15X to 16X involves a complete reflash and setup of the SD card and with 5 endpoints in the system it is not something I have found time or inclination for since V6 was released. I should have plenty of time at the end of December, so no excuses then!)

the command in the linked thread should work

If you’re not comfortable with running the commands, I found that simply uninstalling the two Roon packages and then re-installing them did the trick.

DietPi will reboot after you remove Roon Extension Manager and Roon Bridge…


One more reboot, and you should see your zone show back up in Zoon with version 1.67 installed.

Single command line to reinstall Bridge from the command line:

dietpi-software reinstall 121

3 Likes

I guess I would do 86 as well…just to be safe.

The cause of the issue has been found…

1 Like

Thanks. Your curl -O worked. The first replier had curl -0 which doesn’t work.

Gerald

Hi.
Manual install via SSH worked on mine (DietPI latest build + HifiBerry DIGI PRO) too

Have fun
Bernie

86 is the Roon extensions manager that is for running extensions only and is not required to function as an endpoint.

Hello All,

I just wanted to update everyone here and let you know that Dan_Knight (DietPi Creator) has commented on this issue on another thread (DietPi/Allo units not getting the RoonBridge B167 update from B164). He has found the cause and has reverted to Root permissions for the 6.18 patch which will hopefully get this all sorted out. Thanks again for the report regarding this matter and do let us or Dan_Knight know if you are still running into issues after the patch!

Thanks,
Noris

2 Likes

The weekend is approaching; I thought I’d check and see if you fixed the Roon Bridge update issue. Now it’s not failing, it’s hanging… oy.

Hi Neil,

The fix is only available to Beta testing at the moment:

We are aiming to officially release v6.18 with the Roon service fix, in the next few days.

3 Likes

There was another Roon update today. Unfortunately, it failed to update Roon Bridge on my Pi’s (again - still?). The sad part is that I’m looking for Qobuz support. What happened to Qobuz?

  1. There was no update for the Roon Bridge in this update. The Roon Bridge update you are seeking can be done via a previously discussed work around or by waiting for the next build [of DietPI].
  2. The question about Qobuz might be better asked in a non-DietPi forum. You asked that question in a DietPi specific forum.
1 Like

John, apologies you don’t like where or what I ask. I have friends that I have to answer to about Roon. I talked them in to Roon; I did the install. I’m not sure what’s taking so long with this bridge “fix”. I expect a lot from Roon’s programmers, and I’m not sure where to post these questions (as I stated several times before). If you don’t like my reference to Qobuz, I suggest you ignore it. Let’s be proactive. When do you estimate the Roon Bridge fix will be complete?

I’ll find time this holiday weekend to look for a suitable place to ask questions about Qobuz. It really shouldn’t be this difficult to get information or answers from Roon.

My best to you,

Neil SMall

Pal, I am just a Roon user like you. I was trying to give you answers to your questions. If you don’t like my answers I suggest that you ignore it.

1 Like

Hi Neil,

The issue regarding DietPI not being able to update the RoonBridge remote is fixed in our next release of DietPI v6.18.

Currently v6.18 is in open beta testing:

When beta testing is completed, we will roll out v6.18 to all users.

In regards to Qobuz, if this is a software request that you would like to see offered/supported in DietPi, please create a request ticket and we will investigate:

2 Likes

Just to be clear, we’re not currently aware of any general issues with updating Roon Bridge, and the most recent release was Core only (no mobile updates, no updates for Roon Bridge), so there was no update last week.

My understanding is that there was an issue with updating on DietPi, and Dan is on it. In the world of software, it’s doesn’t get a lot better than “the bug is fixed in our current beta and will go live with the next release”, so I think you just need to be patient on this one.

Also note that there have been very few changes in Roon Bridge over the last few months, if any.

1 Like

The issue is with DietPI, not Roon. Allo products running DietPi are impacted.
This is not really a problem as Roon Bridge works well even without the latest update.
Also Dan sais DietPi will be fixed in the next days.
So let’s all wait, then update our devices through All Web Interface or dietpi-update, and all will be good!
Thanks again @Dan_Knight

1 Like

Hi All,

To clear this up the issue is with DietPi, not Roon.

In our attempt to improve security on users systems, we rolled out the RoonBridge service with its own user “roon”, which had access to audio and DietPi groups for userdata only.
This works fine as an endpoint, however, the remote update will fail, due to insufficient permissions available to update the RoonBridge binary.

I apologise for this.

This is fixed in v6.18 by allowing root access to the RoonBridge service, required for updates.
The release has been delayed longer than expected, due to RL priorities and extended beta testing.

v6.18 will be released this weekend.

In regards to Allo images, the issues with O!MPD are also resolved in v6.18:


If you are having an issue, outside of O!MPD with the Allo GUI images, please email me directly daniel.knight@dietpi.com and I will investigate.

3 Likes