Roon Bridge on Linux OpenSuse Leap 15.2 - Firewalled

Roon Bridge is installed & running OK, and I can see the DAC in the volume section, but the Roon core on another (windows) machine can’t see the OpenSuse Roon Bridge.


Anyone know how to allow Roon broadcasts through the firewall? I can see a heap of External protocols allowed, but which one applies?

Thank you,

Hi @One_and_a_Half,

What kind of Core are you using, a Windows one? If so, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

The Core lives on (another ) Windows LTSC machine. Defender has Roon.exe and RAATServer already entered for inbound, and I added outbound for private networks.

The Core cannot see the Opensuse workstation, but can see another (and everything else) Windows 10 [2004] PC with its DAC is visible, as well as a Lumin U1, which there’s nothing to setup on, works right out of the box. I can select any of these zones to play on and Roon works OK.

To allow services to pass through the Opensuse firewall, they must be listed first. I can see roonbridge.service is running using the [sudo service --status-all] command, but now to find out how to add the roonbridge service to the firewall list to allow it through.

The whole idea is eventually to setup a simple PC with Linux that can emulate the functions on a Lumin U1 (mini) on a Roon Network. From the experience so far, it’s not simple with Linux other than to install it in the first place. Setting up Linux from scratch is not a trivial task. In particular, the built in drivers for the laptop hardware is far from optimal, where the previous windows build was a lot more responsive albeit with a larger overhead, go figure. I thought OpenSuse being controlled by a company would have yielded some better results over a community type distro, but Linux, the way it is will be only on very small amount of desktops, since it’s such an ass to setup.

Will persist.

Documenting the changes for future and however is silly enough to use Opensuse & Roon.

Well, the roonbridge service was added:

In YAST, set firewall to Permanent instead of Runtime.
Add the [roonbridge] service (was a very very small + icon bottom LH corner
Add the ports from this post for Roonbridge, thanks to @japhet_martinez for the ports to open:

TCP/IP Ports 9100-9200
UDP Port 9003
TCP/IP Port 52667
TCP/IP Port 52709
TCP/IP Ports 63098-63100
TCP/IP Port 49863

After restarting the firewall, then adding roonbridge service to the public and home locations, Roon Core and the other windows PC could see the DAC connected to the OpenSuse workstation, hurrah!

I could hear the click from the DAC, but no sound. Tried another DAC, both USB and not a peep.

The detection of two DACS is working for Roon Core, but the local ALSA is not working, so driver problem.

Linux is an ass.

Hi @One_and_a_Half,

Perhaps these threads help?

I’ve also moved your thread to the #tinkering section since we don’t do any testing with Opensuse.

There existed a closed loop whereby a reboot and setting up one of the DACS (to configure) from YAST and the standard audio setting had no sound cards, on rebbot it reset the config.
I’m not putting up with round circle routines, and as ALSA programming, come on, no user should undertake this.

So the Opensuse install was blown away, and Windows 10 re-installed. Need to say snappier reposnce even on Chrome, and hey, UAC2 works as well as ASIO for both DACs selected, out of the box local and from Roon core. Like it should be.

Bye Linux, never again, nice meeting you, but no marriage!

I reread the above posts, but still don’t get why you wanted to use Linux. Avoid Windows (license cost)?
Why not use ROCK?

Sorry to hear that your tinkering with Linux didn’t go so well. I will say that openSUSE seems like an unusual distro choice. Roon Labs say that they have tested their Linux installers on Arch, Fedora, and Ubuntu. I’m curious to know what led you to try openSUSE instead…

Opensuse is supported by a company, has a lookalike desktop to windows, and their setup tool is more GUI than CLI was the main choice. The style of desktop can be customised extensively, I didn’t use this feature, but tinkerers would like it.

I’ve had Ubuntu on a very, very old 32bit laptop, Asus W2J, the layout never grabbed me. I don’t think it could install Roon, 2GB RAM a bit of a problem, only good for router setups and general network debugging now.

There comes a point where if it proves too difficult, then it is… difficult, no point to flog a dead horse.

Oh, with Linux lower overhead it would reduce processing and hence noise. There is a balancing act as to a how much to turbocharge a CPU and OS and keep the application process minimal. I thought to brew one myself. Did not consider ROCK just yet, needed to achieve the essentials first, but it hasn’t happened, so status quo remains.

Is this a general-purpose machine, or a dedicated Roon endpoint? If the latter, why do you even want to run a desktop environment?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.