Roon Bridge uses wrong sample rate (Ubuntu/Roon OS). A reboot of the mini-PC running Roon Bridge corrects the issue

Roon Core Machine

Ubuntu 22.10, Roon Server version 2.0 (build 1160) earlyaccess (Hyper-V, Intel® Core™ i5-10210U, 8 to 16 GB (Dynamic))

Networking Gear & Setup Details

FRITZ!Box 4040, USW-Lite-16-PoE, NetGear GS105PEv3, GS108Ev3, GS108Tv2, AmpliFi HD (x3), all ethernet, no vpn

Connected Audio Devices

Squeezebox Duet/Boom/Touch (SPDIF/Analog/Speaker), MeLE Quieter 3Q (Ubuntu 22.10, Roon Bridge version 1.8 (build 1125) stable, HDMI)

Number of Tracks in Library


Description of Issue

Quite often Roon Bridge on the MeLE Quieter 3Q (Ubuntu 22.10, Roon Bridge version 1.8 (build 1125) stable) uses the wrong sample rate, music is played too slow (choppy, like drone music). If I reboot the MeLE Quieter 3Q everything is back to normal.

Hi Dennis,

My apologies for the slow response.

I checked and it looks like your core is reporting to us in real-time as expected. Can you get me a date/time/track played example of the choppy music you’re hearing? I have some preconceived notions of what I am going to see when I look at diagnostics logging but I want to confirm them and perhaps provide some next steps for you.


Hi @Wes ,

I think I haven’t encountered this issue after I changed the value of default.clock.rate to 192000 in the pipewire.conf file. (192000 is the samplerate I configured in Roon too.)
I changed this file on 30 November, so maybe it’s visible in log files before that date. It always happened after Roon hasn’t been used for a longer time, something like 12 hours. I assume it’s resuming from suspend or something, but I’m pretty sure I’ve disabled suspend.

Hi @Dennis_Mutsaers,

It sounds like it’s working as intended now though right?

It takes some digging to get specifics within logs without specific time stamps.

If it’s working let’s not poke the bear right?



That’s fine by me. :wink:

1 Like

Happy holidays to you and yours, Dennis.


Same to you, @Wes !

1 Like

Morning @Wes ,

It’s back :cry:
I’ve removed Ubuntu 22.10 and installed Roon OS 1.0 build 256. Started a radio station around 07:37 AM (UTC +1) this morning, which sounded like music from outer space. Streaming or local music doesn’t make a difference. I have to reboot ROCK completely to be able to play music normally again.
It’s a bit the same behaviour as with Ubuntu 22.10 before I made the edit to the pipewire.conf file.

Edit: the same issue occurred around 01:53 PM (UTC +1)

Hi @Dennis_Mutsaers,

Unfortunately, I am limited in my knowledge of your setup but here are some things I tracked down in the diagnostic logging.

There are /snap/chromium/ errors coming from your core so it looks like there are some issues with dependencies.

Other errors related to /snap/snapd-desktop-integration are present as well.

Aside from these two errors, there are general socket exception and connectivity errors too.

Here’s the oddest one from the diags and I don’t see what device the .34 internal IP is.

12/23 10:09:11 Trace: [roonapi] [apiclient] CONTINUE Subscribed {“message”:“No Cloud Access\nAccess to the cloud backend is currently restricted to supporters.\nTo give your support you can Buy Me a Coffee via the link above.\nPress Settings to request access via your Supporter Email Address.”}

I do see some access timeouts for caching too.

I am hoping that some of this information can help because I only have general suggestions (network restarts, clearing the image cache, and pointing towards addressing Ubuntu dependencies). Let me know if it helps. If not, I’ll be back in the office on Tuesday and can bring this to my development team.

I might also invite you to post in our Tinkering group to see what our other users might have to offer. From what I can see, this might be a VM and a VM would introduce some unsupported elements to your setup that Roon support cannot account for.


Hi @Wes ,
.33 is the roonserver, that has no problems.
.34 is the vm running roon extensions
.35 is the mini-pc running Roon OS 1.0 (build 256) production that has the problem. I removed Roon OS, installed Ubuntu 22.10 again and edited the pipewire.conf file as previously mentioned. That solves the problem.

It may be of interest for the team that creates/designs Roon OS that Roon OS 1.0 (build 256) production behaves this way and how I created a workaround on Ubuntu.

Hi @Wes
Unfortunately the problem resurfaced. I tried to play a track this morning at 06:54/06:55 am, but failed (device:quieter3q,
Rebooted a 07:02 am.

Hi @Dennis_Mutsaers,

Thank you for getting back to me.

Is this happening in one or ALL zones?

What happens if you turn on DSP and upsample?


Hi @Wes ,

I already configured upsampling for all zones, hoping this would be a workaround for this issue. However this doesn’t make a difference. It’s specific to ONE zone, a mini-pc running Ubuntu/Roon bridge.