Roon cannot acces NAS storage anymore

My Roon stopped working 2 days ago, It Runs on a Mac Mini with SSD and the music files are stored on a Netgear ReadyNas 314 (running SMB only)
I had a short power outage, Mac Mini and the NAS are on a UPS but the switch is not. So after power was back up again I had to reboot to the nas because it was on a wrong IP adres, After I rebooted the IP adres was back to normal but Roon was extremely slow and reported that the Network was disconnected. (Only Tidal was visible no own files) But network was/is not disconnected. I can access all nas data without any problems using Finder but Roon does not see any data and even worse as soon as Roon is starting up the finder also looses all access to data. I cannot unmount any shares as long as roon is running. If I close close Roon I can either unmount the NAS volume and mount again or just wait a few minutes and than all access is back to normal.
In finder the nas is visible as “NAS4” but I have mounted the volume using the direct IP Adress, also in roon I use the IP adres and guest credentials which do not require a password.

Any suggestions how I can fix this?

Have you gone into roon settings storage and demounted and mounted the NAS share?

Hello @Eric_Peters,

Seems to me that the power surge may have affected all of your equipment here. I would try the following (in this order):

  • Exit out of Roon
  • Reboot your Router
  • Reboot your Switch
  • Reboot your Mac Mini
  • Reboot your NAS

Does that help with anything? Can you please also post a screenshot of your Roon Settings -> Storage tab? It should look something like this:


I have tried the shutdowns and restarts without success.

I posted a shot of one of the screen versions. Please note that I also tried select the nas folder with entering the IPadres. When I use that I can select the folder and after a reboot Roon will start; but at a certain moment (between 60 and 1100 tracks added) it will stop completely and the only thing left to get the computer going is a force stop of Roon which will say the following line in the error report: “Network mount: (smbfs) became unresponsive after 1s for 1-3s blocking thread 0x15b6”

Also tried to select only sub folders of my main music folder and if it was a small folder it would work but slow. If I tried to add another folder it would stop completely again.

Because Roon completely got unusable I have deleted the network entries in the storage setting. But the only way to do this was using the finder to browse to:
…\user\library\roon\database\registry\storage and move the files located there to trash.

After another force stop, I have added an old USB2 external harddisk and used finder to copy all Music files from the NAS to this HDD (this works without error but took almost an entire day) When I select the folder on the USB disk, Roon scans, analyses and imports without problems. But this is not the way I want to have this configured.
It looks like there is a mismatch between the way MacOs and Roon handle SMB which causes the lockup but this has only started a few days ago. There has been a hotfix update in the NAS recently but there were no changes in the protocol or security in this hotfix. The macos version (El Capitan) has not been updated at all.
I also have changed the HDD in the Mac Mini from Hybrid to SSD a month ago, and the first few weeks everything was much more responsive … up until now.

One more note which might be related: If I go to the File sharing in system preferences, I can add another share, but when I select the Music folder on the NAS drive it WILL NOT appear in the list, doesn’t matter how often I try or if I use the “NAS4” name or the IP .

Hey @Eric_Peters – can you give us a few more details here? Do you get an error? Was this working before the power outage?

We can dig in on this a bit more, but nothing has changes in Roon’s SMB support, and if you’re not able to access this drive in macOS’s Sharing settings, I suspect you may want to check with Netgear, and see if they have any ideas about why this is happening, since that appears to be an issues with the NAS and your OS, as opposed to something related to Roon.

You might also try creating a brand new share on the NAS, moving your content there, and trying to mount the new share in Roon. Either way, let us know exactly what you’re seeing and what Netgear has to say, and we’ll make sure we get this resolved for you.


I have never tried that before the power outage, so I cannot say if this was working. If I try the same thing from my (Mojave) Macbook it will work, so I suspect it is more likely that something is wrong on the Mac Mini instead of on the NAS. The latter works fine with every other thing I use it for.
If I try to add the share from the Mac Mini (MacOS Server, El Capitan) nothing happens, no error message, just nothing. I can select the folder but it just does not appear in the list of shares.
I already have tried to rename the share without success, copy ing all music to another share… it is about 1TB of data and duplicating that wil almost max-out the NAS and take a lot of time.

Apart from the inability to create a share accessing the NAS from the Mac Mini directly through finder does not create any issues up until the point that I start Roon, a couple of seconds later the finder access to the NAS also goes dead.

Please note that I have an IT background so I already have tried a lot of work-arounds (and maybe too many) so instead of keep on trying and trying to solve this, I think it is cheaper for me to buy a NUC and install Rock. I could probably solve this issue after maybe some fresh installs and a lot of trial and error but that will ask too much of my patience. So unless someone has a real suggestion which is worth while testing, I will wrote off my recent SSD invest on the Mac and Purchase a NUC, all-tough I rather would spend the money on a lifetime Roon license.

Hey @Eric_Peters,

Thanks for the clarification here. Since it works fine on your Macbook but not the Mac Mini, I would kindly request for you to check any firewalls you may have in place blocking Roon.

You can use this link ( as a guide and I would make sure that Roon is allowed through any other firewall blocking software such as “Little Snitch”, “Bullguard” and McAFee if you are making use of those as I have seen updates to AV software cause similar issues.

If Roon is already added as an exception to the OSX firewall list, it may be worth checking what the behavior is like by removing it and re-adding it to the exception list. I’m also wondering if this security setting could be causing some of this behavior (

Please let me know if any of my suggestions help.


I have no firewall activated and no anti virus installed. I only use a separate external firewall between local network and internet. I have swithed it on- and off again just to reset it’s settings. I also executed the other command but have not been able to test anything further because I’m traveling for work this week. Let you know later.

[edit] All of these have not changed anything, I’m not going to waste anymore time on this. It has worked for over a year, something broke somewhere but I cannot figure out where. I just ordered a NUC so now I’m only hoping that a NUC-ROCK will perform better.

1 Like

So I’m now reaching the point where I’m about to throw everything in the garbage…
I just spend 500 Euro to get it going and still no succes: bought a NUC, Installed Memory, Installed SSD, Updated Bios, Installed Rock, Got ROCK running and accessible through webinterface. Was able to connect to the Roon core from one of the clients, restored the database, and now agin I’m stuck for a couple of hours.

Roon asks me to login, even after multiple tries without error to restore the databes. And when I enter my credentials it doesn’t login and keeps stuck in “Inloggen”

Rock seems to be running but just does not let me use it.

very very, frustrating

@Eric_Peters Sounds like the issue might be related to your db that you restored, as a test can you try a fresh start without restoring your db?

It looks like Roon has issues with my network, so not the NUC but the software.
I did a database reset and also had issues: I came through the login screen, selected the music folder without problem but roon dis not start scanning, also not after a forced rescan. I was able to authorize my Tidal account but also no Music shown.
Next to that I see No audio devices at all (and all 7 are live on the correct subnet)

[edit] I added the USB drive which I used to backup my music and also this time I could select the folder containing the music but no music at all was scanned.

[edit2] I did another database reset from the web interface and restarted. Now I came through the setup screens if I skipped adding music. After that I added the music folder via the settings/storage screen. Every thing seems to be working now but scanning is very, really very slow. On my Core duo Mac Mini it would take a fe minutes to scan 60000 tracks and now It scans less than 200 tracks during 115 minutes. The audio devices are visible.

[edit3] after a another core reboot, it seems to be scanning and adding tracks at normal speed now. So, now I have my music… any possibility to get all the customizing work that I did previously in Roon (added album art, combining split albums etc.) back without braking the system. For instance can I copy part of the old Roon database from the Mac Mini to the Rock?

Hello @Eric_Peters,

There is no way to copy just part of the database and add it to Roon, it would have to be an entire backup that is being restored. I will discuss with the team what can be done here but please keep be aware that it may take some time for the team to get back to me regarding this request as it is the holiday period. Thanks for your patience here and I will be sure to let you know once I hear back from the team regarding this request.


Recovering the manual added album art (even if it is just the picture files) would be enough. I didnlt do a lot off tagging, next to that I also fixed quite a few broken album and artist names but most of these were old MP3 rips which I tend to exclude from the library most of the time anyway.

On a positive note: the response time, and as a result, user experience with the I5 NUC is much better than with the old Mac Mini

Hello @Eric_Peters,

As far as I know it is not possible just to extract the images from a Roon backup but I have forwarded your question to the QA team and I will let you know as soon as I have a response available for you here.


Hello @Eric_Peters,

I have spoken to the QA team regarding your request and unfortunately it is not possible to extract images from a Roon Backup, you would have to restore the entire backup to access the saved images. If you by any chance have older backups that still contain a majority of your image files or edits, you might want to try restoring the older backup and see if performs as expected. Apologies I don’t have better news for you here.


I still have the entire old database installed on my mac mini, i’m just not using it because i can not access the music files from that instaall.

Hello @Eric_Peters,

If you wish to go back to your Mac Mini, I would suggest adding your NAS again by IP address using these instructions and this additional guide.

All the images for your database are stored in the Database Directory/Core/(database id)/images_1 folder although please note that they are compressed and not labeled as they are intended to be used only from within Roon.

I think the issue here might be that the power outage affected your NAS, I would suggest running a disk check on your ReadyNAS to verify that it is operating properly.


No, I don’t want to go back to the Mac Mini.

I’m asking if somewhere on the file structure, what it think is the database ,on the Mac Mini, I can find the album art image files??
That database on that Mac Mini is corrupt from a connect to NAS point of view but it still contains the proper album art, well at least the last time I used it.

The last time I closed the Roon server on the Mac Mini, It would work if I accessed the music files on a local USB disk.

Hey Eric,

Unfortunately, we’re not able to really give insight into the structure of the database, or how/where images are stored. The structure of the Roon database can and will change in the future, and generally speaking we don’t want people making changes or interacting with the database directly – we’ve seen people mess up their Roon install this way.

Sorry for the trouble, and that we’re not able to give more insight here.