Roon cannot access Synology NAS after upgrade to DSM 7

My Roon core in on a Nimitra PC (Windows 10). My music files are stored on a
Synology DS218.

I’ve been using Roon in this setup without issue for last few years. Last night I downloaded and installed the DSM 7 update to my NAS and my Roon Core can no longer access my music files on the NAS. Qobuz works fine. I can see all my Qobuz albums in Roon and they play fine. I have tried to add a new network share without success. I get a “NotAvailbale” error.

Note, all my other music playback programs work fine. My Lumin X1 can stream without issue from the NAS via the Lumin app and Minimserver, which is installed on the NAS. JRiver also works fine and can access my music files without issue. Roon is the only playback program that will not connect to my NAS.

I have checked permissions settings for shares in DSM and everything seems fine. Obviously there is a setting somewhere that has changed with the install of DSM 7.

Any suggestions would be greatly appreciated.


You’d need to study this thread:

Thanks for the reply, however I believe the fix you are suggesting is for those who run Roon on a NAS. I run it on a Win10 Pro pc and my music is stored on the NAS. For whatever reason, Roon will no longer access my NAS. Every other device in my home can access the NAS. I can stream music from my NAS via Lumin no problem but Roon will not connect. I’m assuming something changed in DSM 7 that now requires a setting on my Win10 Pro pc to be adjusted. Every other Win 10 Home pc and device connects no problem. The one with Roon will not.

I had to change my Synology admin account after dsm7.
In Windows I had to change my Windows credentials as in the picture. Text is Dutch but you can see the pictures in English.

I checked windows credentials and the fields are not empty. I can see my credentials are correct. Pw, network address etc is as it should be.

Issue resolved.

Synology DSM 7 does not support NTLM v1 out of the box. There is a setting in DSM 7 under File Services → SMB → Advanced Settings → Others where NTLMv1 authentication can be enabled. This fixed the login issue with my Nimitra server. Once enabled, Roon was able to log in to my DS218+ and connect to my shared folder without issue. Tip came from Windows X, the creator of Fidelizer and Nimitra.

1 Like