Roon cannot enable AirPlay endpoint for Airport Express A1088 - Wrong password error

Hi there,

I have a MacPro 2013 on Big Sur running the Roon core. I wanted to stream music over AirPlay to an old Airport Express (A1088) but I can’t make Roon accept the airplay password for the device.

Screenshot 2020-12-24 at 14.38.26

All other macs at home or iOS devices in the network can airplay into it without a problem with the same password.

The nework is on an Eero mesh system. Macs are on the gateway eero, Airport Express is wired via ethernet into another Eero node.

I’ve reset the Airport Express couple times and tried different passwords. All other apple devices are happy with it but I can’t make Roon enable it as an endpoint. It keeps saying wrong password.

Screenshot 2020-12-24 at 14.31.19

Could you please let me know if there’s anything I can do to enable this device as an endpoint?


Does the AE show up in Settings>audio?

Yes, it does. I click on “Enable” and it asks for a password of the AE. Then it rejects the password that all other Apple devices accept.


Have you checked to see if there’s an update for the AE? I assume you’re using Airport Utility to manage the AE.

Yes, using a very old Airport Utility version (v5.6) as anything newer cannot configure an AE this old.
AE has the latest firmware (v6.3) that I believe is released for A1088.

Screenshot 2020-12-24 at 17.03.14


Any chance your Firewall is an issue? You might turn it off to check. Any antivirus software?

I’m not sure about Firewall. It’s literally wired into the same network, all other network devices can see it. Mac that’s running the Roon core can airplay into it, as any other wired or wireless device in the same network. Roon also sees it as it sees other devices in the network, it’s just that it doesn’t seem to relay the password correctly. Roon can stream AirPlay into newer devices. I have a HomePod Mini that works just fine. But not this AE unfortunately…
This feels like either the APIs Roon support has moved on, and they basically have dropped AirPlay support for older AE devices running v6.3. Or there’s a bug in the code for this handshake.

Eddie Express is the AE in question.


Is the name of the AE the same in Roon as it is in the Airport Utility? You can check in the Airport Utility in the Airplay section.

Indeed it’s the same.

Hi @Yargi_Erel,

Are there any special characters in the password?

If you change the password to something else and try again is there any change?

Hey @dylan,
Thought similar and tried complex, long and simple short passwords. The latest one I set is 12345678 just to make sure it was basic and alphanumeric. Still didn’t work with Roon, other devices made it work.


If you were to plug the AE into the gateway would that make a difference? You currently have it connected to a node correct?

Tried this as well. Nothing has changed. In all configruration that Airport Express is within my network, all Apple devices can Airplay into it, Roon just can’t pass the password prompt.

Are you using Airplay 2? I assume you are. I wonder if you were able to download Airplay’s earlier version if that would help?

As mentioned this is an older AE and it’s latest firmware was released 10 years before Airplay 2 was a thing.

Appreciate the help, but I think we have now exhausted trying out different scenarios that I am not after as an end result, even if they work. So it’d be great if Roon Devs get involved and take a look soon.


I agree however I meant Airplay on your MacBook Pro.

Roon core is on a Mac Pro that is running Big Sur, and I think Airplay 2 has been brought to Mac since High Sierra. I’m not willing to downgrade my operating system for this, if this is what you are asking.
Roon should be the party to use the Airplay API available in the operating system to make it work, as the Mac Pro itself has no trouble playing into said AE directly as is.

Can’t blame you. I wouldn’t either just thinking out loud. Hope you get some help from Roon.

1 Like

Hi @Yargi_Erel,

Can we please ask that you reproduce the issue, note the exact local time + date of the password failure and then send us a set of your Roon logs for review by using these instructions? Perhaps there will be some additional clues in logs.

Hi @noris,

I just bought a newer model Airport Express (A1392, latest one they supported until 2018) and replaced the old model. This seemed to have solved the issue. I left the Airplay credentials empty for the new device and Roon managed to deal with that. Now it connects and Airplays into the newer device.

If you guys still need help to see if you have now dropped support for those older AEs, feel free to reach out as I still haven’t discarded my old device. Happy to help.


1 Like