Roon cannot find an album, which is stored on my NUC's SSD

Roon Core Machine

Library is on internal 2TB SSD. I also use Tidal for streaming.

Networking Gear & Setup Details

ISP modem, Meraki switch, Silent Angel Bonn N8 switch, all ethernet cables

Connected Audio Devices

Sotm SMS-200 Ultra neo streamer, ethernet in, usb out in Aqua La voce S3 DAC

Number of Tracks in Library

14000 tracks

Description of Issue

I cannot find an album in my library, that I played before. That i see it is on my SSD, but Roon does not find it, no matter the key words used in search. I tried deleting it from the library and re-adding it. It appeared on last added for a split second and dissapeared again, and still cannot find it.

I am worried this happens to more albums.


Did you try to delete the album, then “Clean up library” and then add the album again? Maybe it helps…

If you know it is in your library, try using the Filter option on the Album page. If I want to find content in my library only, it works faster.

Does it not show-up then in the “Recent activity” section of Roon’s Home screen?

I played it some weeks ago. Is not in recent.

And filter does not find it.

Maybe the time has come to share some details about the album (like it’s name, a screenshot showing it in its storage location, …) to help others who want to help you.

Just to provide this information here if needed as things so far don’t look clear to me:

Larry Heard - Sceneries not songs vol.1

I have already tried a rescan. I deleted and then re-added the album. It is not in skipped files. I checked everything that FAQ before posting this.

Searching by name of the artist shows some other albums I have in my library but not the one I am looking for.

Note: Vol. 1 is possibly wrongly marked as duplicate of Vol. 2 and hidden?

Update: Looking again at your screenshot, we can’t read the album name there, but there seems to be only one and the Vol. 2 album is listed as “In your Library” so that must be it. Check and correct the metadata if needed and/or re-identify the album correctly and you should be set.

Cannot find it by path, with filter option.
I re-identified the Vol.2 album. There is still no vol.1

As I already wrote, there is only one folder visible in your screenshot. Which album is that? Vol. 1 or Vol. 2? Something else? What you write doesn’t make sense to me.

The way the folder is ordered shows you only the album I am missing - Vol.1.
The album that is not missing is not in the screenshot. Why should it be? I see it in Roon, I can find it on the SSD - that is Vol.2.

Because I would have expected that Vol. 1 and Vol. 2 are both in the Larry Heard folder. So the paths for the two albums are different and possibly something is “wrong” with the path for the missing album. Previous issues with albums not showing in skipped files and Roon were related to path issues (special characters, spurious trailing spaces, unicode issues specificaly with MacOS X). Try to troubleshoot in that direction then.

I finally found it. It was hidden under another Larry Heard album, the metadata was messed up. I re-identified it manually, and now I have it again. Very weird.
Anyway, problem solved. Thanks for the tips.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.