Roon CANNOT FIND any of my devices

Roon Core Machine

Apple MacBook Pro OS 12.6 & Apple iPAD iOS 16.1.1 using Roon 2.0

Networking Gear & Setup Details

Both Wired Ethernet and WiFi

Connected Audio Devices


Number of Tracks in Library

LOTS, Thousands

Description of Issue

I went back to using ROON today after receiving your Black Friday special.
I updated the APPS, One APP kept coming up and saying Not Compatible with this device on my MacBook Pro. I started the original ROON APP I had, No Issues It played like it always does for 4- 6hrs then quits. I quit the Roon APP upon starting the APP AGAIN it comes up and says this APP is Not Compatible with your device. WHY?? I find the right APP and each time I start the APP, it request me to join TIDAL again, yet I just did that, and I get no Devices Found and all I get is the Blinking Speaker.

I download ROON ARC and all I get is SYNCING with Roon Core for the first time, continuous circle going round and round. (I don’t have a ROON Core do I?? Isn’t that the storage device by ROON?

I guess I can’t use ROON ARC, that’s ok but why isn’t ROON 2.0 working, WHY can it not find any of the NAIM MUSO devices? Nothing but the Blinking Speaker? This ROON APP is seriously Flawed, both on the MacBook Pro and iPad Pro 2nd Generation It has been over 10 minutes, I’m still only getting the blinking speaker. Nothing Works?

Let’s get a few things out of the way, so that we can then focus on the real problems:

First of all, hundreds of thousands of people are using Roon without issues, it’s not flawed. There are obviously problems in your setup, but most likely they are not generic. We just need to find out what the problem is. Keep calm and help us, and we will get there :slight_smile:

Second, forget ARC for now. If the basics are not working, ARC won’t work. This is not essential, we will revisit it later.

Third, what do the Black Friday specials have to do with this? Which specials did you buy?

Fourth, yes, you have a Roon core. Every Roon setup has one. It is an essential part. However, the core can be integrated into the main Roon app on your MacBook. This is probably what you are using. The core can also be separate and can run on a different machine. One such machine is the Roon Nucleus, which is what you were thinking (“the storage device by Roon” - it’s not just a storage device)

Ok, now to the real problem:

Unfortunately, your description did not make it clear what is happening, exactly. Please describe each step that you are doing in more detail and show us screenshots of what is happening.

1 Like

I also see that 6 hours ago it seemed to have been running, although with Tidal issues:

Was this before or after you did the update, and has it become worse since?

In addition, I see that you had a frequent “stops after a few hours” issue already in the past, but it was never resolved because you didn’t answered the questions asked by support. This means that there was always some problem in your setup. The new one may or may not be related, but we may well have to drill down to basics, so it may need some time and definitely your collaboration.


If your willing to help, that’s great, but I do not need the attitude, especially when I am frustrated.
Thank you!

Using a MacBook Pro OS Monterey & iPad Pro 11" iOS 16.1.1

I had used ROON for 6 months approx before quitting just under a year ago, because yes it was flawed with my NAIM system (MUSO & MUSO QB) YES, I know thousands of people use ROON, that’s why I started it over a year ago! I have been back and forth with Tech Support a year ago trying everything, but most I could get was 4-6 hours of playing time before everything quit playing.(But at least the APP worked) I had to quit the APP and restart the NAIM devices by pulling the power plug on them in order for the devices to be reconized.

So now year later, maybe less, I try ROON again on their Black Friday $2.00 for three months deal.
When updating the APP’s on the devices, I received a message saying that this version of the Roon Software was not compatible with my MacBook Pro OS Monterey. I then started using the older APP with was still running in the background. When the NAIM quit playing I decided to quit the APP and start again. This is when the problems began.

I am using a NAIM MUSO and QB which from what I am told by many a NAIM dealer they are NOTORIOUS for BAD Streaming Connections!!!

I installed the Latest APPs both on a MacBook Pro and a iPAD Pro
The One APP on the MacBook Pro was saying it’s not compatible with my system. That messages has now gone away.

Every time I start the app on my MacBook Pro, it keeps asking to log into my TIDAL CONNECTION, each and every time. It is not remembering the connection.

Then I get to the Starting Connection APP page and it can’t find any of the MUSO devices (everything is on the same network). So it asks me to push finish, then after doing that all I get is the “BLINKING SPEAKER”, which I said in my original post!

I cannot get any connection between ROON and my MUSO’s, it will not find the NAIM MUSO devices.
Minutes, hours go by and nothing has changed, still the blinking speaker.
Everything is on the same network.

Apple Airplay Works and the NAIM APP Works, but “ROON" does Not!

I don’t know how much clearer I can be?

Thank You

Do we have any other Naim Muso users in the house who could assist here?

@Rob_Hadlow, what model of MacBook Pro do you have (year is helpful)? Can you confirm that you can play Roon to the MacBook Pro speakers? I want to make sure that you Mac firewall is configured with exceptions to allow Roon to see other devices on the network.

You also mention that you have a mix of wireless and wired device connections. Can you confirm that the MacBook Pro Core and the Mu-so and Qb are on the same network subnet (that is, every device has a network address where the aaa.bbb.ccc is identical and only the .xxx is different)?

I am already done, good luck. You wanted help but did not spend a minimal amount of effort on your highly confusing OP, then I tried to structure it a bit so that we can be productive. I asked you for one specific thing and you didn’t do it, instead your first thing is criticizing my attitude. I have better things to do with my free time on a Sunday.

I have a full Naim system though not a Mu-so. Also am a regular on the Naim forum. There is usually no Roon-specific problem with the Mu-so as such, as far as I have seen. Many people use it successfully (including multiroom and grouping). Some points:

  • It does not autoupdate firmware (has to be initiated from the app Settings and availability is not super obvious), so it’s easy to let it get out of date if someone is careless, so I’d check that there aren’t old bugs lingering
  • Random hardware failures were occasionally reported, like for any hardware
  • There is an older and a newer (2nd gen) model, the older one has a poor wifi module so is very recommended to run wired, the Mu-so 2 is fine (with the usual caveats).

Many posts on the Roon forum about the Mu-so, but to see all you must search for both Mu-so and Muso because the first spelling is correct but the other also frequent.

/out :wink:

1 Like

Just to mention, when opening ROON 2.0, it does Not Recognize any of my audio devices.
All I get is the Blinking Audio from the Speaker Picture, as it seem to be looking and looking.

Using a MacBook Pro 15” Early 2020
When I could get into the “Old ROON APP 1.8”, yes it played through Mac Speakers.
ROON 2.0 APP Does Not Recognize Any of my devices as mentioned above, all on the same network.
I can see them on my Network, they’re all listed.

NAIM MUSO Units Play via the NAIM APP and via Apple Airplay.

Naim MUSO (Version 1) via Ethernet directly to the modem.
Naim MUSO QB (Version 1) on WiFi (in a different room)

Using a NetGear Mesh WiFi 6 system.
All NAIM Product and Computer showing on my network, no issues there.

Every time I restart the ROON 2.0 APP, it asks me to relog into TIDAL, it does not remember.
NONE of my Music Devices Show in ROON.

All devices including Modems have been restarted.

I do not know? I am puzzled.

Hi @Rob_Hadlow,

I would like to take a look at your issues. Could you please power on your core and leave it on so that my diagnostics requests go through?

In addition to your mesh configuration, can you please answer these questions?

What is the make/model of your modem?
How is your core connected to your network?

What I AM able to see via our account servers is that you’re running 2.0 on all of your devices now.


Hi Wes;

Core turned on.
Netgear Mesh ORBI WiFi 6
Core would be through my MacBook Pro 15" Early 2020 year via ethernet.
Using remotely with iPad Pro 11" 2nd Gen.

Yes 2.0 on all devices, which is where the problem arose. 1.8 I was able to do everything like before.


Hi Rob,

What model is your modem (not the router or mesh)?

Is your MacBook connected via ethernet to a mesh node or wired directly? Are there any switches involved?

I did see that your core came online. The diagnostics I have now show errors in connecting to Tidal but there are also some critical errors relevant to your database.

There are two potential angles here. Either it’s a problem with the SW/DB or something is keeping Roon from working correctly. I’ll list two potential fixes.

Fix one is to add exceptions for Roon into AV and/or firewall configurations:

I’d also like to see what happens when you start with a clean slate and if you’ll work with me on this, we’ll be sure to honor our Black Friday offer and give you the offer in its entirety. Please test things BEFORE restoring any backups you create so we don’t carry the problem back over.

Here are the steps:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Kind regards,

1 Like

Hi Wes;

Cable Modem provided by SHAW (Canada)
PT #CGM4331SHW No Idea the Brand? Possibly Motorola?

“RAATServer” had four folders names this with various endings.

NO FIREWALL. I changed names to old and reinstalled software.

It worked, after renaming everything deleting software and reinstalling it worked.
I logged into my ROON Account and the computer and and my MUSO devices were there.

Do I know delete the ROON Old folder?

Thank You

1 Like

Hi @Rob_Hadlow

I am glad to hear it worked!

As long as you have the databases and everything you need to make Roon work, yes you may. Just avoid the actual Roon folder we just created!

Enjoy the music, Rob!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.