Roon cannot find my core

Roon Core Machine


Networking Gear & Setup Details

Netgear Nighthawk 7600 Router; Verizon Modem: everything is wired with Ethernet Cat6. Roon iPad is connected by WiFi to Netgear Router network.
Roon app is on (2022) iMac with current updated OS, and also on (2020) iPad with current updated OS. iMac is connected to whole system ethernet network and Wifi also on Netgear Router Wifi network.

Connected Audio Devices

5Terrabyte WD hard drive is connected by USB directly to Nucleus+, Audio endpoint is Meridian 861v8 w/ID41 card connected to Nucleus+ and network by Ethernet.

Number of Tracks in Library

130,000 tracks

Description of Issue

Following an electric service outage two days ago, I have been unable to reconnect with the Roon core. The Roon App has been stuck searching on the page “Choose Your Roon Core” after clicking on the link on that page “Find My Roon Core”. I have tried at least a dozen complete restarts of the whole system and also taken the indicated steps on the “Help” linked page from the same “Choose Your Roon Core” page, all without success. The firewall on my iMac is off. I do not know the internet IP for the Nucleus+ (though I have IPs for the iMac and Meridian processor). Everything else in my house connected by ethernet, Wifi, or internet cable is currently completely fully functioning, except Roon.

Hi Bruce,

You might try getting to the Nucleus’ Web UI even if you don’t know the IP by trying either:

  1. http://nucleusplus

  2. http://nucleusplus.local

Another alternative, is to plug a monitor and keyboard up to the Nucleus+ and it’s IP should be displayed. Additionally, if you do this, you could post a pic of that screen which would help support.

Thanks Dan.

I tried both searches you suggested and each resulted in “Safari can not find the server” results.

Then, I did my best to follow your alternative suggestion with what I have on hand:

Brought the Nucleus+ to my iMac and substituted its ethernet cable connection at the one port going into the Mac: nothing then appeared that I could find on the Mac.

I then used the Lanscan app I have on the Mac to do a port search and it found the Mac plus one item: Elite Group Computer Systems with an IP of Assuming this is the Nucleus+, I then returned the Nucleus to its shelf, plugged it back into the system and then did a scan on the Roon app for that IP.

Still, same result: Roon is hung up “Looking for Your Core”.

What else should I try
Thanks, Bruce

Hi Bruce,

Thanks for trying those suggestions. I have pinged @support to engage as the next steps would have to be handled by them, ( I’m a fellow user, Moderators are volunteers).

Bruce, for what is worth, I have a nucleus core and am having similar issues of connecting my desktop Roon software with the nucleus core. No power outage here. Working fine until yesterday, now with continual problem of connecting to the nucleus core.

Daniel, sorry you are having similar problems. I’m such a music addict that even being cut off from my library and TIDAL for a couple of days is painful. I’ve not yet heard from Roon support, but because the core in my Nucleus has proved inaccessible after a number of key steps it may be because the network board is fried. My audio dealer contacted Roon on my behalf and heard back that the repair would be $800 plus shipping, and after hearing back from Roon support I’ll likely soon send it in for repair.

Thanks much for the update. Sorry to hear that the return is needed

@bruce_nicholson $800 sounds pretty steep. Look around the forums, lots of issues with Roon/Nucleus. Make sure they are giving you a good warranty. I was only offered a 30 day warranty before i passed on the repair.

Hi Bruce, I’m guessing that this means you connected the Mac directly to the Nucleus?
If my interpretation is correct the ip address you saw would be a default ip address provided by the Nucleus network card as there’s no DHCP provided (normally assigned by your router). It sounds like a strange software/network issue if the Nucleus is correctly returning a default address.

I would be inclined to waiting for some comment from @support before you commit to a (very) costly repair.

Hopefully you’ll hear something sooner than later.

David, I have not determined that a return is necessary, but suspect that it will be, as I had indicated. I have not received any communication from Roon support - so I am still waiting…for any assistance they may offer in defining the problem.

Hello @bruce_nicholson ,

Thank you for your patience here while your case reached our queue. Can you please try to connect the Nucleus HDMI output to a TV or monitor, power the Nucleus on and share a screenshot of what you see listed? You should be seeing a diagnostics screen with IP address info and Roon status, but you may not see a HDMI output at all if there are underlying hardware issues, do let me know if that’s the case. Thank you.

1 Like

Attached is the photo I just took of the TV screen after connecting the Nucleus by HDMI. It indicates that it is searching for the internet address. I have not been able to get a connection with the core for 9 days, with the Roon App invariably stuck indicating it is searching for the core.

Hey @bruce_nicholson,

With your Nucleus still powered on and connected to your TV & network please try the steps in this Help article.


Thanks Jamie.

I followed the steps in the Help article. This is a photo of the
TV screen info. It shows the IP address and an admonition, which appears to be accurate. The core is still not reachable via ethernet links to my Netgear router, but when I connected the Nucleus directly to the internet modem, it connected to the core. However, a message came up advising that the core is not connected to a network and no further steps were possible. I don’t know how to change DHCP settings on the router. Is that something you can instruct me on or should I get some other assistance for that?

Not trying to but in but,

This shows the Nucleus is up and running, it is just not getting a DHCP address. Before messing with the router, I would start at the basics and make sure the ethernet cable is securely plugged in at both ends. Then maybe switch to a different ethernet port on the router/switch. After that, maybe switch out the ethernet cable.

Thanks Daniel, I appreciate it as I am not that tech savvy. I switched out the ethernet cable and also switched router ports. Twice, once currently ongoing, the Roon App page “Choose your Core” came up and it showed my nucleus and indicated it was connecting…but then a few moments later went into its “Searching for the Core” mode, indefinitely. Does this tell you anything?

From screenshot it appears that my original guess was correct, your Nucleus is not getting an ip address from your router’s dhcp.
@Rugby ’s recommended checks are a good starting point.

Do you have a firewall blocking the Nucleus or some security device (for example a Fingbox) blocking access to the network?

Thanks Paul. I’ve had the firewall off on my iMac since this issue arose and just checked and it is still off. I don’t have a fingbox (or even know what it is). I use two unmanaged netgear ethernet switch boxes for the ethernet connections, but since set up 4 years ago have not had any similar disconnects with this setup.

Hopefully @noris will see your screenshot post soon.:crossed_fingers:t4:

Hi Bruce,

Go back seven days to my previous post and see if you can bring up the Nucleus Web UI now. Also, take another look at the Nucleus, what IP is it now showing, has it changed from your previous picture.