Roon cannot see my devialet amplifier in devices

Is the IP you have on the dCS Bridge by any chance the same as you get on your Devialet amp? Which device is doing DHCP on your network? Is it possible to do reservations in the DHCP server by MAC address?

@mark_gilligan

Another thought… the dCS Bridge is RAAT and discovery is Roon’s own and different from AIR. If you install Devialet’s AIR driver on your PC (just for testing purposes) and it finds your amp successfully it is a RoonAIR problem. If the amp is not seen by the Devialet driver either, the problem is probably somewhere in your network set up.
I’d guess the dCS might sound better than RoonAIR (or AIR) anyway, but the direct integration of Devialet with Roon is functionally very nice!

I borrowed the network bridge, so I do not have it any more, and cannot check what the IP address was. The DHCP server is my airport extreme wifi router.

I have just spent the last couple of hours trying lots more things.

All the things that work fine:

  • Devialet:

    • Remote app works OK
    • Air from a PC on the network works fine
  • Roon:

    • The apps on PC, ipad and iphone can all fine the core
    • the core can find other devices on the network which are airplay compatible e.g. apple tv, and linn streamers
    • I have already use the core with a DCS network bridge hanging on the end of the same network cable as the devialet is now connected to
    • I have made sure all the server firewalls allow the traffic between the roon and devialet devices

Versions:
- Devialet is running 10.1.0
- Roon core version V1.3 build 242

The only thing that does not work is that the core cannot see the devialet!

I am completely stuck… there is literally nothing else to try… everything works except for roon.

Please help @support :frowning:

Thanks

Mark

This is really weird! The reason I ask about the IP of the Bridge is that Roon remembers that ‘Zone’. If your Devialet happens to get the same IP it can be ignored by Roon as that ‘Zone’ contains config that belongs to the dCS Bridge. If this is true, there are two ways to get around it:
1.: add a reservation in the Extreme DHCP server for the MAC address of the Devialet pointing to a different IP than the one your Devialet has now.
or
2.: Borrow the Bridge once more, connect it and observe that Roon finds it - then in Roon’s Audio setup for the Bridge press the two cogwheels and select ‘Disable’. This should free the ‘position’ so to speak…

I would appreciate @support to confirm or deny that this is a possibility as it is a ‘thin’ straw…

Otherwise, the fact that Devialet’s AIR driver is working from a PC on the same network as Roon is a bad sign for Roon. The possibility of a faulty Roon Core is there of course. Have you tried a reinstall? Maybe use a different Roon installation (the one on your PC) as Core just for testing? Can you see the Devialet from there?
Just to be sure: you are using the same IP subnet for all devices?

Zones have a unique id and the IP should be not used to remember that id.

If you are finding this happens, let us know what the device is so we can check with the manufacturer. This should never be the case and the IP should be able to change freely without Roon losing track of the zone.

At this point I would try:
Remove everything from your network except Roon core, a Roon remote, and the Devialet. Disable any firewalls etc.
If it doesn’t show up, maybe post the ip config for each machine. I would personally scrap DHCP for this test and set all ips manually - even if it’s just temporary (I disagree that DHCP is robust and better than static IPs - it’s easier but can be a cause of problems especially if the dhcp server has become confused or not refreshing or cached or something).
Power cycle everything after setting static ips - including switches/routers.
Then you’ll know exactly where you are, otherwise you may be chasing a problem that isn’t obvious.
If it doesnt work after this procedure, something’s really weird or broken and shouldn’t be too hard to pin down.

Thanks Danny. Good to have this confirmed. Then we can rule out my thoughts re. Roon blocking. I agree with hifi_swlon’s test description. That should clear things up.
I happen to use an Airport Extreme in my own network. I use it in bridge mode so the unit simply bridges wifi and wired which places all networked devices in the same IP range. I also use DHCP, but the server is (now) on my firewall. Used to run on one of the Linux boxes I have. When the Airport is in Bridge mode, DHCP and NAT on the unit is disabled. I suggest Mark should also set his Airport bridged while doing the next test. If DHCP is necessary the WHS should be able to do this.

Hi Mark

You mentioned that AIR on another PC in the network works fine?

Have you disabled that instance of AIR?

I once learned the hard way that having two instances of AIR running at the same time is not a good thing …

I only installed air on the PC for the test and uninstalled it afterwards. There are no air devices on the network other than the roon core.

Hi @mark_gilligan ---- Touching base to see if you have had chance to give @hifi_swlon 's suggestion (:thumbsup:) a go ? Let me know, as I am curious as to what the outcome of that test is.

-Eric

I allocated fixed ip to the core and the devialet, rebooted all and no difference :frowning:

Did you take everything else off the network?
Can you ping the Devialet from the Core machine?
What are the network settings?
Have you tried doing a fresh config for the Devialet? I guess you did if you gave it static ip.
is the Devialet wifi now disabled?

Sorry to ask so many questions, but I feel unless you get right back to basics and report exactly what you’re doing at the stripped down level, it’s almost impossible to diagnose from afar.

Depending where you are and how much you trust people accessing your net maybe someone can teamviewer in and have a look?

Not trying to avoid giving info, but there are so many settings on the server, router and switch that it is not really possible to state everything.

In terms of your specific questions, all devices are pingable from everywhere. So devialet is trivially visible from the whole network including from the core.

There was nothing on the network other than the server, the devialet, and my iPad for a remote.

The devialet only has Ethernet enabled, no wifi.

I created a new configuration for the devialet which has a digital input and optical input and the Ethernet. All else is off.

I honestly get it, it’s tricky to detail everything, but my hunch is the problem lies in one or more of those settings…

If the router can be removed temporarily once Roon has booted up, I’d definitely remove it - if you’ve got static ips then all should still run as it is now at least - you should still be able to ping everywhere. Then you’re down to server, and switch. The Devialet is pretty basic so my guess is that’s not the issue if you can ping.
So it’s the switch or server. Shame you can’t drop the switch out. Even a £20 basic dumb tplink or netgear or whatever would suffice just to allow you to isolate it.
If it still doesn’t work at that point it must surely be a server setting. If the switch fixed it, it would most likely be your switch settings.
In leu of a standin switch, can you backup switch config and factory reset?

Network troubleshooting is a right PITA at times, but you’ll get there…

1 Like