Roon cannot see my devialet amplifier in devices


I have just had an email today letting me know about the native support for Devialet Air within Roon! J this is brill, since my main amplifiers are Devialet Experts.

Anyway, I have just spent the last couple of hours trying to get it to work, and whatever I do, the Devialet products simply do not appear in Roon under settings>Audio.

I have updated all the software on the Devialet (to 10.1.0), and the Roon versions of the core and clients to V1.3 (build 242) (see the Roon screenshot below).

I have proven that the Devialet is accessible to the network by pinging it, and also using the Devialet remote app from an ipad that requires it to be visible on the network. All is visible.

However, after all this, the Devialet amps, simply do not appear within the Roon products. The overall roon setup has already been working very well with a dCS network bridge on the end of the same Ethernet cable I have just plugged into the devialet, so the devialet is the only change.

It would be great if someone could try to explain more about what can be done to diagnose further.



Hi Mark, what do you see under ‘Settings’, ‘Audio’? I have an endpoint that doesn’t appear in that list but is in the audio settings.

Stumped, with the setup you describe on a previously working dCS bridge on the same wire, it’s hard to see where there could be a problem.

Have you tried powering everything down and back on? You’ve definitely disabled/closed the AIR virtual driver?

If you’re on an iPad have you scrolled down in audio settings? It will be at the bottom after networked devices.

Hi Steve,

The Devialet definitely does not appear either on the ipad app or the PC client.

I have not used air before, so there is nothing air related running. It is a clean setup from an air perspective.

argh… hmmm…

I had already had to remove some firewall restrictions to get Roon working in the first place e.g. the core was not visible to anything when I first installed everything. However, that is all fine. So the tests that are clear are:

  • all software on everything is up to date
  • the roon apps can see the core across the network so there are no secuirty problems
  • Roon can see my various airplay compatible devices around the network
  • the roon setup has been working with the DCS network bridge
  • The Devialet amps are also on the network (on the same cable as the DCS was)
  • the devialet amps are visible from the clients and server on the system by pinging it
  • The devialet control app works fine across the network from those same clients
  • air has not been running anywhere, so cannot be blocking anything

The only bit not working is Roon seeing the devialet!

Are there any lower level diagnostics I can run to see exactly what is going on?



You could look in the logs but I suspect it’s not going to be easy to spot even if something pops up there.

I sometimes run the tail command on the current log, and you can watch it while you power up the Devialet and see if anything appears. Support will probably be better in this case though.

The only other thing I can think if is if you have wifi enabled as well - I’m not sure how Roon deals with that. If you are running wifi might be worth giving the Ethernet cable a good click to check its in properly - you may be pinging the wifi! Probably not but I’m very IT savvy, but it’s happened to me more than once! And of course is a lovely quick solution. :slight_smile: (but I’m clutching at straws…)

Hey @mark_gilligan – what exactly did you change here? Have you tried disabling all firewalls completely, as a temporary troubleshooting step? Are the exceptions you put in place there for RAATServer too, or just Roon? You’ll want those configured for both.

Also, can you tell us a bit more about your Core machine and network topology, as described here?

Lastly, I know you said everything is up to date, but can you also confirm the software version of the Devialet?

the devialet version is 10.1.0 as mentioned.

The server is a windows home server 2011 which is based on windows server 2008. The whole network is cat5e cabled to a 1gbit switch. The whole house is in fact designed and built around high bandwidth audio streaming. So the server is connected to the switch and so is the devialet.

There are various ipads and laptops connected wirelessly into the system to be used as remote controllers.

I cannot remember right now what I precisely disabled, but can check the firewall settings later to see.

Ok, I have tried a load more things with the Devialet in terms of minimally switching off almost everything except for the ethernet port (running DHCP), 3 digital inputs and SAM.

None of this makes roon see the amps!

I have also tried completely switching off the firewall on the server where the core is, and the devialet is still not visible.

I simply cannot see what on earth else to change or try.

@support please help! I simply cannot get it working. I would be happy to buy a lifetime subscription if only it actually worked! :frowning:



have you tried setting a manual ip on the Devialet, and usung the same ip that worked with the unplugged dCS?

It will definitely work…

Hi @mark_gilligan ----- Thank you for the report and the continued feedback here, both are appreciated! Sorry to hear of the troubles.

A few things I would like to confirm with you:

  1. Since adding the Devialet amplifier to the chain of communication and noticing this issue, have you tried power cycling all of your equipment? Core machine, endpoints, router, switches, etc?

  2. Based on your posts I see that you have disabled your firewall on the server (:thumbsup:), are there by chance any antivirus application currently running?

  3. You’ve also mentioned the following:

“The whole network is cat5e cabled to a 1gbit switch”

My assumption is that you are making use of an unmanaged switch, by please confirm and also provide the make/model.


Hi Eric,

The router, switch, modem, server, amps have all been rebooted. No luck.

The switch is a d-link dgs-1210-24.

The server, switch, router and modem are all in a server cabinet and the whole house is designed for streaming from the ground up. I have used the system for all manner of servers and streamers for video and audio and never had an issue with anything before.

I have switched off the firewall, but the app and clients for roon can see the core whether the firewall is on or off, since I have set rules to allow all roon traffic anyway. This is from iphones, iPods, iPads as well as pcs and macs running all manner of operating systems.

I really cannot think of anything else to try!


P.s. the suggestion about fixed ip addresses is something I have tried. It did not work either. In fact it made other aspects of the system worse. The devialet remote control app from an iPad/iPhone became unresponsive sometimes. DHCP is more robust. I have been able to use dhcp for all other streaming aspects from all providers in the past.

Hi @mark_gilligan — Thank you for the follow up and verifying that information for me.

If I am not mistaken the D-Link DGS-1210-24 is a managed switch and we have seen a few issues crop up with these devices in the past ( Example: #1, #2, #3, #4). I would recommend enabling flow control on the switch, as we have seen it help other users.


Hi Eric,

I have tried enabling flow control on all ports. Made no difference. :frowning:


Hi Eric,

Is there any way to specifically get roon to look at a particular ip address when looking for devices?


If you have a spare unmanaged switch, I’d try plugging your core, Devialet and router into it to isolate if it’s your managed switch and roon not getting along.

If your router is right there maybe plug the core and Devialet directly into it to test with its unmanaged switch.

I do not have another switch. :frowning:

I simply cannot understand why there is an issue given that I have had the whole setup working with a DCS network bridge already. The only variable is the devialet instead of the DCS.

As said earlier, everything works in fragments, but simply not all together!


Does your dcs network bridge have a gigabit network port? The Devialet is only 100mbit which might be causing issues at your switch if not quite configured correctly.

Igmp snooping, is it off or on everywhere?


did you get this to work?

If not, your amp will tell you which IP address it’s got in one of the menus on it’s display. Can you ping this IP? If you install the Devialet Remote app on your iPad, does it find the amp? Can you control volume with the app? Did you disable WiFi in the Devialet when you enabled the ethernet port?

The remote app works and can easily control the Devialet volume, and I have disabled the wifi so it is only ethernet connected.

It is not working yet :frowning: