Roon 1.2 plays DSD 128, Roon 1.3 version 196 doesn't [Solved, managed switch flow control]

QNAP TVS 882T, with quad core i5 3.6 MHZ, 16 GB RAM, running Roon core to Sonore Microrendu to Simaudio 780D. Under Roon 1.2 DSD 128 files played fine. After upgrading to Roon 1.3 version 196 DSD 128 files start playing, then after a few seconds sound is distorted then playback stops. Then a message "an audio file is loading slowly… appears. DSD 64 files play fine, as did DSD 128 files on Roon 1.2

1 Like

Hi @Andrew_Sew_Hoy ----- Thank you for the report and my apologies for the troubles here. The feedback is greatly appreciated!

Can you please verify for me that there is no “audio analysis” running when you are making this observation with DSD 128 content.


1 Like

Hi Andrew, I encountered the same weird behavior with Roon 1.3. Even FLAC files in 192Khz does no longer play correctly.
First 2 or 3 seconds are ok, and after the sound is hashed. Did you observed same issue with 192Khz FLAC files (in addition to the issue with DSD128 files) ?
Do you use DoP ?

No audio analysis running. I let it finish prior to trying to play DSD 128 files

I get the same behavior as you with 192Khz files. They play fine for a few seconds, then there is hash or distortion then the file stops playing. I use a Microrendu; under RoonReady settings DSD support is set to DoP.
I did not have these problems with Roon 1.2 and did not change anything in Roon except to upgrade to 1.3 build 196 on the QNAP core and 1.3 build 194 on my iPad.

Do you use a Cisco switch between your NAS and the MicroRendu ?
Some reports issue with RAAT on Cisco SG200-08 switch or the TpLink TL-SG108E…
I’m using a Cisco switch but, I’m not at home to check the model…

This could potentially be an issue as the Cisco managed switches in their default configuration can cause some problems (although I’ve only ever had issues with discovery, not actual streaming).

The Cisco SG-100 series switches work great and I highly recommend them, but the SG200 and SG300 series may need some tinkering to get them to get out of the way. I’m using SG100 at the store and SG200s at home with no issues like the ones described.

The odd thing here is that @Pat is able to play 24/192 content using Squeezelite on the same Raspberry Pi hardware. RAAT and LMS hit the network differently so this doesn’t eliminate the net as the failure point.

Do either of you have another device that you could try as an endpoint? Laptop wired to the same network port running RoonBridge would be great. That could confirm or eliminate the network as the culprit.

I use a Netgear GST 716 switch.

I’m using a Cisco SML2008. It is managed, and the LAN port used by the RPI3 with Squeezelite (piCorePlayer) is indicated as a 100FDX Link status. I’m exclusively use Cat 6 or 7 cables.
“Flow control” check boxes are not activated, some reports to set this option ton “on” (a TPLink discussion)…
I’ll do some test this evening with another switch or LAN option (?).

Under multicast setup turn off IGMP snooping under IPV4 and the equivalent setting under IPV6 (can’t remember what it’s called). Check your router as well and turn off multicast / UPnP support.

Also, Roon had to add IPV6 support for 1.3 due to some Apple requirements so I wonder if Roon Bridge is sending out some IPV6 packets that are pissing off the switch / router. This could potentially explain why Squeezelite is working but RoonBridge isn’t.

Hey @brian any thoughts here?

1 Like

I’m not very savvy technologically, but with information from above:
I replaced the Netgear GS 716T with in my network (It’s a managed switch) with an 8 port Netgear GST 108, an unmanned switch.
No other changes.
I can now play DSD 128 files and FLAC diff files 192KHz without apparent problems.
I’ll have to leave it to others to work out what parameters have to be configured in smart or managed switches to get Roon 1.3 to function.
Andrew Sew Hoy

This is very useful information and suggests that the switch (and likely some other device on your network) are conspiring to mess with playback.

Unless you have a need for a managed switch (VLANs or QoS) I would encourage you to dump the GS716 altogether and run with something that’s unmanaged. If the GST108 has enough ports then you’re set, otherwise something like a Cisco SG100-16 works great.

It is possible to configure your GS716 to work, but if you’re not savvy with the ins and outs of layer 2 switching configurations then the easier route is just to run an unmanaged switch.

I guess I’m showing my ignorance but it seems the switch or how the switch is configured is causing the problem, as all I changed is the switch itself (I do realize that weird interactions can occur with software changes) I do not have enough ports on the GST 108, I realize that buying a new 16 port simple switch might be the easiest solution but before abandoning the GS 716T I’d like to know what is entailed to make the managed switch work with Roon 1.3

Hi, I got some advancement in my investigation thanks to a fine tuning on my Cisco switch.
I’ve reloaded my RPI3 with a Unbuntu server 16.04 armv7 on which I installed Roon 1.3 armv7.

192Khz not playing by default. If I activate on the Cisco switch (SL M2008) the option “Flow control” on the port connected to my router, 192Khz files are working. Great!
The “Flow control” on the LAN port connected to the RPI3 does not seem to change anything.
The JumboFrame option has no effect.
I’m still not understand why the RPI3 LAN port is viewed as a 100Mb/s as the RPI3 comes with a 1Gb/s LAN port.
The other good news is that DSD128 is now working too :slight_smile:
Hope this help, but this “Flow control” option is something already suggested in an another thread.

Not according to the specs:

Networking: 10/100 Ethernet, 2.4GHz 802.11n wireless

To make matters worse, al four USB ports and the Ethernet port share 1 (one) 480Mbps bus. This used to cause problems with high traffic flowing on ethernet and USB simultaneously, but driver optimisation has improved this the early days. Since you can plat DSD128 problem free, it appears to be not much of a problem anymore.

Yep, sorry for the mistake, I was sure about the 1Gb/s ^^
Yes DSD128 is well supported now, as said before, many distributions sound now up to date (piCorePlayer, Moode, Volumio).
However, now my goal is to switch to DietPi for a try. I would like a micro-core Linux like piCorePlayer without SqueezeBox. The DietPi thread seems a bit confusing for the moment, many issues reported, not clear to know if these issues are relevant for our own use cases…

Anyway, thank you for the great support of Roon team.

No known issues at the moment – apart from the odd online repository playing up when installing/updating (very rare). DietPi, while not as extreme as PiCore, is rather slim and writes its logs to RAM by default – sparing your SD card and making it practically immune to card corruption when improperly shut down (read: yanking the power cord. :slight_smile: ).

Nice touch: @Dan_Knight, the great mind behind DietPi, has added RoonBridge to the software install menu – making the installation of RB and the required dependancies easy as… eh… well… Pi.

I think I have solved the problem in my case.
I configured my switch through its web interface to enable flow control. (I use a Macintosh so the browser I used was Firefox). I have a QNAP TVS 882T to a Netgear GS716T smart switch then to a Microrendu and then to a USB DAC
I can now play DSD 128 and FLACand .aiff 192khz files in Roon 1.3.
Without the Community’s help I never would have been able to figure this out.

1 Like

You’re welcome Andrew. :+1:
I got myself benefit of the help of the community, a long support chain :wink:
It seems this concern is not only restricted to managed Cisco switches but Netgear and TPLink seems also concerned. I would suggest to Roon team to leave a big mention to end-users in the installation manual…

+1 on the flow control solution. My chain is Synology DS1515+ > wired ethernet 2 port bonded connection (two 1gig ports) > Netgear GS724Tv4 managed switch > wired ethernet > microRendu > Oppo HA-1. After 1.3 install couldn’t play anything over 24/96 or DSD64. Music would start, play clean for 3-5 seconds, then descend into garble, then “a file is loading slowly…”. Checked out several threads here and decided to look closely at the switch. There is a ‘Global Flow Control’ option in the switch software configuration which I found to be set ‘off’. I set this option ‘on’ and restarted the switch. Can now play up to DSD256 without issues. I would note that DSD256 with DSP ‘off’ but Volume Leveling set to ‘Auto’ shows a processing speed of 3.5 (!) - but I knew from the beginning that the DS1515+ would be a processor limited Roon Core environment. Anyhow, much appreciate the forum support.