Roon 1.2 plays DSD 128, Roon 1.3 version 196 doesn't [Solved, managed switch flow control]

Hi, I discovered Roon 1.2 in trial mode few days before the 1.3 upgrade.
I was a user of JRiver as server and a RaspberryPi3 with Moode connected in USB to a PSAudio DirectStreamDAC with no problem at all. The DAC support DSD only in DoP mode up to DSD128. Roon ergonomy and stability seems to me far, far better than my previous setup, so I choosed Roon definitively :slight_smile: .

However since Roon 1.3, FLAC in 192Kbs and DSD128 does not play correctly. DSD64 are OK. In 192KHz, the 2 or 3 first seconds are ok but after I have many drop out during playback. In DSD128 the error message appears telling that “an audio file is loading too slowly…hardware issue…”.
As fas as I remember, I had no issue to read DSD128 with Roon 1.2, but I’m not completely sure while the upgrade occurs during the 2 last days of my trial period.
I believed about a problem with my Roon core server on a NUC (Core I3 1,8Ghz/4GB RAM + 120Gb SSD) under Ubuntu Server 16.10 but I observed exact same behavior with a server running on a MacBook Pro Core i7 (SSD+16GB RAM).
Roon bridge is installed directly on Moode (don’t know which Linux it is but it comes with a Linux 4.4.24 advanced kernel). One again I had no problem to play these files with JRiver (as server) and Moode as renderer before. So I tried to replace the Roon bridge on raspberry by the latest piCoreplayer audio optimized version pCP3.11.
With squeezelite, I can play correctly the 192Khz FLAC files, DSD64 in DoP and for an unknown reason DSD128 are down sampled to PCM 176Khz in 24bits. It is indicated in the audio transformation path in Roon Controller.

I’d like to return back to Roon bridge but for the moment Squeezelite performs better than Roon bridge despite the RAAT
Is it a network issue or a known limitation of Roon bridge on Raspberry in USB ?

Thanks

It the little Pi connected by Wifi by any chance?

If I remember correctly, Squeezelite and Moode pull in the files and do the decoding on the Pi itself. With Roon/RAAT, all decoding takes place on the core and an LPCM stream is sent to the client (RoonBridge). This requires more bandwidth, especially noticeable at higher bitrates.

Hi Rene, thanks, I forget to mention that all my devices (Roon server and Roon bridge) are wire connected to the LAN, no Wifi.

1 Like

Great – that does eliminate a lot of things. :slight_smile:

I’m not sure how RoonBridge behaves on MoodeOS, since it’s optimised for well eh… Moode. You may want to go the DietPi-route on a spare SD card – it’s the best/most efficient way of running RoonBridge on a Pi.

EDIT: Just to add a datapoint: I have a Pi in my main system that is playing PCM192 for hours daily. It is outputting through SPDIF though – maybe (speculation alert!) since the Pi’s USB and Ethernet are still sharing the same (USB) bus, the higher network traffic and USB output are reaching the Pi’s limits – even though that does not rhyme with you saying DSD128 was fine with Roon 1.2. Anyway – if you could try DietPi: let us know how it goes!

Actually, I thought about the same conclusion than you, so I tried to install RoonBridget Armv7 on a fresh install of Ubuntu Server 16.4 armv7 for RPI3. Installation ok, CPU consumption less than 8% if I remember well, but I had exactly the same problems.
I’m very interested by DietPi but the long long thread of discussion about several problem dissuaded me to go further…
Besides that, how to explain that 192Khz files are ok with RoonServer and Squeezelite and not ok with the same Roon Server with RoonBridge. Same hardware, network, …
The Audio transformation path indicates in both case a lossless playback without any down nor up sampling at all.

Yes – but like I said: an entirely different way (and protocol) of sending over the data: the LCPM stream sent to RoonBridge requires more bandwidth, but at the same time places less strain (decoding) on the endpoint. I only refer to DietPi as it’s a proven environment for RoonBridge to run 100% fine – you’ll be up and running in 10 minutes or less. :wink:

The only other datapoint I can offer is my Cubox doing DSD256 over DoP happily with Roon 1.3 – but that seems relevant here. There’s ample Pi’s in use on these forums – maybe someone will chime in with fresh ideas or experiences.

1 Like

I’ll try DietPi, for sure. Great! I just understood that DietPi is headless and can be configured through SSH on a remote computer :slight_smile:
Why the upgrade to Roon 1.3 would require more bandwidth than 1.2?
I’m a bit confident in the fact that I tested successfully the same config in Roon 1.2 to play 192Khz FLAC files. There another discussion on the forum of someone who was able to play DSD128 with Roon 1.2 and can no longer do it with 1.3…

I’ve read lot of similar issues from peoples using a Cisco switch (it’s my case). Not at home to check my switch model, but may be a clue…

Got some good result explained here. The problem seems related to a “Flow control” option of a switch between my router and my RonnBridge.

Roon 1.2 plays DSD 128, Roon 1.3 version 196 doesn't [Solved, managed switch flow control]

1 Like

(repeating my post from another thread) +1 on the flow control solution. My chain is Synology DS1515+ > wired ethernet 2 port bonded connection (two 1gig ports) > Netgear GS724Tv4 managed switch > wired ethernet > microRendu > Oppo HA-1. After 1.3 install couldn’t play anything over 24/96 or DSD64. Music would start, play clean for 3-5 seconds, then descend into garble, then “a file is loading slowly…”. Checked out several threads here and decided to look closely at the switch. There is a ‘Global Flow Control’ option in the switch software configuration which I found to be set ‘off’. I set this option ‘on’ and restarted the switch. Can now play up to DSD256 without issues. I would note that DSD256 with DSP ‘off’ but Volume Leveling set to ‘Auto’ shows a processing speed of 3.5 (!) - but I knew from the beginning that the DS1515+ would be a processor limited Roon Core environment. Anyhow, much appreciate the forum support.

I’ll add some of my experience here regarding flow control. I never had any issues running Roon server on windows, but I struggled with the performance problem when I tried moving my server to Ubuntu. The problem was solved when I turned on flow control for endpoint connections. I thought it was strange that the problem only became manifest with linux endpoints and server, and with flow control turned off on the endpoints. I also would never have figured out the flow control angle without the community here, but there’s something else at play with the Linux combination too. I hope this helps, and many thanks for the help I received!