Can't see my connected devices

When I select an audio zone only option is my Airplay AVR. I’m not seeing my Oppo HA1 nor my Pro-ject S2.
Under Settings>Audio I can see networked devices>Airplay.

I can also see ‘Connected to The Core’… These devices…
Every now and again this flashes and changes to ‘Connected to This PC’ and brings up relevant listing…more like flashes up for a brief instant.

What I have done wrong and how do I fix it?

Roon still not displaying my S2 so I’ve given up and gone back to playing via my Oppo 203 (which Roon has now decided does exist). Worked for about three songs and then froze.

Thanks for the report, @Michael_Blair!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

May I also ask that you verify the following:

  • Since you’ve noticed this behavior, have you tried rebooting your Core machine, audio zone devices, and networking hardware?
  • Is there any antivirus software or firewall active on the Core machine? If so, you can try to disable them and see if that improves things.


Thanks Dylan.
I’m running Roon V 1.5 (build 323) stable 64 bit. The app is telling me I have the latest version installed.
I’m running a Microsoft Surface Book (Intel Core i7-6600U CPU @ 2.6GHz 2.81 GHz with 8 GB RAM. Windows 10 Pro build 1803.
Core is stored on an SSD attached to my Synology DS916+ NAS.
Music is stored on HDD on the NAS, approx. 4500 tracks. Also use Tidal and have around 8500 tracks in my Tidal favourites.
When using the Surface in my study it is attached via the proprietary Surface connector to a Surface hub; ethernet cable from hub to a Netgear Nighthawk S8000 (Model #GS808E)
The NAS is connected to the same switch via two ethernet cables (Link Aggregation).
The switch is hardwired to a though the walls and downstairs to a TP-Link TL-SF1008D switch. This connects via ethernet to Netgear Nighthawk X6. The X6 connects to the modem which links to the NTD where the fibre internet connection terminates.
When using the Surface in my theatre room it connects via wifi. The theatre room is adjacent to the ‘cupboard under the stairs’ where the router live (one internal wall).
Today when I’m in the study using Roon it can see my Oppo HA1. I’m able to play music files form my NAS but not Tidal. Playing direct from Tidal app is somewhat hit and miss too.
No idea what I did with the Pro-Ject S2 but I can see and use that as well. Of course I’ve added it to enjoy MQA files from Tidal thru Roon, not much joy at the moment.
Any clues as to what I’m doing wrong?

Poop, seems I spoke too soon.
TIDAL issue resolved; simply uninstall Tidal, reboot device, reinstall Tidal.
Successfully using my Pro-Ject S2 earlier today in Theatre Room playing music from my NAS. Then took Surface back to study to do tidal fix.
Return to theatre room; reconnect Pro-Ject S2, start Roon and it can’t see the S2!!!
Sees my Oppo as a networked device and currently playing Tidal thru that.
Under settings>audio it shows my Oppo as a networked device and my AVR as an airplay device.
Then, like yesterday I get intermittent flashing of a list of devices Roon is ‘enabling.’

Hey @Michael_Blair — Thank you for the detailed response!

Just to clarify the above, do you experience these difficulties in both the study and the theatre? Or is it exclusive to the theatre?

The Nighthawk switch looks like it may be a managed switch.

I usually like to mention that we’ve tracked a number of issues to in the past to managed switches(examples: here, here, and here).

The simplest way to confirm whether the switch (or its settings) are contributing to these symptoms would be to temporarily test with the switch removed from your network. Whether things improve or not, the results of that test would be a great data point.

I would also recommend enabling flow control on the switch, as we have seen that settings resolve a number of issues for other users in the past.

Are there any active antivirus or firewall on the Core machine? If so, try disabling them and see if you experience the same behavior.

In the past, we’ve seen that some have had success using Google DNS to improve their TIDAL experience. Try following the instructions in that link and see if the experience improves.


In terms of Roon not seeing the S2 this happens in both the study and the theatre. In the study I have just noticed that when my Oppo HA-1 is connected Roon recognises my S2. Strange indeed. HA-1 connected via USB to Surface hub.
The switch is not a managed switch although does have some features of amanaged switch. I’ve turned off IGMP snooping. Not expecting this will solve my S2 connected via USB problem but it hasn’t had the desired effect on being able to play Tidal thru Roon either. I’ve left it for now and will try again in coming days. I’ve enabled flow control on the switch; to no effect. Firewall and antivirus on my NAS (where core is attached on an SSD) are disabled.
Whilst flow control has been enabled I can’t enable for the NAS ports (as they’re trunked). I might try this later. I haven’t tried Google DNS but may do so later.

Thanks for the update @Michael_Blair!

Just to clarify, both your Oppo and S2 are connected via USB to the Surface Hub? When you connect just the S2, you cannot see it in Roon, but when you connect the Oppo HA-1 as well you are able to see both? Have you tried using a different USB cable? If you connect the S2 directly to the Surface or the Core, do you still experience this?

Also, after reviewing your setup again, I noticed this:

The NAS is connected to the same switch via two ethernet cables (Link Aggregation).

While this may not effect the device not being seen when connected via USB, I like to bring this up as you may see some performance difficulties with this type of setup. I recommend trying to remove the link aggregation from your setup for optimal performance.


Thanks Dylan, I really appreciate your help with this.
My intention with the S2 is to use it in my theatre room. Whilst I had thought it would be easier to set this up using my Surface Book I’ve decided to resurrect an old desktop PC, set that up in the theatre room and connect the S2 to it.
Finally got around to doing this yesterday. S2 connected and recognised by Roon no problems.
Still can’t play Tidal music via Roon. Tidal standalone works perfectly fine. Tried again in Roon without success.
Uninstalled Tidal - don’t ask what made me think to do that - and everything works fine in Roon for a few tracks and then stops again.
Roon previously played Tidal without issues. I’m not certain but might the 1.5 upgrade have caused issues?
Today I’ve reconfigured my switch so it’s not doing link aggregation. I also unbonded the ethernet ports on my NAS. This doesn’t achieve anything in terms of playing Tidal via Roon. I then disconnected the switch from the network (ethernet port in wall in study) and connected NAS directly to the ethernet port in the wall in the study.
Tidal still works fine. Roon took forever but eventually started to play Tidal via Roon….but only for about forty minutes and then stopped completely.
I can play tracks form my NAS but not from Tidal via Roon. I can Tidal direct.

1 Like

Thanks for the detailed response, @Michael_Blair!

Are you experiencing this difficulty with TIDAL on all endpoints? If you play directly to System Output does this happen?

As mentioned above, Google DNS may help:

Additionally, clearing your TIDAL cache may help:

  1. Shutdown your Roon Core
  2. Find and open your Roon database
  3. Navigate to /Library/Roon/Cache
  4. Move the contents of the /Cahce folder elsewhere, like your desktop
  5. Try restarting Roon and syncing Tidal


Thanks Dylan. I presume by shutting down the core you simply mean turning off Roon on whatever devices are running it? Did that. Located database on my NAS. Relocated cache folder as suggested.
Then restarted Roon. No change, still can’t play Tidal. Disabled Tidal>restarted Roon. Then logged back in to Tidal and let it resync. Still can’t play Tidal.
Tried Tidal direct and it plays fine.
Tried Roon via Oppo 203 and it works OK but not for MQA tracks. Back to Roon via Pro-Ject S2 and it worked…for one track; then switched albums and it stopped working.
Haven’t tried Google DNS as I’m in Australia and that is aimed at US users only.

Thank you for the updated info, @Michael_Blair!

To clarify here:

Tried Tidal direct and it plays fine.

Are you referring to playing directly to System Output in Roon, or just playing via the TIDAL app? If you play directly to System Output, are you able to play TIDAL just fine?


1 Like

I’m referring to playback in Tidal. Typically this works fine.
Just tried playback in Roon again. MQA playback played first two or three tracks of an album then freezes.
Also tried System Output and this did not work either.

Thank you for the additional information, @Michael_Blair.

I would like to propose a test that should help us narrow down the list of possible culprits for this issue:

  • Set up a new Core on one of your Windows devices
  • Make sure firewall and antivirus are disabled and you are connected directly to the router via ethernet
  • Connect to TIDAL on this Core
  • Try playing directly to system output on this machine

Let me know if you experience the same difficulties when trying the above test or if it works fine for you.


Hi Dylan and thanks for your help…so far. I haven’t followed your instructions/suggestions/requests to the letter, although I guess by now you’ve worked out I can’t follow simple instructions :grinning:

I realised that the PC I have placed in the theatre room was not running the current version of Win10. I have forced updates on that. I then tested playback again…to no avail. The updates to the PC made no difference.

I setup a new core on the PC in my theatre room, this is the PC connected via USB to my Pro-Ject S2.
I have previously ensured that both Tidal and Roon are allowed through my firewall. I didn’t check the anti-virus.
I reconnected Tidal and the music folder on my NAS to the new core.
I tried playback via the Pro-Ject S2 and all seems good.
I did all this last night (Tuesday In Australia) and played back plenty of files of varying formats - including MQA - from Tidal and my NAS via Roon.

This afternoon/evening (Wednesday my time) I have spent about two and a half hours playing back all sorts of files in varying ways (play an album, select a track from one album then whilst it’s playing pick another track from another album, shuffle music etc). It’s a test, I’m trying to break it or trip it up :slight_smile:
As a test I’m declaring this successful. Guess I now need to know how to go back to the core on my NAS without issues.

That’s great new, @Michael_Blair!

Since everything seems to be working okay on your PC, I think it’s safe to say there’s something about the NAS or how it is connected that is at the root of what you were seeing previously.

Earlier youmentioned:

Can you elaborate a bit on how the SSD is “attached”?

Is the firmware on your NAS fully up to date?

Is there anything different about how your NAS connects to the network compared to the PC?


Hi Dylan, the SSD is attached to the Synology DS916+ by USB. I’m using a USB 3.0 port on the NAS. The connection on the SSD case is the weird shaped USB 3.0 Micro B.
NAS FW is up to date although Synology have just released a new version which isn’t available automatically in my region yet. I’ve downloaded the latest version and am updating NAS as I type this.
PC connects to ethernet wall socket in theatre room. NAS (is currently) connected to wall socket in study. Both these sockets are connected to patch panel under the stairs which is connected to TP Link switch I mentioned in an earlier post. The switch is connected to the router.

Thanks for the details, @Michael_Blair,

If possible, are you able to move the NAS and connect it directly to the router? Or possibly move it to where the PC is and connect it using the same connection the PC is using? If you do this, do you still experience the problem? This will be a great data point. Since we know the PC is working, this will help us determine exactly where the problem may be occurring for the NAS.


Thanks for the suggestion(s) Dylan. I’ve relocated the NAS and connected it directly to the router. I still cannot play Tidal through Roon. I did manage to play Tidal using the Tidal application and I can play the music stored on my NAS using Roon.
As a separate exercise, back in the study where the NAS usually lives, I’ve plugged in other network devices and these all work fine.

Thanks for the additional information here, @Michael_Blair.

So, just to recap and make sure we are on the same page:

  • PC Core works as expected
  • NAS Core is having difficulties with TIDAL regardless of how it is connected to the network
  • Other devices connected to the network using the same Ethernet connection as the NAS do not have any issues

Based on this information, I’d like to propose another test. Earlier, you mentioned this:

SSD is attached to the Synology DS916+ by USB. I’m using a USB 3.0 port on the NAS. The connection on the SSD case is the weird shaped USB 3.0 Micro B.

This stands out as a factor that is different between the Windows machine and the NAS. If you install Roon directly on the NAS’s internal storage as opposed to a USB drive, does that make any difference?

Thanks for you patience and continued cooperation as we continue to troubleshoot. It is truly appreciated!