Initial server / controller connectivity - sporadic

I’m not sure if this is a bug or something on my end, but the problem is the controller app communicating with the server app. These “two” require constant fiddling/restarting to get them to talk when I want to start a listening session.

I have to make sure I follow a strict order of operation when firing everything up and is especially true when one or both are woken from sleep. Extremely frustrating and getting old

My setup is:

  • Headless Win10 Pro wkst running ROON server and HQP (HP Z400)
  • Mac mini running as NAA for HQP
  • Win10 home Laptop/2 in1 running ROON controller (HP ENVY x2 13.3", 8GB, 256SSD)
  • NAS containing music (qnap ts-251)
  • All items are connected to managed switch running 1GB with exception of mini which is connected to one of the fiber ports on switch (media converter at mini end)
  • Wireless is dedicated AP’s and overall network is new/fast etc…
  • Running latest ROON build.

My typical scenario is as follows:

  1. I’ll sit down and wake up laptop (roon controller not running as I have given up on it working after a period of time away)
  2. RDP to my server
  3. Fire up ROON server (don’t leave running for same reason in #1) and HQP
  4. Switch back to laptop and fire up ROON controller. Sometimes this works sometimes not as I can leave it sit at the “Connecting to Core……” for minutes without it “connecting”.
  5. So I must kill the controller app AND the server app. Start the process over again and things will usually start working.
  6. Controller has the IP (fixed) of the server in the settings. Regardless, it seems to take a long time to “connect” to server e.g. from the initial time I fire up the controller, then to it saying “Connecting to Core……”. that to me seems weird as one would think it would be somewhat instant/zippy.

I don’t recall this behavior in earlier builds but had automatic updates turned on which I have since turned off. As mentioned in #1 + #3 it never works anymore (I don’t recall this being an issue in earlier builds say 7 months ago) and so leaving ROON server (or for that matter controller as well) running doesn’t gain me anything since I’ll usually have to kill it once or twice before things work.
I would think at a minimum leaving ROON server running is how it is designed to be, no?
Any suggestions would be greatly welcomed.

This would be the area I would initially focus on (typically this works fine for people - so there may be something amiss locally … possibly an interaction with HQP).

I would suggest you leave Roon and RQP running and then when you have an issue contact @support so they can take a look at Roon’s log files.

I note you have managed switch (I run managed as well but they can be a double edge sword ) it’s worth double checking there is no multicast package filtering going on.

There’s an @support tag in my post, let’s see what follow up they can offer.

In addition to the switch I would check the WiFi access points as well. Some products can get really touchy when multicast is involved as it’s something that can kill a wireless network. Some manufacturers sneak changes to these settings (or behavior) into firmware updates (I’m looking at you NETGEAR!) so it would be worth checking the entire network. In some cases a change in firmware on one device can cause it to get into a multicast fight with another.

In general disable IGMP snooping on the switches and any “UPnP” settings on the access points, switches, and router.

1 Like

Hi @Swisstrips ----- Thank you for the very detailed report and my apologies for the troubles here. I would highly recommend trying the troubleshooting tips given to you by both @Carl and @AMP, as all of their suggestions are sound pieces of advice. Thanks guys :thumbsup:

In the meantime, I would like to gather some logs from you so our developers can have a closer look at what’s going on here and will be contacting you momentarily via PM with instructions.


@Carl and @AMP and @Eric - thank you all for the quick responses, awesome!. I know the holiday is upon us and appreciate the tips provided. I will look into Carl+AMP suggestions first and then look at my PM for further instructions. Thanks again guys :slight_smile:

1 Like