Roon cannot see my devialet amplifier in devices

the devialet version is 10.1.0 as mentioned.

The server is a windows home server 2011 which is based on windows server 2008. The whole network is cat5e cabled to a 1gbit switch. The whole house is in fact designed and built around high bandwidth audio streaming. So the server is connected to the switch and so is the devialet.

There are various ipads and laptops connected wirelessly into the system to be used as remote controllers.

I cannot remember right now what I precisely disabled, but can check the firewall settings later to see.

Ok, I have tried a load more things with the Devialet in terms of minimally switching off almost everything except for the ethernet port (running DHCP), 3 digital inputs and SAM.

None of this makes roon see the amps!

I have also tried completely switching off the firewall on the server where the core is, and the devialet is still not visible.

I simply cannot see what on earth else to change or try.

@support please help! I simply cannot get it working. I would be happy to buy a lifetime subscription if only it actually worked! :frowning:

Thanks

Mark

have you tried setting a manual ip on the Devialet, and usung the same ip that worked with the unplugged dCS?

It will definitely work…

Hi @mark_gilligan ----- Thank you for the report and the continued feedback here, both are appreciated! Sorry to hear of the troubles.

A few things I would like to confirm with you:

  1. Since adding the Devialet amplifier to the chain of communication and noticing this issue, have you tried power cycling all of your equipment? Core machine, endpoints, router, switches, etc?

  2. Based on your posts I see that you have disabled your firewall on the server (:thumbsup:), are there by chance any antivirus application currently running?

  3. You’ve also mentioned the following:

“The whole network is cat5e cabled to a 1gbit switch”

My assumption is that you are making use of an unmanaged switch, by please confirm and also provide the make/model.

-Eric

Hi Eric,

The router, switch, modem, server, amps have all been rebooted. No luck.

The switch is a d-link dgs-1210-24.

The server, switch, router and modem are all in a server cabinet and the whole house is designed for streaming from the ground up. I have used the system for all manner of servers and streamers for video and audio and never had an issue with anything before.

I have switched off the firewall, but the app and clients for roon can see the core whether the firewall is on or off, since I have set rules to allow all roon traffic anyway. This is from iphones, iPods, iPads as well as pcs and macs running all manner of operating systems.

I really cannot think of anything else to try!

Mark

P.s. the suggestion about fixed ip addresses is something I have tried. It did not work either. In fact it made other aspects of the system worse. The devialet remote control app from an iPad/iPhone became unresponsive sometimes. DHCP is more robust. I have been able to use dhcp for all other streaming aspects from all providers in the past.

Hi @mark_gilligan — Thank you for the follow up and verifying that information for me.

If I am not mistaken the D-Link DGS-1210-24 is a managed switch and we have seen a few issues crop up with these devices in the past ( Example: #1, #2, #3, #4). I would recommend enabling flow control on the switch, as we have seen it help other users.

-Eric

Hi Eric,

I have tried enabling flow control on all ports. Made no difference. :frowning:

Mark

Hi Eric,

Is there any way to specifically get roon to look at a particular ip address when looking for devices?

Mark

If you have a spare unmanaged switch, I’d try plugging your core, Devialet and router into it to isolate if it’s your managed switch and roon not getting along.

If your router is right there maybe plug the core and Devialet directly into it to test with its unmanaged switch.

I do not have another switch. :frowning:

I simply cannot understand why there is an issue given that I have had the whole setup working with a DCS network bridge already. The only variable is the devialet instead of the DCS.

As said earlier, everything works in fragments, but simply not all together!

Mark

Does your dcs network bridge have a gigabit network port? The Devialet is only 100mbit which might be causing issues at your switch if not quite configured correctly.

Igmp snooping, is it off or on everywhere?

@mark_gilligan

did you get this to work?

If not, your amp will tell you which IP address it’s got in one of the menus on it’s display. Can you ping this IP? If you install the Devialet Remote app on your iPad, does it find the amp? Can you control volume with the app? Did you disable WiFi in the Devialet when you enabled the ethernet port?

The remote app works and can easily control the Devialet volume, and I have disabled the wifi so it is only ethernet connected.

It is not working yet :frowning:

Is the IP you have on the dCS Bridge by any chance the same as you get on your Devialet amp? Which device is doing DHCP on your network? Is it possible to do reservations in the DHCP server by MAC address?

@mark_gilligan

Another thought… the dCS Bridge is RAAT and discovery is Roon’s own and different from AIR. If you install Devialet’s AIR driver on your PC (just for testing purposes) and it finds your amp successfully it is a RoonAIR problem. If the amp is not seen by the Devialet driver either, the problem is probably somewhere in your network set up.
I’d guess the dCS might sound better than RoonAIR (or AIR) anyway, but the direct integration of Devialet with Roon is functionally very nice!

I borrowed the network bridge, so I do not have it any more, and cannot check what the IP address was. The DHCP server is my airport extreme wifi router.

I have just spent the last couple of hours trying lots more things.

All the things that work fine:

  • Devialet:

    • Remote app works OK
    • Air from a PC on the network works fine
  • Roon:

    • The apps on PC, ipad and iphone can all fine the core
    • the core can find other devices on the network which are airplay compatible e.g. apple tv, and linn streamers
    • I have already use the core with a DCS network bridge hanging on the end of the same network cable as the devialet is now connected to
    • I have made sure all the server firewalls allow the traffic between the roon and devialet devices

Versions:
- Devialet is running 10.1.0
- Roon core version V1.3 build 242

The only thing that does not work is that the core cannot see the devialet!

I am completely stuck… there is literally nothing else to try… everything works except for roon.

Please help @support :frowning:

Thanks

Mark

This is really weird! The reason I ask about the IP of the Bridge is that Roon remembers that ‘Zone’. If your Devialet happens to get the same IP it can be ignored by Roon as that ‘Zone’ contains config that belongs to the dCS Bridge. If this is true, there are two ways to get around it:
1.: add a reservation in the Extreme DHCP server for the MAC address of the Devialet pointing to a different IP than the one your Devialet has now.
or
2.: Borrow the Bridge once more, connect it and observe that Roon finds it - then in Roon’s Audio setup for the Bridge press the two cogwheels and select ‘Disable’. This should free the ‘position’ so to speak…

I would appreciate @support to confirm or deny that this is a possibility as it is a ‘thin’ straw…

Otherwise, the fact that Devialet’s AIR driver is working from a PC on the same network as Roon is a bad sign for Roon. The possibility of a faulty Roon Core is there of course. Have you tried a reinstall? Maybe use a different Roon installation (the one on your PC) as Core just for testing? Can you see the Devialet from there?
Just to be sure: you are using the same IP subnet for all devices?

Zones have a unique id and the IP should be not used to remember that id.

If you are finding this happens, let us know what the device is so we can check with the manufacturer. This should never be the case and the IP should be able to change freely without Roon losing track of the zone.

At this point I would try:
Remove everything from your network except Roon core, a Roon remote, and the Devialet. Disable any firewalls etc.
If it doesn’t show up, maybe post the ip config for each machine. I would personally scrap DHCP for this test and set all ips manually - even if it’s just temporary (I disagree that DHCP is robust and better than static IPs - it’s easier but can be a cause of problems especially if the dhcp server has become confused or not refreshing or cached or something).
Power cycle everything after setting static ips - including switches/routers.
Then you’ll know exactly where you are, otherwise you may be chasing a problem that isn’t obvious.
If it doesnt work after this procedure, something’s really weird or broken and shouldn’t be too hard to pin down.

Thanks Danny. Good to have this confirmed. Then we can rule out my thoughts re. Roon blocking. I agree with hifi_swlon’s test description. That should clear things up.
I happen to use an Airport Extreme in my own network. I use it in bridge mode so the unit simply bridges wifi and wired which places all networked devices in the same IP range. I also use DHCP, but the server is (now) on my firewall. Used to run on one of the Linux boxes I have. When the Airport is in Bridge mode, DHCP and NAT on the unit is disabled. I suggest Mark should also set his Airport bridged while doing the next test. If DHCP is necessary the WHS should be able to do this.