Roon can't connect to Core [resolved: firewall issues]

I don’t have Roon Bridge installed, but, I do normally send music from Roon to my Apple TV: as mentioned in previous posts in this thread, that method of playback also doesn’t work, but, instead of skipping through the tracks, it just freezes at 0:00 of the track I’m trying to play.

@danny - you’ll see I sent a log playing to the Apple TV also in this thread.

Another update, @danny : I just tried connecting to my Roon Core via my macbook pro and it continually looks for it without finding it (even though the core is on with Roon open). This is despite the fact that I have ‘accept remote connections’ ticked. I also tried manually entering my IP, but, still would not connect.

This is in MacOS sharing? Can you send a screenshot?

I fear you having networking funny stuff going on, but the RME issue is a whole different thing.

Are there any firewalls involved anywhere? Are you 200% sure nothing on your Roon Core machine or router?

@danny I use Avast Premium Security on the Roon Core. Roon is set to ‘exception’ and has no firewall. My RME Totalmix software (which controls the routing of I/O) is also set to ‘exception’ and has no firewall.

and I’m not sure what you mean by “are you 200% sure nothing on your Roon Core machine or router”? What would I be looking for exactly?

Also, re: network funny stuff, I have no problem sending to my apple tv via the tidal app, my UE Boom speakers, my macbook pro, my iphone…just Roon. I’ve had problems with using both my Macbook and my iPhone to remote the Roon Core for many months now (and have tried getting help here to no avail) in which I’d get consistent internet dropouts when I used the remotes. Since the 1.8 update, it seems I can’t even remote at all. These kinds of problems seem to plague Roon and nothing else I use.

And radio silence again :unamused:

@danny - any luck looking through my logs?

Hi @Adam_Casey,

macOS Remote Connection

Is the Mac on the same IP range as the PC?

Are the networking devices that you listed above the only ones in use? No other access points, bridge routers, switches, anything like that?

The Mac isn’t seeing the Core at all so this is almost certainly a networking issue.

Playback Problems
If you disable Avast completely is there any change here at all?

Is Windows Defender firewall running? Can you try disabling that as well?

The issues you’re having could be caused by something like this, so it would be helpful to verify that if everything is completely disabled it still doesn’t work.

Thanks for your reply, @dylan

My Windows Defender firewall was on. I disabled it for both public and private networks. I also turned off my Avast Premium Security. The system output on the Roon core still skips through all tracks. My network access from my macbook worked though, but, only when playing back to the macbook pro system output. I am also now able to play to my Apple TV. So, a few improvements, but, not being able to play anything on my Roon core still a major issue.

@Adam_Casey – FYI, I moved your networking issue here, but left your RME issue in the other topic.

Thanks, @danny - the strange thing is, exception are setup, but, when I completely disabled both the firewall and Avast Premium Security it worked. I’ll investigate further and see what’s up. I certainly need these two things to be running at all times.

Do you have raatserver.exe added as exceptions in both?

Also, let’s try to narrow down which one is causing the problem by having you test in each configuration:

  • Windows firewall only
  • Avast only
  • Windows + avast

Hi Kevin,

I did not have raatserver.exe added as an exception. I just enabled it and the problem seems to have been solved. I’ll report back if I have any further issues in the next two days.



1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.