Roon can't connect to Roon search

Roon Core Machine

Windows 10 Intel i7 8th gen. 64GB RAM, SSD.

Networking Gear & Setup Details

ASUS AC-5300 router

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Ever since the ARC update, this is a new problem for me. It is very frustrating not to be able to search in Roon.

@benjamin , please help.

@G_Man, can you please provide additional information and what version of Roon you are using for your Core? Are you stating that you cannot use search in ARC or in Roon with a Remote, or both?

Both Core and remote are Roon 2.0 build 1148.

I don’t use ARC. I only search in Roon with Remote.

Thank you.

I just checked my Roon Core and am able to search (based here in the US). Are you getting no results or incorrect results when you search? I also am tagging @support for assistance.

No results at all. I just get this error message:


Thank you @G_Man. Have you tried rebooting your Core and restarting Roon?

That worked. But… I had rebooted my Core 2 nights ago, and it runs 24/7.

I shouldn’t have to reboot the Roon Core every day, as if it was Windows 95.

On a related topic, I will be requesting a feature whereby Roon does not rescan all the storage locations every time it is rebooted. A better design would be for it to write the whatever index structure it builds from the storage locations to disk, and then read that file upon boot up, thereby avoiding wearing down our hard drives.

Thank you

1 Like

Glad you are back up and running @G_Man. I recommend you create a new support request regarding the re-scanning of your library after rebooting occurs. I run my Core on a 2019 MacBook Pro and my library is not rescanned every time I start Roon (I don’t run my laptop 24x7). The Roon staff may want to review your logs.

Thank you very much, Robert!

I will def follow up on the library re-scanning issue.

1 Like

@G_Man is correct , I have NUC/ROCK running current software

It has an internal SSD and an external USB Drive.

Roon scans the USB but not the SSD, this was just restarted, its re-scanning the USB drive, I raised this question after an issue i had after the update. It does it every time. I have only recently had the USB drive attached so not sure if it came in with V 2.0 Roon OS , if that helps.


He doesn’t mention how is PC is setup. I was never aware of this when I ran Roon on a std desktop with Internal Drives, likewise with the NUC SSD

Couple of minutes later


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.