Roon can't find the Meridian MS600 endpoint

I decided to improve the Roon playback and bought myself a Merdian MS600.

The equipment worked well for a while, however: after i disconnected the CAT-cable, Roon just seemed to refused to find the MS600 again.

  • I can easily access the MS600 on it’s IP
  • I have no Sooloos core software or QNAP NAS
  • tried to turn on/off the MS600 and restarting the Linux-on-PC-Roon-Core a lot
  • tried to change the CAT and reset the the LAN connection
  • tried to change between static and dynamic IP

I’m kind of out of options.
Someone got an idea that could help me further?

Have you tried connecting the Roon core and the MS600 to the same (dumb) switch? In other words, eliminate as much network infrastrucure as possible to see if discovery works that way.

1 Like

Is the MS600 running the latest firmware?

You can update firmware with the Sooloos Configuration Application. Mind: if needed, the application starts the update without warning!

1 Like

The Roon Core and the Meridian share the same switch (TP link, no other connections besides the LAN to the router).

I can’t help with your problem but have something similar with my MS200. Whilst it can be seen over wifi it can’t be detected by Roon by any wired method I’ve tried.

At least it works most of the time but can be really flaky and around late afternoon, weirdly, is completely unusable.

1 Like

These must be either network problems or perhaps weird settings in the MSx00 left over from some previous installation.

As the Roon team wrote the protocols and (I believe) firmware for the MS200 and MS600, one can hardly imagine that they wouldn’t know how they work… And FWIW my MS200 works perfectly.

1 Like

Yes, I agree but what is that weird setting? I’ve just tried to listen to music and I’ve had to reset the MS200 6 times within half a song and you just give up at that point.

I got my MS200 from someone who used Soolos, if that could make a difference.

Has he done a factory reset (available, if I recall correctly, on the device’s web interface)? And what was the answer to the firmware question? (I don’t see it above.)

1 Like

I’ve tried the configuration application several times.
It does only offer some options that can also be altered by its IP interface or a “nothing to configure” screen.
If this implies that the software is up-to-date (as it should renew the firmware automatically) than i’m good with the latest firmware. I have asked Meridian to assist me in this matter (so far without respons).
My actual firmware is 2.406 device build 338

Exactly the reason why i picked a Meridian streamer :wink:
I’m glad it works well by some users (however: not all users are pleased and i’m willing to become part of the first group instead of the second ;-))

You’re in the wrong place. We are not talking about the Meridian Configuration programme on Windows.

You need to type the IP address of the MS600 into your web-browser, and you’ll get a webpage with a lot more things to configure. That’s where things start getting interesting.

The IP interface certainly offers a lot more options than the Windows configuration manager. However, updating the firmware is not an option within the IP menu…

Is there anything within this menu, besides change between static/dynamic IP that could improve the way Roon finds the streamer?

I’m concerned that you have no “SLS” input set, and no start-up source. It should be set to Sooloos, as far as I know. I’m not 100% sure this is the problem, as I suspect you don’t have a Meridian system connected, but I would try changing it.

I don’t have an MS600 anymore, but my MS200 screen there looks like this:

(If you can find the MS600 through your browser like this, I doubt that fixed IP is the problem.)

Did you do a factory reset when you first acquired the unit? (I’m not sure how one does one, but it must be possible…)

1 Like

Thanks for thinking with me! I’ve changed the SLS setting as suggested. So far without any luck…
I did not make a factory reset after requiring the unit, however: the unit worked at once the first time after connecting the new equipment.

How come you have ControlPC running then, according to the Sooloos Configuration Programme?

If you did have a Sooloos core, your symptoms (as far as I understand them) would be right. Sooloos would “take” the MS600 and Roon would not be able to see it. But you could find it through IP address and in Configuration programme.

Sharp! I really have no Sooloos core software installed.
I installed almost all available Meridian software i could find in an effort to update the firmware.
So… I’ve got ControlPC (and several other Meridian applications) installed and no Sooloos core (i don’t have a QNAP).
Do you think (un)installing ControlPC would affect the working of the MS600?

I don’t mean to be sharp. Just trying to help!

QNAP is not the only way you can have a core. You can have a physical device (MC200/MC600/MD600/Control15 for example), or you can run Sooloos TouchPC, or the QNAP package.

So you don’t have a QNAP. Do you also not have a MC200/MC600/MD600/C15 sitting on your network? (Just asking!)

If you “installed almost all available Meridian software” is it possible you have Sooloos TouchPC running somehow?

Running out of ideas. There’s probably a simpler answer which I missed…

I’ve no Meridian physical device.
I can either use a Windows PC, Linux Mint PC or Netgear DuoNAS.

Sooloos TouchPC is not offered from the Meridian support page. Google only offers a link to : Meridian Sooloos Touch:PC Application.

Sooloos TouchPC is different from ControlPC?
Is SooloosTouchPC something i can obtain from Meridian?

OK, can’t help further.

@Carl @ncpl @joel @support any thoughts? I probably missed something simple.

1 Like

RBM – I have a MS200 hardwired on my LAN. Currently Software version: 1.0, build 137, Co-processor version: 1.3.6, Hardware version: 2.1

I have never owned or installed anything pertaining to Sooloos.

Can I use the Sooloos Config App to automatically update my MS200 to the latest rev?

If so, any reason I shouldn’t do it? Don’t want to brick it…