Roon can't load Tidal

Roon Core Machine

Intel Nuc 8, i7 CPU, 8MB RAM, Roon version 1.8 build 952
Roon remote MacOS 10.13.6, Roon version 1.8 build 952

Networking Gear & Setup Details

ASUS AT-86U router and Buffalo BS-GS2016 switch

Connected Audio Devices

Aqua La Voce decoder with USB input

Number of Tracks in Library


Description of Issue

Roon can load Tidal home page yesterday without any problem but today Roon can’t load Tidal home page and pop up the message “error loading page, please check your network connection. Reload page.”

I have tried to log out my Tidal account and log in back. The issue is still there. If I click settings, Roon will crash most of times. I can log in Tidal APP without any problem.

I had the same issue this morning and restarting my Roon Server (Roon ROCK) fixed it.

1 Like

Same with me two weeks ago. Several times “Tidal login failed” but rebooting the core and the issue was fixed.

since the last two updates, I am having constant problems trying to play tidal tracks. It seemed as though 952 has solved it, but now I tried today and tidal will just not play again. Very irritating, particularly given the cost of this software. Things used to work fantastically reliably. It’s just so irritating to try and just play music and be met with constant problems.

Hey @Depei_Wang and team,

Thank you for reaching out to us with your question. My apologies for the delayed response and for your wait. We’ve made some recent changes to the support team structure and some reports have experienced a longer response time than usual.

Since some time has passed I wanted to touch base to get your current status. If you’re still experiencing this problem and need assistance please let us know.

A good first step is to log out of your Tidal account in Roon, reboot your system, and log back in.

We’ll be watching for your reply and get back in touch as quickly as we can. Thanks! :pray:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.