Roon cant play many Tidal albums

Ive had Roon and Tidal for a year. Made playlists, enjoying good quality music. BUT there are many albums that i can play from Tidal that not plays in Roon!!! why is this???
Example, today i wanted to play hell freezes over with Eagles! works fine directly from Tidal, But dont work in Roon.
My rig works fine on must albums, cable to router and blablabla. But … are there any limits to the use of Roon that can explain this ??? are there any agreements? issues ? with agreement with tidal true roon i have not understood?
This also concern albums and tracks ive played several times from my playlists before, from other artists… suddely wont play anymore in Roon, but i still can play them from Tidal!!!

When you say won’t play what happens exactly?
Stops, skips, error messages?

Works for me through Roon from Tidal source. Must be another issue.

I have to say I’m having this issue as well. Tons of tidal content will not play anymore (used to just fine). For example a playlist full of tidal Xmas music, Roon skips over certain artists and albums but plays others. I’ve just updated the software to the latest version. Is that the problem?

Did you check to see that the album is still available on Tidal? I was playing Tidal Xmas playlists through Roon also and noticed that one or two albums are blank (no cover picture) and they are skipped over in play.

Yes. I can play the tracks in Tidal directly that are skipped over in Roon.

I’m having a similar problem. I’ve been away from my Roon Core for about 8 months. Now I find that all Tidal tracks in my playlists are “Unavailable”. When I click the ellipsis for the track and try going to the album, I get “This album was not found.” If I browse the artist or search my library, I can find the track, play it and re-add it to a playlist. Of course, I’d really rather not do that for every single Tidal track added to my playlists!

Hmmm. That’s interesting. I have not played this playlist in a year, so that tracks with your similar experience. Roon…. Any clue what is happening?

The version that is in your playlist has been withdrawn by Tidal, probably due to licensing changes, the link between your playlist and the track/album is broken.
They then relicense and put a new version of the exact same thing back out but it isn’t the original and the link is still broken.
If you look at your playlists over time you will see unavailable against tracks appearing.

Search the forum and you will see loads of threads about it and feature requests to track the withdrawals.

For future reference if you have something you think is broken post in the support area as that is the only place the Roon support team look.


Error message … track is not available from Tidal :slight_smile:
I cant play them from Tidal anymore inside Roon …works fine both on phone and computer inside the Tidal app. But not from Roon. Day after day :frowning:
There are many albums that are not awailable anymore inside Roon… this leads to alot of tracks in my playlists are simply skipped. But all of the albums can be played outside Roon.
Soo is it a roon app failure? or a licence error?.. maybe tidal are changing albums allowed to play true the Roon app?

That should not be the case if they are truly still available in the Tidal ecosystem itself and you can play them in a Tidal app outside of Roon.

Have you tried signing out of Tidal inside Roon, restarting Roon Core and then signing back into Tidal again?

They are still available in Tidal BUT it isn’t the same ID that was originally in roon, see my post above.

1 Like

probably due to licensing changes you say… are you guessing??
and how do we users or Roon support help us fix it ?
I tried deleting tracks in playlist and then put it back in my playlist with no luck… are we suppose to micro manage this problem ourself spending hours ?? Then why do not Roon support fix this problem with some relinking/ retracing at programming level if you are right about this issue?

As I said
“Search the forum and you will see loads of threads about it and feature requests to track the withdrawals.”

Yes i have tried logging out Tidal … restarting the core and logging back in with no sucsess of fixing this problem.
I have in some occations, while deleting a track that is not working in a playlist for then to reinstall it… made it work. But only very few times. The whole prosess doing this is kinda time consuming and should be a automated prosess.
if …ged_hickman1 … statement in his reply here is legit. then this should become a automated fix at programming level. To reinstall a broken link to a new version of the track, because of licensing change i mean.

1 Like

From September 2015

I’ve had a half dozen instances of this occurring on Qobuz, happily listening along, then to find it is “not available “ the next day. Then a week later, it’s back. A licensing change or something like that makes the most sense to me. I’m a many years lifetime Roon licensee and it has happened on both Tidal and Qobuz. Very rare though.

I can’t say why, only that it has occurred on both streaming platforms. Qobuz seems to curate content to my tastes better than Tidal so I went with Qobuz exclusively.

Ok thank you for caring…

Hmm i see. well ty for info.

3 posts were split to a new topic: Specific Tidal Album Not Playing in Roon