Roon can't see my Astell & Kern DAC via Roon Bridge on my network

Core Machine (Operating system/System info/Roon build number)

Lenovo Thinkpad X220 PC, Roon trial version

**Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Linksys EA6350 on Ethernet network to Roon Core PC and two Roon endpoints.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  1. Astell & Kern KANN or KANN Cube (both in USB audio input mode) connected to Allo USBridge Signature Network Player via USB cable (this player runs Roon Bridge internally).
  2. Astell & Kern KANN or KANN Cube (both in USB audio input mode) connected to Lenovo Thinkpad X61S PC via USB cable, running Roon Bridge.


The Audio Devices list shows my X61s Roon Bridge PC (labeled as “Field PC-2” in attached screenshot) and plays audio through it, but it can’t see either of my Astell & Kern players that is connected to it via USB.

Hi @Oliver_Barrett,

If you connect your Astell & Kern directly to the Core as a test, does that work as expected?
Do you have the USB DAC driver installed on both Core + Roon Bridge device?

Hello Noris,
Yes, my A&K KANN Cube works fine when directly connected to the Core. The KANN Cube Audio ASIO Driver that is shown in the Devices list for “This PC” in my screenshot (attached) needed to be enabled first.

However, when I connected my KANN Cube to my 2nd PC running Roon Bridge (Field PC-2), I got a “Device Initialization Failed” message when I tried to enable the KANN Cube Audio ASIO Driver (on this PC). This was after I tried uninstalling and then reinstalling that driver earlier today. Perhaps my PC-2 has an issue, it is an old machine that I had upgraded to Windows 7 (from Windows ME).

Thanks again!

Hi @Oliver_Barrett,

Since you are using a Windows PC, I would verify that RoonBridge.exe/RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

You could also try re-installing RoonBrige to see if that helps or installing the full Roon client.

Hello again,
Since Norton is managing my firewall settings, I checked its settings, and found nothing that would block Roon Bridge. I made sure that my Roon network is a private network.

I tried reinstalling Roon Bridge, but no change. I also tried to install the Roon client, but my old PC is Windows 7 and it doesn’t have the OpenGL driver. I’m thinking of just going ahead with buying a miniPC with Windows 10. One candidate is the Intel NUC, but are there other good, electrically quiet miniPCs I should also consider?

Thanks again!

Hi @Oliver_Barrett,

Is there any change in behavior if you try to temporarily disable Norton completely as a test? Antivirus programs sometimes have a specific way of setting up exceptions, so it would be good to confirm if this is the case here. You could also try hosting the Roon Server on Windows 7 to see if it has the same behavior, Roon Server has no GUI so you shouldn’t run into the old OpenGL driver issue.

If you want to get a NUC, we would suggest using ROCK: Roon Optimized Core Kit. It is an operating system that we created and runs a variant of Linux. While it should work with your devices, I would double check Linux compatibility prior to purchase.

You could also look into using another sort of Roon Bridge, either one you create DIY (like on a Raspberry Pi - Ropieee/DietPi/Roon Bridge, or look into a pre-built solution - Allo USBridge/Sonore micro-ultraRendu to name a few).

Ok, I’ve confirmed that KANN Cube requires a Windows 10 PC or Mac (running Roon Bridge) to receive USB audio running in DAC mode. The PC requires the KANN Cube USB port driver to be installed (supplied with the KC). I recently acquired an inexpensive Intel NUC that I’ve been using for this, it acts as a Roon endpoint to bridge my KC DAC to my Roon Core PC via an ethernet network.

This issue is resolved.

1 Like

Hi @Oliver_Barrett,

Thanks for the update here and glad to hear you got the issue sorted out!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.