Roon can't see Mytek Manhattan II Network Card [Resolved]


I installed the Roon Ready Mytek Network Card into my Manhattan II.

When I use mConnect (the supported control app) I can play dlna and Tidal content, but Roon can’t see it. I’ve previously used Allo’s USB Bridge and DigiOne with the same DAC with no problems. Roon still finds the USB bridge/DigiOne. But not the network card…

I’ve tried restatring pc/roon/manhattan.

I’m not familiar with the network card but are the network settings correct? Turned off your firewall?

It’s a very new product, I believe (the card, not the Manhattan :-)).

Normally, the card should present itself to Roon in similar fashion to your Allo products.

There may be a RoonReady mode that needs enabling (can’t find anything in the manual).

The obvious: check whether the card has an IP address in your normal network range.

Let’s flag @support to see if the Manhattan II w/ card is RoonReady certified yet – and if they can be of assistance to get you up and running.

Looks ok, Roon finds the other players which are lined up connected to the same switch so I can’t really see what settings to change.
Tried to turn off the firewall, didn’t help :frowning:

We haven’t reviewed nor certified this device, so there is no way it is Roon Ready :slight_smile:

That’s very strange… Are you totally sure??

Here’s from the Mytek website:

OPTIONAL “ROON READY” NETWORK/Wi-Fi CARD: Turns the Manhattan II into network streamer with 24/192k andDSD64 maximum throughput. Compatible w/ Roon, Airplay, DLNA/UpnP, Spotify Connect, IOS, Android’

Manual for the network card:

Brian is the one authorising the certifications, so yes – I guess he’s pretty sure.

It looks like Mytek has gotten a bit ahead of themselves – it may be wise to take matters up with them first.

How quickly can you return it?

We have been in contact with Mytek.

The card is intended to add Roon Ready capability to the device, but has not been submitted or certified and so is not yet Roon Ready. In the meantime, we can’t really support it since we don’t know if it has issues still and do not have one to work with.

You will need to bug them to get this straightened out asap, devices are not supposed to be shipped until they are certified.

Hello Hertzberg

Have you tried to ask Mytek for support directly here?:

We are not on this forum all the time, so your best bet is to contact us directly. Maybe you did, Im not sure.

Brian: The card is the OEM card which Roon actually recommended to us, so IT IS Roon compatible.

It works just fine, the only issue here is it has to get certified which means Brian has to test it. Roon will be recoeving Manhattan 2 for certification in the next few days and Im pretty sure it will get certified as it works just fine. Ideally it should be already certified, it just didnt happen yet with our busy schedule this Fall leading to CES ( Mytek has just announced shipping of Clef)

If your card doesnt work it could be for these reasons:

  1. Manhattan has old “pre card” firmware. Please update to latest one using Mytek Control Panel

  2. Card is improperly installed > see manual

  3. (unlikely) something is broken.

Typically with card installed youd have additional “Network” input show up in menu. Select this input - you will see “waiting for network” briefly and then the sample rate and bit rate will appear. That means dac is seen by network

If above doesnt work, please fil in support ticket.

Current users: please ignore " not Roon certified" and just use the card as described in manual. Certification will happen later this month.

Best Regards, Michal at Mytek

1 Like


Thanks for you fast response. I have updated the Manhattan via the PC/Mac app, and the Network card via the mConnect app. Network card firmware is v3.3.11 - the Manhatten firmware is 1.11R0575.

I get the “Waiting for Network” and NETWORK input option as described. It seems to work fine with with mConnect and also with Bubble UPnP. I can play music from my local NAS and from Tidal. But there was one strange thing - playing the same MQA file with the two different control apps gave different results. With mConnect the Manhattan display panel said “PCM 24-44”, with Bubble UPnP the display read “MQA 24-176”. Using my Allo device and Roon, this file shows up as MQA 24/192.

Anyway - main issue for me is of course that Roon cannot find the Manhattan card. I have tried restarting everything in multiple orders, swapping network cables, moving my Roon core pc to the be connected to the same switch as the Manhattan, with no different result. Roon can see my Allo DigiOne and USB Bridge, but no the Manhattan Network Card.

For the record - the card now works with Roon and I was able to enable it under settings-audio.

I reinstalled the card, gently making sure that all connections between the ribbon band and the card, and also between the two cards were as they should be. If that was what made it work with Roon or any other changes I made in my network or on my computer or in Roon, I dare not say, but now the card works with Roon.

1 Like

Glad you got it squared and listening to music! :smiley:

Thanks Daniel. It is very frustrating when gear holds the music away from you. After I had been struggeling with the Manhattan card for a while, and had tried reconnecting all my stuff in various setups, the other Roon devices also wouldn’t show up in Roon for a while. I was not very found of Roon for a while there… It is not always plug and play. Sometimes I miss my CD- player :roll_eyes:

When you’ve got to know it a bit better I’d be really interested to see how the card compares with the USBridge from a sound quality point of view. I have one (USBridge that is, can’t stretch to the Manhatten yet but it looks an attractive option).

This topic was automatically closed after 18 hours. New replies are no longer allowed.