Roon Causing Constant NAS HDD Access

@support Unfortunately, my trial period has expired and I have canceled my subscription. Curiously, I launched Roon on my iMac and got this screen (no surprise about the screen):

As soon as I did, the constant NAS access began. It has been several minutes since I started Roon and while it cannot be used to view or play my music files, it continues to access the NAS every 10-15 seconds.

Just thought it may provide more clues.

Hey folks,

Apologies for the slow response on this thread. This ended up with me, and the last 2 weeks have been a little bit busy :innocent:

So, I’ve discussed this issue with our dev team, and I think this is a side effect of how storage works in Roon. Roon is designed to watch your storage devices in real time, and when you add an album it should show up automatically. When your storage device is turned off, the albums it contains should disappear from Roon automatically as well, returning when your storage is turned back on.

There are a lot of reasons the product is designed this way, but one reason is that we wanted to avoid the experience we’ve all had in iTunes where you go to play a seemingly-available song, only to find the media is no longer available.

In practice, Roon will only perform as well as storage devices it’s being used with. As has been discussed quite a bit, many NAS devices do not consistently report changes back to us, and some operating systems (Linux especially, but also macOS) are particularly susceptible to this when using SMB.

Because we need to detect whether the storage device is still on and available, we do check on a regular basis that the NAS is still on and available, and we suspect that’s what is keeping the NAS awake here.

So, the shorter answer here is that Roon is in regular communication with the NAS, and that’s really how our storage infrastructure is designed to work. If that’s keeping the NAS from going to sleep, the only real answer would be for us to change the design, or to use local storage instead of a NAS.

That said, we are going to do some more investigation here. If we are still communicating with the NAS even after the folder is disabled in Roon, that would be a bug. And everyone should feel free to open a feature request related to us changing how storage works in Roon – this would be a big change, so we would want to see real interest in this kind of use case.

If power consumption is the primary concern here, you might consider using a simple USB drive for media storage, and back it up to a NAS that’s only on for a few hours a week.

Hopefully that helps explain the current status of this issue folks – if you have any questions let me know, otherwise we will schedule some testing in our QA department once the dust from 1.5 settles, and we will let you all know if we’re able to identify anything that’s not working as designed. Thank you!

@mike I appreciate the update. I need to take some time and think about what you said but wanted to say thanks for the info.

@mike I just want to be sure that I understand something. Roon is regularly communicating (every 10-15 seconds, as I have experienced) with all storage devices, not just NAS?

@support Just wanted to update you. I copied my music to an external USB drive. Other than an issue (posted in these forums) with Roon not recognizing that ‘Music’ on the NAS and ‘Music’ on the external USB drive are not the same, the constant HDD accessing has stopped.

Was it the QNAP TS-431P, my iMac 18,3, Mac OS 10.13.4, some combination of the three?

Abandoning the NAS (which I use for other things) was my solution.

Thanks to all for their help and input!

1 Like

Thanks for letting us know John.

I’m going to do the same when I get round to it.

If I understand @mike’s post correctly, it’s a feature of Roon to regularly poll any NAS drives where it expects library music to reside, in order that it is up-to-date with what music is currently available in the case of disconnection/re-connection.

He also says it’s more of an issue with Unix based OS’s running SMB.

I think it’s a real shame to be polling a spinning HD every 10 seconds or so when it’s on 24-hrs a day. (I like to leave my mac mini and my NAS running and hoped they would put any spinning drives to sleep when I’m not using them, but I can’t while I’m running Roon).

It’s not about energy consumption, it’s about longevity of the HDD.

I think this is an unacceptable situation, so… since there’s a workaround, I’m going to do that…

Move my music to my Mac Mini with a backup on my NAS. Then I can let my NAS spin down, or switch it off until I need it.

I hope my mac will spin down any local drives while they are unused, even while Roon is idle on there and pointing to them for it’s local library.

@John_Conte @Dan_Brown
I still have the same situation. I’m not impressed with the constant chuntering of the NAS or the explanation given by Roon staff. I’m reluctant to move the music to a USB drive.

I don’t buy the Unix/Linux SMB thing that has been mentioned. I have tried shutting down Roon and running JRiver on the same Linux HTPC and that lets the NAS sleep when not being used.

Also this problem didn’t occur when I first signed up to Roon. If I played Tidal tracks for an hour or so and then switched back to tracks stored locally on the NAS I could hear the disks spinning up. Something has changed in Roon’s implementation.

@mike is there an update on this?

For me, at first I thought everything was aok pulling my music from the NAS and then upon reading threads on this forum it was pointed out about deleting songs through Roon was actually deleting the file from the NAS.

To be fair there are plenty of warnings before you are actually deleting but it had happened to a few users here. So I decided to move my music to external USB drive hooked up to my core and than have a backup of the USB to the NAS.

Well immediately my navigation in Roon was instant and noticeably faster than pulling everything from the NAS.

–MD

Just hooked up my Nucleus and am trying to figure out where to store my music and how to connect it to the Nucleus…

I see this thread died in June, did you all give up on the NAS>Ethernet>Roon idea and go HD>USB>Roon?

Man, this stuff ain’t simple. Too many choices and not enough easy to find info about how to decide…

Hi David. I ended up transferring my music to the internal drive on the Mac Mini. It works fine.
I think you’d be best off using a little USB drive with the Nucleus unless you can get a second drive fitted inside?

There is room for a 2.5" drive inside the Nucleus, but only up to 9.5mm thick.
I believe this limits the HD size to 2TB at least in spinning, and I need 4TB.
The kicker is I have two perfectly good enclosures but one only has USB 2.0 to mate with the Nucleus, other wise I have to buy a eSATA>USB converter, which would be USB 3.0 and faster…
But then I’ve got an enclosure with fan in the stereo cabinet, and how do I load new music onto it, can I do so through the Nucleus’ ethernet network connection?
Meanwhile I ordered a 4-bay NAS to put in my network cabinet, away from the stereo. I figure Roon will solve the NAS-waking issue soon :slight_smile:

You could get a 2.5inch external USB3 4TB drive.
Like the following… no fans… https://www.amazon.co.uk/Seagate-Expansion-Portable-PlayStation-STEA4000400/dp/B017KE8OG0/ref=sr_1_2?s=computers&ie=UTF8&qid=1540426712&sr=1-2&keywords=4tb+hard+drive+external

Or if you want to go with what you’ve got, USB 2 is fast enough at up to 480Mbit/sec to serve up music to quite a lot of zones at once.

CD quality PCM is just under 1.5 Mbit/sec.
24/192 PCM is 4.6Mbit/sec
DSD is 5.6 Mbit/sec, or 11.2 Mbit/sec for DSD 128.

1 Like

I’m still using a NAS and it is still prevented from sleeping by Roon and chunters away constantly.

My solution is to shut down the mini PC which runs my Roon core, when I’m not using it. It’s attached to my hifi. The NAS goes into sleep mode quickly after that.

1 Like

I know it goes against common logic, but the HDs will last longer if they newer spin down.
Personally my NAS newer spins down.
If you really want to be more green put it on a power schedule that turns it off at night/during the hours you are not home.
I am pretty sure that Roon designed the nucleus to take the taller 4TB drives. Internal/directly attached drives will perform better than a NAS. Use the NAS for backup.

I recently moved my USB local drive connected to a PC, running Linux and where Roonserver is running, to a NAS and reconfigured Roon to point to the NAS storage. I see that Roon is constantly accessing the network storage even if music aren’t playing. If I stop Roonserver the disk activity stops.

Wondering why would Roon do this ? Is Roon trying to monitor it ? Any way I can disable it ? In the Storage configuration I have “automatic rescan interval” set to 8 hrs.

Thanks in advance.

Hi @Debjit_Ghosh, I’ve moved your post into this topic, have a read esp.

I’d recommend a 4tb internal ssd for your nucleus. See this link…

The constant churning of my QNAP NAS has been doing me head in over the last couple of months! Even when I’m not listening to music the drive (which is under my desk) drives me insane and it’s taken this long to discover Roon is the cause!

I have no stored music and only listen to Tidal and Live Radio so why does Roon need to constantly access the drive?

1 Like

Is roon on the Nas?

Correct. QNAP 672XT i3 8GB
Thuderbolt to ethernet connected to iMac using AFP protocol.

I’ve had to move it off the NAS on to my iMac which is unfortunate given the NAS is well equiped and designed for such purposes.

It’s possible to instal an additional M.2 SSD. If the core is installed on this will Roon continue to churn the spinning hard drives or only the SSD it’s installed on?