Roon Closes when I try to add a new folder

Core Machine (Operating system/System info/Roon build number)

MacBook Pro Retina running Mojave 10.14.4 Roon Build 1.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity Router - WIFI

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

MOJO DAC via USB

Description Of Issue

When I click on Roon/Preferences/Storage/Add new folder Roon closes. I have completely uninstalled and reinstalled Roon twice and regardless of where or when I click on Add New Folder the program closes. I discovered this when I was trying to add files from NativeDSD.

Well, I found a work around. I just dragged the .dsf folder to Music, next to iTunes Folder, and it is playing just fine on Roon right now. Still don’t know why Roon crashes when I try to add a new folder. Must have something to do with Mojave.

Hi @Rosey,

Can you share a screenshot of what folder you were trying to add in Roon?

Does this occur if you add other folders or only this particular one?

Hi Dylan, The folder I was trying to add is just a regular folder full of .dsf files I downloaded and unpacked from NativeDSD.

The first capture shows the folder NSDS012 - I dragged in to Finder/go/Home/Music. This worked.

The second capture shows the .dsf files in the folder.

The third capture is where the problem occurs - If I click on: Storage/+ Add Folder, Roon Crashes. I can’t add any new storage folders at all.

The fourth image shows the result of my work around. I was able to add another dsf file just now - the two .dsf folders are the NativeDSD sampler and the Bill Evans tune.

I had some work done on my MacBook and had to reinstall stuff - including Roon. Before I had my MacBook repaired, I was able to add folders.

It is entirely possible that there is something that I don’t understand about this and I appreciate your help.

Regards

Sandra

Thanks for the info here, @Rosey!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi Dylan, I did it twice the first time at 3:51pm PST, I had my DAC on and tried to add a storage folder and Roon crashed. I did it again right away (3.52 pm PST) with the DAC OFF and same thing, tried to add a storage folder and Roon crashed.

Hope this helps.

Glad to do more testing.
Sandra

Hi @Rosey,

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

I ran Roon yesterday. When I opened it the first time - all my music was gone. So I closed it and reopened it and my music was there. I am thinking that I might have cause your diagnostics to cancel. ?

Hi @Rosey,

Apologies for the delay here! Initially the diagnostics report did not come through but I tried enabling once more and the report successfully came through. The technical team is analyzing the report and I’ll be sure to update you ASAP when I receive their feedback.

Thanks,
Dylan

Hi @Rosey,

I spoke with the team regarding their analysis of the report. They’ve found that the crash seems to be related to a file with uncommon characters located in your Users folder. So we can track down what file this may be, please do the following:

  1. Launch Terminal
  2. Type cd and press Enter
  3. Type ( ls -la ; file -I * ) >~/Desktop/lstest.txt and press Enter
  4. Send us the lstest.txt file that is saved to your desktop via a shared Dropbox link

Thanks!

Got the file ready to go, got dropbox set up but where do I share the file too? Post it here on this open network?

I looked at the file and it has a lot of .bfg (bigFish Games) links on it. Strange. What actually is this file that was collected?

Hi @Rosey,

You can click on my profile image here on the site and then send me a Private Message with a link to the dropbox file.

This is a list of file names in that folder. Based on the technical team’s analysis it appears that there is a file with non-standard characters that is causing Roon to crash, and so this will allow the team to identify which file may be causing that to happen.

Thanks,
Dylan

Hi @Rosey,

Apologies for the delay here! I spoke with the team about their findings here, and they discovered that this issue is stemming from the following:

.config\FairyTale\

Can you try renaming this to one of the following and let us know if this resolves things?

.config\\FairyTale\\/

Or

.configFairyTale/

Thanks Dylan, but I have been out of UNIX for over 20 years and can’t remember how to do this, I even googled it but that was a waste of time. I would like to look at this file first. Can you help me with this? Thanks!!!

Hi @Rosey,

This folder should be inside the /Users/sandragilbert folder. If you move it out of the Users folder this should work as well.

What an experience. I have been searching all over my computer - including the Users/sandragilbert folder for this file and it turns out it was a hidden file. I found and deleted it since I have absolutely no idea where it came from and is not a game I have ever played.

After I deleted it and ran Roon, I was able to open Roon/Preferences/Storage/Add folder and it worked. Thanks again for all you help - it appears the problem is solved.
Best regards
Sandra

I’m glad to hear that things are working for you now, @Rosey! Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.