Roon Code on Mojave OSX

I am running Mojave (MAC OS 10.14.6) on my iMac and Roon code v1.8 build 1136. However, I am not able to upgrade it to V2.0 and that’s the reason I can’t use my Roon Remote or Roon Arc on my iPhone.
Can you please help me and tell me what should I do to resolve this conflict in versions.
Thanks.

Roon 2.0 only support MacOS 10.15 and upwards.

Choices are, upgrade your Mac, run a patched version of MacOS (many have done this with great success), or stay on and upgrade to 1.8 (Legacy).

1 Like

@Milan_Ivanovic, I moved your post to Support so the community and Roon can assist you better.

When Roon 2.0 was released, Roon required a new set of minimum configurations:

Now, 10.15 (Catalina) is the minimum required to run Roon 2.0. Can you upgrade to that on your Mac? If not, then 1.8 Legacy is your option unless you change your Core computer to a supported configuration. If you stay on Roon 1.8 Legacy for your Core, you will need to download Roon Remote (Legacy) for your iPhone.

1 Like

As an aside, it might be worth updating the ‘largest libraries’ section, as M1 and M2 based Macs running Roon 2.0 are probably more than capable of running quite substantial libraries, particularly if they have 16GB or more of RAM.

1 Like

Thanks Dave, I’ll see what the staff thinks.

1 Like

Hi @Milan_Ivanovic,

Thank you for patiently awaiting an official Roon support response.

Although @Formula is correct that your Mac won’t support 2.0, 1.8 Legacy will still work for you.

I’ve enabled diagnostics and see your devices have different versions and we need to remedy that to get you up and running.

Here is the link for the 1.8 Legacy download for your Mac. In addition to this you will need to uninstall Roon 2.0 Remote from any mobile device and search your app store for Roon Remote Legacy to get a compatible version.

In looking at the diagnostics I also see a Windows device. Alternatively, you could migrate your core over to that machine (if that works for you) and utilize 2.0.

Whichever way you go, let us know if we can help!

Thanks,
Wes