Roon completely broken after update

Roon Core Machine

W7 64 bit

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

After installing the update nothings works.
So I decided to start from scratch.
Uninstalled Roon Server, rebooted, installed server again.
After that added folders manually.
The albums don’t populate - and it says no audio devices found

I just want to listen to some music.

1 Like

Will Roon even run on Windows 7?

Microsoft hasn’t supported Windows 7 since January 2020.
Roon not playing is to be somewhat expected.

I had it running on win7 32 bit very recently so that should not be a problem

Windows 7 64bit worked fine until the update. There’s another thread here that suggests the update broke other than Win7 as well.

So I shouldn’t have updated, it was working flawlessly moments before?

1 Like

I don’t know. Just throwing that out as a possibility.

11 posts were split to a new topic: Remotes don’t connect to Core after update to build 860

Did you try to restore a backup?

Yeah, I had the same result, no audio devices, no music library.

I’m in the same boat. Ran the update and now everything is gone and no audio devices are showing. It was working fine moments before. I’m on a Mac M1, so doubt this is a windows specific issue.
What do I do??

Hey @Jason_A,

We’re so sorry that the update has had such an impact that you can’t listen to music at all. While Windows 7 is not officially supported, it does not mean that for your use case it won’t work. So, we’re glad you were all set.

The symptoms you’re describing point to database corruption (more on that soon). In the meantime, could you please try these steps?

  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Restore a backup

Thanks a lot :pray:

A post was merged into an existing topic: Remotes don’t connect to Core after update to build 860

A post was merged into an existing topic: Remotes don’t connect to Core after update to build 860

Hey @Fabian_Falconett,

Thanks for letting us know you’re experiencing somehting similar. The same thing as Jason :relieved:

Could you please give that a try?


I have completed that process a few times.

So usually after the first time I get the no albums/no audio devices.
After awhile it will change to database issue (There was an issue loading your database)

I followed all the suggestions in the Roon Help Centre. It behaves the same way.
Loading a back up database will result in the no albums/no audio devices problems.

I reported same issue in the “Issue with database” thread here. I have also followed the database restore instructions as here (move the folder, reinstall, restore). Done it a few times. Same problem, cannot move past no audio devices and no music.

I’ve tried all that plus creating a new database and issues remain i.e. Roon will not scan/load albums and audio devices remain undetected. I’ve done complete uninstall and reinstall with no success.

1 Like

2 posts were split to a new topic: Roon does not launch (hanging logo)

Hey @Jason_A,

Thanks for going through all the steps (and even more than once!). I only wish the result would have been what we were all hoping for: a restored database, so all your playlists, tags, favorites, play history, settings and so on will be just as before.

Do you have another backup (older) you could restore? I ask because, other than that, as much as it pains me to say, starting fresh is the only other alternative…

We created this post explaining things in more detail:

CC: @Alan_Sparks, @Paul_Candy and @Alan_McMillan

I couldn’t be more sorry this is the case. Our team is going through the same thing and we feel your pain… some of our databases are not restoring either :pensive: