Roon completely broken after update

Hey, this is just a joke? I just read this thread (Read this if "There was an issue loading your database" after updating to Build 880) where it says:

" If you restore from a backup and still see “There was an issue loading your database” , try restoring from your oldest backup. If you’re not having any luck with your oldest backup, then the only alternative is to start with a fresh database."

I tried reinstall Roon Server, restore database backup and still see that screen. Before the update I made this morning, everything was fine, and you now saying, “hmm, try to start fresh database”, are you kidding me? I’ve been managing this database for a few years.

If you approach the problems you have caused in this way, there is nothing but say goodbye to you for good.


Hey @Radek_Toman,

I wish I could say it was a joke, and a very bad one at that :pensive: :sob:

Thank you for going through the steps already. The only other solution to starting fresh is trying to restore an even older backup. Do you have any you could try?

If the backup is from before the database was corrupted, it should restore just fine. The reality is that once a database is corrupted, there’s hardly anything that can be done to continue to use it…

It’s not easy for us to say this and we’d all wish this wasn’t the case. Just like you, our team is experiencing corrupted databases and some of us are starting fresh too… :cry:

Okay so I’ve completely given up on getting my library back.

How do I get Roon to work?

A fresh install has the same issues.

So now what?

1 Like

Appreciate your apology, but hey - give up is marked as the solution?
None of my backups restore, so my best guess (being a new-ish customer) is that your backup facility doesn’t work too well. Or, your new software isn’t capable of reading the 1.8 build 831 database.

So, what now? I see people also saying starting from an empty database doesn’t work either. Do we wait for your guidance or is any to be forthcoming?

Since we know 880 (apparently) causes a lot of people a lot of problems, let us drop back and proceed forward carefully. At least maybe we could get back to working. And I know to disable automatic updates for the future.



Dear rebeka, I keep the last two backups.


Both don’t work. I understand it’s not your fault. But developers who refuse to admit their mistake and face it. It’s not OK to lose forever a significant portion of paying people. Thanks and good bye Rebeka :slight_smile:


This could mean that you’ve got Roon running on an old PC with an unsupported OS, your harddrive is nearly full, or the harddrive is just completely shot.

Can you tell us more about your PC? HDD or SSD, and how old is it?

Have you tried starting fresh yet?


Mechanical Drive for the OS - Replaced semi regularly - aprox 3 years old

It runs Plex just fine.

1 Like

Well, no. I’ve held off a little based on hoping you guys could come back with something better than “just start over.” I’m not in as bad a shape as some here with years of DB preening, I’m only about 3 months in. But now wondering if it’s going to keep being hard to stay.

I’ll probably try from square 1 later today.


OK… so I just did try. Removed installed Roon Server, and reinstalled 880 on my Windows 7 box where 831 was very happy. Did NOT try to restore a backup.

So now, I have roon client on my laptop (windows 10) showing the server with 0 anything, NO audio devices, and a pulsing Roon logo.

Also rebooted the machine, Roon came up exactly the same.

No other changes except the Roon install was done here. Other services such as Plex are running fine.

1 Like

Was it a surprise to Roon engineers that the new build might be incompatible with “corrupt” databases all of a sudden? As of yesterday morning, my database wasn’t so corrupt as to be inoperable.

Will Roon be compensating long-time subscribers for the loss of their database info and the time it takes to start from scratch?

Roon is a premium service that I pay for exactly to avoid “starting from scratch.” I have been religiously backing up my database as recommended.

Thankfully I have another streamer that accepts Tidal/Qobuz AND Spotify I can use for the time being…


I really wish I had better news to share, but there’s no getting around the fact that this was always a recipe for disaster. :slightly_frowning_face:

We have pretty modest minimum requirements for small libraries:

  • Windows 10
  • SSD
  • i3 CPU or better
  • 8GB RAM

Microsoft ended Windows 7 support two years ago and an SSD is an absolute must – reliability aside, the performance you get over an HDD is unreal. I’m surprised you’ve been able to tolerate Roon’s performance with an HDD, it must be unbearable.

The AMD Phenom 9500 is extremely underpowered compared to an i3 processor, but you might be able to get away with it if you upgrade to Windows 10 and install an SSD.

Can you upgrade it to Windows 10? What CPU do you have, SSD or HDD, and how old?

This is a good sign…Have you tried restoring the oldest backup you have?

My oldest backup is probably a few weeks old, which likely isn’t old enough. I haven’t tried it yet, hoping that Roon would be able to service customers some other way.


I really wish there was another way, too. :frowning: Try restoring that backup and hopefully it’ll be successful.

What about this question?

That’s probably covered in the Roon terms and conditions.