Roon connects to squeeze products but will not play

Roon sees the squeeze devices - a transporter and classic 3 but stops internet radio after a few seconds and simply skips between tracks on albums. The squeezebox did play for a bit on initial setup but has not since. Roon logo is displayed on device and intended source is displayed but no music. Radio shows as stopped. I have tried all of the remedies in support for Roon not connecting ie cycled LMS emulation, did factory reboots on both devices, checked to make sure no instances of LMS was running.

Roon is running on Windows 10, files for albums are on a NAS- about 20,000 tracks in FLAC, network is a wired gigabit on a D-link switch.

Hi @Frank_Pavlick ----- Thank you for the report and the feedback. The insight is appreciated!

Moving forward, to help aide in our evaluation of the behavior you are experiencing with your squeezebox endpoints may I very kindly ask you for the following information:

  • When you notice that internet radio is stopping (after a few seconds) and tracks are being skipped on albums, does the application generate any kind of warning/error message?

  • Do you make any of the mentioned observations outside of the ROON application when using the “transporter” and “classic3”?

  • In regard to playback of your locally stored content (i.e from the NAS) have you tried testing with media stored directly on the Win10 core machine?

  • If you have other endpoints in your setup, do they display any of these issues or are you only experiencing these errors when using your Squeezebox audio zones? How does playback via the internal speakers of the Win10 core hold up, any issues?


Thanks for the response.

I get no error messages. On radio, the pause symbol turns to a play symbol and in the music zone the currently streamed track name is displayed. For a recorded album, each track is displayed for about 4 seconds as it scrolls through them.

I have reloaded LMS and the squeeze devices play normally.

I have tried from the local machine with the same results.

I have a Bluesound NODE 2 attached and it plays normally. The internal speakers play normally.

Hi @Frank_Pavlick ---- Thank you for taking the time to answer my questions and providing the requested feedback. Very appreciated!

In light of your observations in your most recent update, would you please verify the model D-Link switch that is currently being implemented in your setup and furthermore can you please describe your network configuration/topology. I want to have a clear understanding as to how information is being passed along your setup and the tools you are utilizing to make these connections possible. You have already verified the use of a switch but having feedback on any additional hardware would be appreciated as well (i.e the type of router you are using, extenders, repeaters, etc).


The D-link switch is model DGS 1016D. The router is an ATT Uverse model 5268AC. All of the endpoints are copper wired directly to the switch with either CAT 5 or CAT 6 wire. There are no extenders or repeaters.

Thank you for that information @Frank_Pavlick, appreciated!

Moving froward, just to verify, you have “enable squeezebox support” set to “yes” in the application, correct? Furthermore, I am going to be enabling diagnostics on your account so our techs can try to get a senes to why you could be experiencing this behavior with the transporter and classic 3. What this action will do is the next time the application is active on your machine a diagnostics report containing a set of Roon logs will be automatically generated/uploaded directly to our servers. Once the report comes in I will be sure to confirm that we have it and then pass it over to our techs for further analysis.


Flac support is set to ‘yes’. Also in device setup Flac compression is set to ‘yes’. For a day or so I had connected a Pi device instead of the III but it behaved the same way. I have reinstalled the III.

Hi @Frank_Pavlick ----- Thank you for verifying that information for me, very appreciated!

Touching base to let you know that we have received the mentioned diagnostics report and that I have passed it over to our tech team for analysis. Once they have completed their evaluation I will be sure to share their thoughts/findings with you in a timely manor.

Thank you agin for your continued patience, while the team conducts their investigation!

Hi @Frank_Pavlick ----- The team has looked over the received diagnostics report and are unfortunately not seeing anything in logs that is pointing to the “cause” of this behavior.

In light of this the team has asked if you could please gather the following information/timestamps:

  1. Please reproduce the issue and note the time when the error occurs.

“Roon sees the squeeze devices - a transporter and classic 3 but stops internet radio after a few seconds and simply skips between tracks on albums”

  1. Please also take note as to what was being played (internet radio station, album, etc) during the troubleshooting exercise.

Once I have the above information, I will go ahead and re-enable diagnostics and have the team take another look.


All times are CST as stamped by computer.

This is for endpoint named Den. At 2:42 pm started internet radio- Houston Public Radio. Stopped before 2:43.
For same endpoint started an album (Forever) with 35 tracks. It had scrolled through them all by 2:45. Played from RAID.

For the endpoint named Family Room. Started internet radio-same station-at 2:45 and it stopped before 2:46. Started an album from RAID (Norah Jones with 13 tracks and it scrolled through them by 2:47.

For endpoint Kitchen - which is the Bluesound device I started at 2:54 and it is playing normally.

Thank you @Frank_Pavlick, this is exactly what I was looking for! Confirming that diagnostics have be re-enabled on your account and once we receive the new report I will be sure to let you know we have it.


UPDATE: Looks like the report just came in. Passing over to our techs for review.

Hi @Frank_Pavlick ----- Thank you again for your continued feedback and more importantly, thank you for your patience while our tech team has been looking into this behavior you are experiencing with your Squeezebox zones.

Moving forward, the tech team has informed me that they are not seeing anything conclusive in the Roon or RAATServer logs that we received with the diagnostics report from your system. In light of this the team has inquired if you are by chance making use of any firewalls or antivirus applications that could be potentially blocking RAAT.


I use McAfee for internet security. I turned it off yesterday to see if that would help but it did not. Are there particular ports that need to be open? Not sure if I mentioned it when starting this thread but one of the devices did play when I first installed but has not since.

Yes, there are. In fact there is a recent post which lists them. I will take a look for it, if you have not found it. Not at a desk currently and searching on a mobile is a pain.

1 Like

This is the post: