Roon constantly crashing during playback


I currently have my core running 64bit on Windows Server 2012 R2 on build 339 of Roon. My outputs are ethernet to a PS Audio DSj DAC, and two computers with Realtek ASIO/WASAPI drivers into Sound Desks/Pre-Amps.

My current issue is that when I stream music, be it from library or TIDAL, after between 1/2 and 10 tracks, I receive a warning saying Transport failed to load media. It tries to load a few more tracks before saying Too many failures, stopping playback. If I try to play anything else on any zone, the core crashes and no remotes can connect.
NB: It can particularly occur when pressing play now on an album during playback.

Things I’ve Tried:
I have tried changing most output settings in device setup and disabling DSP engine to no avail. I have also tried restarting my core server, again to no avail.

How to Replicate:
I am not entirely sure how to replicate as this never happened previously. I can however suggest trying to play on several zones at once and then playing another album.

James Conway

Thanks for reaching out, @J_C1, and apologies for the difficulties here.

So we can better understand what you’re experiencing, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Please also verify the following:

  • Does this behavior occur for all endpoints, or just one?
  • Can you confirm that Roon is up to date, along with the firmware for your devices?


All endpoints and firmware are up to date. This is happening on all endpoints. My network is connected via a 10Gb NetGear switch.

Hey JC,

Guessing it is a managed switch, first, try disabling IMGP snooping. If that doesn’t work verify that you are not using Jumbo Frames. If that doesn’t work you can search this site for all the various issues that occur with the managed switches.

I’ll try those tommorow, but I doubt that will change it since this never used to happen and I haven’t reconfigured my network in any way.

EDIT: IMGP snooping was off, as were Jumbo Frames, I also tried restarting the switch, all to no avail.

Hey @J_C1,

Just to verify, this is happening to endpoints that are not networked endpoints? Endpoints connected directly to the Core exhibit this issue?

Can you detail what kind of switch and router is in use here?

Also, where is you media library stored? Directly on the Core machine or elsewhere on the network?


Media library is on the core machine, these endpoints are connected through the switch like below:


I do not have a way to test connected directly to the core with crossover cables as it is an important server and cannot be disturbed. The switch is a Netgear managed switch and my router is a BT hub.

Thanks for the info here, @J_C1!

The Transport: Failed to load media error is typically caused by networking issues, which it sounds like you may be experiencing here.

Since we aren’t able to directly connect anything to the Core machine, I’d like to recommend another test. If possible, can you try connecting the Core machine and endpoints directly to the router as opposed to the Switch? Knowing if there is a change in behavior with this connection will give us greater insight into exactly what you’re experiencing here.


1 Like

Still not working in that configuration.

Thanks for giving that a try, @J_C1.

I’d like to propose another test here that should verify where the behavior is coming from. If you have another device capable of running Roon, can you try installing Roon and trying this on the same network with a fresh database? Do you experience the same behavior?


I might not need to try that, my server just had a massive failure last night due to the C: drive only having 2.9MB free! I’ve fixed this after hours of seeing ‘An operating system wasn’t found’. Am currently testing Roon since this and seems to be working so far! Will keep you posted.

1 Like

Glad to hear that things are operational so far, @J_C1!

Definitely keep us updated and let us know if you see any further issues.

Happy listening!