Roon constantly crashing with Tidal

Hello @support

since the 1.5 update Roon will not remain stable. Mostly with Tidal and back-ups. Whenever I connect to Tidal the connection is eventually lost.
Often saying ‘transport: failed to load media’ and then logs me out of Roon and takes me back to the Login screen.

Remove Tidal and generally function is consistent although there are occasional drop outs but I’m not logged out of Roon.
Occasionally I’m losing connection as Roon can’t find any Devices for playback. Either they reappear or I restart Roon and they’re back.

I have tried; clean reinstalls, repowering the router multiple times, with and without firewall, all rules to allow Roon and raat in place for firewall, a different Tidal account, using pc only, Android app only, iPad app only.

Connection is lost more frequently and faster when selecting MQA from Tidal.
With non-MQA it will play but eventually crash.

With NAS as source it’s generally ok if Tidal account is setup on Roon but will occasionally crash. As soon as you switch to Tidal, specifically MQA but eventually non-MQA also, it will crash and log out of Roon.

Login sometimes hangs, sometimes immediate, sometimes slow.

Tidal is functioning perfectly well independently.
Desktop, apps, and via Bubble Upnp (via Oppo 105d to Mytek) all function fine.

Although I hadn’t previously (before 1.5) backed-up I have now tried to back-up to various locations (NAS, Nimitra, Dropbox) unsuccessfully and lose connection when attempting to force back-up. It reconnects independently without need for login.

Please help!


My setup is;

Roon Core (ethernet)
Nimitra (Windows 10 32 bit)
via USB to Mutec mc-3+ usb
via AES/EBU to Mytek Brooklyn Dac+

Control (WiFi)
Lenovo pc laptop (Windows 10 Pro-64 bit, i5)
Android App
iPad App

BT infinity Router
TP Link switch

WD MyBookLive NAS
Tidal HiFi

Sounds like a issue with the network. Patch cable, ethernet card, switch, router etc. If so rebooting everything will not necessarily correct this. Maybe systematically temporary switch out or eliminate each component. Just a thought.


Possibly, but everything stable pre 1.5 update and the issues mainly arise when Roon is connected to Tidal. I’m unsure if the back-up issue is related since I’ve only attempted since 1.5.

Ethernet was from the TP-Link but now into Router and no difference.

Thanks for suggestions.

Hey @marc_w — Thank you for the detailed report!

May I kindly ask that you please verify the following:

  • Have you also tried power cycling the Core machine since noticing this behavior?
  • Do you experience this behavior if you just leave Roon running without playing music? Or is just when playing music from TIDAL? Is it always happening with the same endpoint? If you try to play to a different endpoint (system output on one of your devices) do you still experience this?

To further troubleshoot, I recommend trying the following:

  • Try using a different cable to connect the Core to the router.
  • Try pinging the Core machine the next time this happens. Is your Core accessible over the network?
  • Is there any antivirus software or firewall that may be contributing to this behavior on the Core machine? If so, try disabling them and see if the experience improves.

Since all remote devices seem to lose connection to the Core when this occurs, my initial thought is that the Core may be experiencing network difficulties, which is causing the remotes to lose connection. Let me know results the above tests yield for you.


Hi Dylan,

thanks for the reply.

I’ve tried power cycling the Nimitra, where the Core is, multiple times. Specifically after any change I’ve tried.

I had Roon (Radio) playing fine half the day today without Tidal.
Added Tidal back on and Roon crashed and logged me out. Logged back in and left Roon on without anything playing, just sitting on the Tidal screen for a few hours with stable connection, it crashed and logged me out of Roon again as soon as I tried to play through Tidal.

I added the Mutec a while ago but the issue is the same with or without the Mutec in the chain.

Issue is the same when using System output on laptop as endpoint.

The Nimitra remains accessible on the Network whenever Roon crashes.

I’ve tried different ethernet cables direct to router and to TP-Link switch. (cables are from Blue Jeans so tested before sale).

I uninstalled the antivirus software and tried disabling Windows Defender Firewall to no effect. When active the rules are in place to allow Roon and raat.

Most of the time it will lose connection to Tidal, crash and Log me out. Only occasionally do the devices disappear while I remain logged in.


Thanks for the details, @marc_w!

I noticed that the Nimitra you’re using for your Roon Core falls short of our recommended specs.

Because this device uses an Intel Celeron processor you may experience performance issues, particularly with larger libraries or DSP, or if you don’t use an SSD for your Roon database.

I know you mentioned this setup was working before, so it’s hard to say whether the issues you’re experiencing are related to performance, but we do like to give people a “heads up” when their system is under spec, since it can impact the product in a number of ways, and you may encounter some limitations going forward.

For next steps here, I would like to recommend the following:

  • May I ask that you please verify if this behavior happens for all endpoints? If you play to system output, does that exhibit the same behavior? I’m guessing the answer to this will be “yes”, but knowing for sure will help us narrow down the root cause of you are seeing.
  • In the past, we’ve seen that some have had success using Google DNS to improve their TIDAL experience. Try following the instructions in that link and see if the experience improves.


Hi Dylan,

Roon functions perfectly on all endpoints (Inc. system output on pc, Android, iPad), without Tidal. As soon as Tidal is added back in it crashes and logs me out.

I’ll give the Google dns a try tomorrow. Weather is too good in Scotland right now so it’s bbq time!


Thanks for the update, @marc_w!

I’d also like to recommend another test for when you set up Google DNS:

  1. Shutdown your Roon Core
  2. Find and open your Roon database
  3. Navigate to /Library/Roon/Cache
  4. Move the contents of the /Cache folder elsewhere, like your desktop
  5. Try restarting Roon and syncing Tidal

Enjoy the nice weather!


Hi Dylan,

unfortunately my BT Home Hub 5 router does not allow for the DNS settings to be changed. This is by design from BT, apparently.
Nevertheless, I tried moving the contents of the cache folder and restarting Roon/syncing Tidal and again lost connection to Roon. So no change I’m afraid.


Thanks for the update, @marc_w!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Login; 00:21 BST 01/06/18
Playing Tidal Roon crashed 00:24

Thanks, @marc_w! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hey @marc_w,

Thank you for your patience as we continue to investigate this.

I spoke with the technical team today regarding their analysis of the diagnostics report. The report is showing some signs of drive issues that may be causing the behavior you’ve seen.

To test this out I’d like to recommend moving your Core to another machine temporarily and trying to play TIDAL. Do you experience the same behavior on the other machine?


Hi Dylan,

thanks for the reply.

What are the ‘drive issues’ mentioned in the report? It would be useful to allow the manufacturer of the Nimitra to address these.

I don’t have another suitable machine to try with the Core available to me right now.


Hey @marc_w,

This is what the technical team was seeing in the report:

System.IO.IOException: There is not enough space on the disk

Is storage full on the Core machine?


Hi Dylan,

thanks for the feedback.

It appears I inadvertently setup databases for both Roon and RoonServer causing storage to fill up. This was after the initial stability issues arose when I tried re-installing to solve the issue.

Whatever the initial issue was I now have Tidal functioning and only the occasional drop out. It isn’t logging me out, I just hit play and starts playing again. I’ll let you know if there are any further issues over the next few days.


1 Like