Roon constantly crashing

Hi. I am a new Roon user, still in the trial phase, basically testing whether to change over to Roon from my long-term JRiver system.

For the past 5 years I’ve used JRiver, on a computer extensively modified to extract maximum goodness for my bits: fanless i7 Haswell with 16Gb DDR, running Windows Server 2012 R2 with AudioOptimiser and JPlay; and separate isolated battery power for motherboard, JCat USB card, and 3 x SSD. The music is on 3 drives: 2 internal 500 gig SSD’s and one external WD 3Tb NAS connected directly by ethernet cable to the computer.

When I initially tried to install Roon, having backed out of Audio Optimiser as far as possible, I had problems with video drivers (I’m using the built-in video, not an external graphics card) – what I gather are the usual OpenGL issues. I solved this by finding a new video driver online, and after that Roon seemed to work – though it struggled with initialising the database – I have over 50,000 tracks.

My DAC is an MSB Technologies Reference DAC, with the MQA enabled Quad USB input module connected to my JCat USB card.

Currently I boot into Windows Explorer, from which I can select either JRiver, Roon or the Tidal app. JRiver connects to the DAC through the JPlay Kernel driver. I disabled all the possibilities on Roon except for the MSB ASIO driver.

My problem is that Roon keeps crashing. Whereas JRiver is completely stable, Roon will only play for between 30 seconds and 10 minutes before it closes down. It’s not that the computer shuts down, just the Roon app. And it’s very slow to open – at least a minute.

I did notice that, although I’m getting the purple seal of approval, when I’m playing Hi-Rez PCM the front of the DAC shows the bit depth varying between 20 bits and 24 bits, which it never does with JRiver.

I would like to stick with Roon – it’s got much better metadata than JRiver, I like the integrated Tidal streaming, all and the SQ seems to have improved markedly from when I first tried it 2 years ago, but I need to track down this problem.

Any thoughts?

Hi @Graham_Thorburn1 ----- Thank you for the report and sharing your feedback with us, both are very appreciated!

Moving forward, may I very kindly ask you to please provide me with the following information:

  • How often does this crashing behavior occur (every hour, twice a day, etc.)?

  • Is there a specific file format or bit rate you are streaming (consistently) when this issue occurs?


I did once get a couple of hours, but mostly it’s between 30 seconds and ten minutes. A couple of songs or so. And seems to mostly be with hi-rez pcm, but I’m not sure. Got sick of it and went back to JRiver.

Sorry for the frustration here @Graham_Thorburn1 – totally understandable.

We just enabled some extra diagnostics on your account. If you start Roon again, it should submit a report to our servers with logs so we can understand exactly what’s going on here – I’m guessing we’ll be able to resolve this for you once we get a look at that info.

Let us know when you’ve had a chance to start the app up once more, and we’ll take it from there. Thanks for your patience here.


Well, I’ve been running it for an hour or so. Crashed twice so far - both times within ten minutes. I’ll go down and kick it off again now. Noticed that it often shows less than 24 bits on the front of the DAC - often fluctuating between 20-24. but I have the purple seal of approval.

Running a different playlist now - only DSD. Seems to be the most stable it’s been - even up to 4 x DSD - been running about 40 minutes now. So it seems that PCM - 24/96 or 24/192 is the problem.

Damn!! Discovered a different problem - I have a ‘master copy’ of all my files, and my NAS is automatically synchronised with this. But I had to move all my (hundred odd) playlists onto the NAS, because Roon will only work with playlists that are on the same hard drive as the files they refer to - you can see where this is going, can’t you?..

Hi @Graham_Thorburn1 ---- Thank you for the follow up(s) and the feedback! Both are very appreciated!

Moving forward, I can confirm that we have received the diagnostic report from your system and it is currently with our techs who are evaluating the information found in the log traces. Once my report has been updated and passed back, I will be sure to share the team’s thoughts/findings with you in a timely manor.


Hi, @Graham_Thorburn1, may I kindly ask you to remove this file:
“Z:\DOWNLOADS - CD-REZ\decca_Downloads\09_Piano_Concerto_No_21_in_C_K_467_2_Andante.mp3”
Because our analysis showed that it must be the reason why your Roon is constatly crashing. Please, share the result with us here.



1 Like

OK - did that, and fingers crossed, so far so good. If you don’t hear from me, it’s fixed, and thank you. I didn’t even realise that I had any mp3 files in my collection. By the way, found a way around the playlist problem - now all I have to do is work out how to shuffle within playlists on the PC screen (I’ll go and check for other posts on this).

Good to hear that, @Graham_Thorburn1! Hope after this the issue will be resolved and you’ll continue to enjoy your music using Roon.

P.s. We want you to send us that file, I contacted you via PM with additional info.



Sadly, the problem has returned. Approximately every 3:48 seconds Roon crashes - whether it’s playing files from the NAS, the internal HDD or Tidal. I’ve scanned my NAS for any stray mp3 files, and eliminated the three I found - but made no difference. Luckily JRiver works without a flaw, so I’ve reverted to that (temporarily?)

Sorry - I meant every 3:48 as in 3 minutes 48 seconds (and I’m being a bit facetious - I didn’t actually put a stopwatch on it - just noted from the running times of the songs that it was between 3:40 and 4:00)

Hi @Graham_Thorburn1 ----- Thank you for touching base with us and sorry to hear that the issue has continued.

Moving forward, upon seeing your update I have went ahead and re-enabled diagnostics on your account so we can try to get a better handle on what could be causing the issue(s) on your setup. Once the new diagnostics report reaches our servers, I will be sure that it makes it way into our tech team’s queue right away.

Furthermore, I am curious as to what troubleshooting you have performed with your setup. I know currently from your posts, Roon is being hosted on the mentioned fanless i7 Haswell (WS 2012 R2) and that you had a bit of trouble getting things up and running on this unit at first. By chance during your troubleshooting, have you tried letting another device (temporarily of course) host your Roon core?


OK. Painstakingly went back to constantly restarting Roon in order to generate something to diagnose. Can I assume that 5 times or so will be sufficient?

Hi @Graham_Thorburn1 ----- Thank you for touching base with me, appreciated!

In regard to your question, 5 times should indeed be enough. Once our tech team have completed their analysis of the most “recent” diagnostics report mentioned in my previous, I will be sure to share their thoughts/findings with you ASAP. Your patience is appreciated!


Any news yet? The problem continues.

Hi @Graham_Thorburn1 ---- Thank you for your continued feedback, but more importantly, thank you for your patience. I have just sent you an update via PM.

Looking forward to your update!

Ok. No .mp3 file of that name, but a .flac file of that name in that location - ripped from CD. I eliminated that, and so far so good. Why would a flac file appear as an mp3 file in your diagnostics? And why is it a problem?

Hi @Graham_Thorburn1 ---- Thank you for touching base with me, I appreciate the follow up.

Just to reiterate a bit, I would still recommend removing the entire album from the watch folder (i.e \RIPS - CD-REZ\Włodek Pawlik\ Songs Without Words) as mentioned in the PM. Furthermore, in regard to “why” the mentioned track is appearing as an MP3 in our diagnostics is tough to say. Is it possible that you have (or had), two copies of the album “Songs Without Words”?

Lastly, I can ask our techs if they have an understanding as to “why” the media was the problem, but my sense is that in order to determine exactly why we would have to do some further testing with the media in house.