Roon Core does not restart anymore after Windows reboot

Roon Core Machine

OS Name Microsoft Windows 11 Pro
Version 10.0.22621 Build 22621
Processor AMD Ryzen 9 5900X 12-Core Processor, 3701 Mhz, 12 Core(s), 24 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 2806, 10/27/2022
SMBIOS Version 3.3
Embedded Controller Version 255.255
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product ROG STRIX B550-F GAMING (WI-FI)
BaseBoard Version Rev X.0x
Total Physical Memory 31.9 GB
Available Physical Memory 21.0 GB

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

It was all working fine until about a month ago. I tried to connect to my Core and it was not found. Went to the PC running it and RoonAppliance was not in the Task Manager list. Tried restarting RoonAppliance directly and it did not work. Right clicked and started it as Admin and it started up and all was fine. It stays running and working fine after that. Until … I reboot windows for an update or something. The RoonAppliance does not restart automatically after the reboot and I have to manually start it (as admin).
I’m sure some update changed something, and thought about re-installing the core to let the install maybe fix it. But didn’t want to risk breaking something else with my library since there are a large number of songs and lots of time spent cleaning the current database up.

Also, am on version 2.0 build 1272 and it claims I have the latest. Found this in my Application Event log from a reboot I just did:

Application: RoonServer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeLoadException
at Sooloos.App.Main(System.String[])

Fellow user here.

Not exactly clear, if you were/are running Roon’s server or GUI version on your core.

My recommendation is to install both, server starts with the system, GUI could be auto-started as well or only if there’s a need to control from there.

Also add/verify Firewall exceptions.

I am running both on the PC. And have UI on my phone as well. I do start the UI on demand and do want the server (RoonAppliance.exe) to start on my PC (core). And it used to. That is what somehow changed. It no longer restarts on reboot (say a Windows Update). So when I start the UI on my PC or phone, it will take a while then say it can’t find my core. Then I have to go to the PC and navigate to the server folder and manually start the RoonAppliance.exe. Then everything keeps working until the PC is rebooted again for any reason.
From the log messages, it does seem like it is trying to auto-start, but gets the error I posted. And it won’t restart unless I start it by selecting Run as Administrator.

So, clicking “Roon server” from the applications drawer does not work?

And, once you started RoonAppliance.exe manually, does right clicking the icon in the system tray show “Launch on startup” as ticked?

Maybe that’s due to it having been run with admin rights?

If you’re not manually deleting any Roon related folders prior to reinstall, your work should be retained - but I can’t vouch for that, of course, and even taking database backups (do you?) doesn’t seem to guarantee keeping everything intact on restore.

If now, you’re still stuck, only @support may be able to further assist, so I tagged them now for some additional visibility of your issue…

Clicking the server or appliance without admin seems to do nothing. So seems it needs admin rights for sure. It does not show in the system tray though. I can only see it in Task Manager. Its there and working fine though :slight_smile: And it is not in the registry at Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

For the current hassle of starting it manually I didn’t want to take the chance of breaking what is otherwise working and re-installing. Was hoping maybe an update would fix it. Do have backups on but have seen enough in the forums to make me not want to risk re-installing. Lots of effort to clean things up and configure it.

1 Like

CAn somebody at Roon explain on Windows how Roon Core is started so I can check that it is configured correctly. It sort of seems like it tries to start but gets the .Net error I posted. And since it runs manually when started as Admin - did some Windows update change permissions so it used to start as normal user or something. Need some details/facts from Roon devs here and I could probably figure this out.

Hey @Ed_Wegryn,

Thanks for your patience! I’ll take your issue to our development call to discuss further.

In the meantime, do you know if you have any recent backups saved? If so, it would be good to re-install Roon.

  • Make a Backup of your current RoonServer Database (or make sure you have a saved backup)
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

As noted, I do have backups and would make a new one first anyway. But since it works with manual starting, really prefer not to take the chance on goofing something up since I have seen plenty of posts where things were working until a re-install. Maybe that is needed, but was hoping to either get a clue here to fix it more surgically - or for an update to maybe fix it.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.