ROON Core Issues

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

After much finagling, swearing and with a little help from this forum I have finally transferred my ROON to a new Dell Inspiron computer. ROON sees all of my music and will play correctly on devices attached directly to the computer and to devices on my network.
My problem is that the system cannot “see” the ROON OS Core either on the computer itself or on any remote device. Going to Settings - Setup - Find ROON OS just gives me a rotating search wheel with no results. When I open the ROON App on my Pixel phone or my Samsung tablet the App just hangs up searching for the Core. Have verified all basic troubleshooting hints and have tried putting the IP address or host name into into my remote devices with no luck.
What am I missing about the ROON Core??

What do you see when you go to Roon - Settings - General on your Dell? You should see this…

We need a bit more information. If you are running the full Roon app on the Dell, it seems like this is your Core. If “ROON sees all of my music and will play correctly on devices attached directly to the computer and to devices on my network”, then it seems like everything is working just fine if you are using the Dell?

Note that the “Find ROON OS” is for finding Cores running on Roon OS, i.e., Nucleus, ROCK, or some similar 3rd-party devices. If your Dell with full Roon is your Core, then you don’t need that.
(Unfortunately this is not quite clear if you are not well versed in the Roon lingo. Changing this to something more descriptive has been requested several times)

“When I open the ROON App on my Pixel phone or my Samsung tablet the App just hangs up searching for the Core” seems like the apps have trouble finding the Roon Core on the Dell. If the Dell is wired to the network, it is possible that your router is configured to use a different subnet for wired LAN and wifi. This would prevent the apps from finding the Core. Please post the IP addresses used by the phone and tablet, and the IP address used by the Dell

Your image is exactly what I see on my Settings - General tab.

OK, then. There’s your core. If you do what you said, you’ll see this…

When I look at the ROON Audio setup it does not show either my phone or my tablet as other network devices. Not sure if this is a problem or not. All equipment it the house is hooked to the same home WIfi network. ROON does show my Google Home and Google mesh WiFi points throughout the house with IP addresses. Dell shows IP, Phone, Samsung tablet, Google Home and my Google Chromecast is

Yes, I see that but it ends there. ROON never says anything about seeing the core and my remote devices hang up here continually searching for the core.

Phones and tablets are by default configured as private zones because it is unlikely that one wants to remote play to a phone. They are only available as outputs on the phone and tablet itself. To see them elsewhere, you have to go to Settings > Audio on the phone/tablet and change this:

I.e., this is the case even if everything works. In your case they probably won’t show up as an output zone on the Dell even after you turn “private” off.


Most of these might be different subnets though. It depends on the so-called netmask (also called subnet mask) that is configured on your router, which would be something like (a class C network, which is the most typical for home networks) or (a class B network). The netmask that your router is configure to use should be shown somewhere in the LAN configuration on the router. Each 255 in the netmask “masks” the network part of the address, allowing the individual machines to have device numbers where the zeros are.

So with a netmask, the individual machines would all share the same network number in the first three blocks, and only the fourth number would differ for each machine. E.g., one machine would be and another, and a third They would all be on the same subnet, “1”. (You can then have 255 individual machines)

With a netmask, both the third and the fourth number identify machines, so there could be a machine and another, and they would nevertheless be on the same subnet. (This allows for having many more individual machines, which is usually not necessary in home networks and therefore is quite unusual)

192.168 is the LAN network in either case. In most home LANs, the netmask is, which would mean that only the forth number identifies individual devices and the third number in your configuration (87, 12, 86) would identify different subnets.

Subnets can be used to structure LANs and separate devices, but the problem then would be that Roon’s device discovery does not traverse across subnets. In this case, the Dell and the Chromecast would be on subnet 87, the phone on 12, the tablet and the Google Home on 86. Which would be a somewhat weird setup though. But it would explain why Roon neither on the phone (12) nor the tablet (86) can see the Core on the Dell (87)

E.g. on my network with a netmask of, they are all on the same subnet 178 and only differ in the fourth number:

Please go to the admin web page of your router, find the LAN configuration part and post a screenshot. It should look something like this (from my router)

Just had a very interesting but frustrating with T-Mobile regarding their 5G Home Internet. I have an Arcadyan KVD21 5G home internet router and the tech people DO NOT have any access to the netmask settings and cannot tell me if it is a class B or class C netmask. Since the T-Mobile gateway is plugged into my Google mesh router I will try to see what netmask that router is using. In any case, I guess I will have to change my subnet numbers so they are identical??
The tech did say I could try to get a Nokia gateway from T-Mobile and then I would have access to that data.

You hopefully use DHCP on the router for automatically assigning IP addresses, and hopefully only either the Arcadyan OR the Google Mesh has DHCP enabled. Only one router may assign addresses or you will get a holy mess.

I would hope that you have access to the admin page of both routers, you don’t need the T-Mobile people for that. The class B vs C and your local IP addresses concerns your LAN, it’s not their concern really.

If you use DHCP as you should (and would be the default on any router), you by yourself should not change or have to change any addresses. The DHCP service should assign them based on its settings, like in my above screenshot. Note that the subnet mask here is configured as (the router’s default) and the DHCP server automatically assigns only addresses in one subnet between and

Something like this is by far the most likely default configuration on any home router. Depending on the router, it may be possible to create more complex configurations with subnets and so on, but I don’t understand really how the addresses you listed were configured, unless someone did that on purpose.

Some routers have the option to use different subnets for wifi and wired LAN, but if you have a netmask then I don’t understand why you have three subnets.

Before you make any changes it would be good to understand what the current configuration really is (it might still be a netmask) and how that came about. Post screenshots of both router settings ideally

Google’s default is 192.168.86.x is the Arcadyan gateway.

All Google Nest Wifi devices use the network. Any other networks, like, are assigned to devices on the Guest Network.
Can you check please if the Guest Network is turned off?
Don’t forget to reboot everything afterwards.
And, just to be sure, are there any switches on your network? These could also create another subnet.

Unfortunately, the Arcadyan gateway can’t be set up for bridge mode and there are no settings on this router related to NAT and DHCP that you can tweak. is the IP address to access the Arcadyan gateway settings. The best way to do this is to install the mobile app first.
Set up a new and different wireless SSID for the Arcadyan, so devices can connect to this wifi no more.
Don’t forget to write this down so you can keep your 5g modem accessible.
The Google Nest WiFi system creates an inner network separate from the outer network created by the Arcadyan KVD21 unit.
Because the Google system is also a firewall, there are limitations on how devices on the inner and outer networks can talk to each other.
Hopefully, the solution here is to connect your Ethernet devices (e.g. your ROON core on the Dell Inspiron, perhaps other units for audio as well?) to the inner network created by the Google primary unit. To do this, use the LAN Ethernet port on the primary Google unit. You can connect an inexpensive unmanaged Ethernet switch like a Netgear GS108 to this port to make more ports available. The Google Nest WiFi unit’s WAN Ethernet port should be the only thing connected directly to your Arcadyan KVD21 unit.

In case the guest network is disabled and no switch within your network you will have to try to set up a custom LAN IP range:

Unfortunately, it seems that this modem can’t be set in bridge mode either.
Perhaps, if you can get one, I have a Huawei CPE Pro 2 I can really recommend.

1 Like

Let’s summarise; you have two issues:

  1. Searching for a Roon OS Core using Roon on your Dell fails
  2. Your remote devices can’t find your Core.
  1. is a non-issue: your Core is running on your Dell Inspiron computer, which is running the Windows OS. You don’t have a Nucleus or a NUC that has had ROCK installed on it - they are the only two devices that use Roon OS - therefore, Roon won’t find an instance of Roon OS, because it doesn’t exist in your setup.
  2. is because you appear to have several different subnets set up in your home network. Roon doesn’t work across different subnets.

Firewall rules will hide the dell core. Thank windows for that…

Let’s get his different subnets sorted first before we start worrying about Firewall rules…


6 posts were split to a new topic: The “Find Roon OS” Function is Confusing

Hi @Ed_Littleton ,

As others have noted, your Roon Remotes are unable to connect likely due to a firewall. Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.