Roon Core not in sync with Roon Remotes tell me is playing

Roon Core Machine

  • Ubuntu Server 22.04.1 LTS on an Intel NUC11TNHi3
  • The OS, applications and all my CD rips are stored on a Kingston NV2 PCIe 4.0 NVMe 2TB SSD
  • RAM memoy in use is 1x Kingston ValueRAM 8GB at 3200MHz

Networking Gear & Setup Details

  • Netgate 6100 pfSense router
  • 1x Ubiquiti UniFi 6 Pro Wi-Fi

Connected Audio Devices

  • 3x Sonos One SL

Number of Tracks in Library

18059

Description of Issue

Whenever I am playing something and I queue something else, the Roon Remotes seem to be living in the future. Playback is half a song or so behind what is being displayed in the clients.

I also see this on Last.fm where Last.fm thinks I am already playing the next song while the previous one is still being played on the speakers.

Just an idea and you may even have tried that already, but …
… did you restart core and remotes?

Great idea and it is indeed something I already tried. The issue returned tho. I am not sure it returned right away…

Hi Eric
I do not know if it has any connection but have you tried resync delay after the restart?
Screenshot 2023-02-12 at 12.53.24

Oh wow! I did not even know about this. Will give it a try!

At settings/audio click on the settings for the endpoint and device setup. Maybe it works, hope it works

Damn, does not seem to be available for Sonos devices. I have the functionality for everything else, except for the Sonos. Maybe it is related to Sonos.

I’ve never used Sonos. I think has this for RAAT endpoints (my Yamaha airplay also does not have this). But from others a know that Sonos has its own app, maybe you find there the same setting

Are the ones set to use WiFi or Sonos mesh?

They use my Wi-Fi network. If only I had the option to connect one via ethernet and use the Sonos network. Because I live in a very small studio apartment, Wi-Fi reception is excellent.

Hey @ericafterdark,

I wanted to check in on this thread to see if you were still running into issues with your remotes skipping ahead? If so, could you please share a timestamp the next time this happens?

Does this happen if you temporarily disable Last.fm? Does this happen when playing content to the system output of your remote device VS your sonos one?

It would be good to test out if this issue occurs on any specific type of content, like tracks from your local library, or streamed tracks from Qobuz or Tidal.

I’ll be on the lookout for your reply. :+1:

The root cause was the Sonos protocol.

I did not experience a problem when using AirPlay with the exact same Sonos speakers.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.