Roon Core on MacOS timing out, high CPU rate

Roon Core Machine

I am running Build 970 (latest) on an i7 iMac, quad-core, 16GB RAM. Full details are displayed in the video.

Networking Gear & Setup Details

Core is connected via ethernet to a gigabit switch and that switch is connected to cable modem. SpeedTest run on the core gets 488 Mbit/sec download speed.

Connected Audio Devices

I use Roon on my Mac laptop, iOS iPhone and iPad OS iPad - all are updated to latest version. When using Roon on a laptop it cut out several times saying “waiting for Roon CORE” before restarting playback.

The audio chain was being channeled to an Auralic Aries streamer that is connected to the same ethernet switch as the core. Laptop is connected over wifi in the same room. Performance didn’t change when using Roon Core iMac directly.

Number of Tracks in Library

~144K, over half are via Qobuz.

Description of Issue

Roon core is “not keeping up” to be able to play music without dropouts. In the past I’ve watched Core run at around 8-16% CPU cycles via top. I restarted the app several times and it always ran over 100% CPU, even with no playback. The log suggests there’s a lot going on in the background connected with Qobuz.

I recorded the Core’s screen in Remote Desktop to capture what was going on.

Included are the log file for the relevant time and the Core running with top -u in Terminal

Let me know if you need additional information. I’d like this to work.

Not a lot of extensive testing, but I upgrade the Core today to build 988. It’s now running at what I’d consider reasonable CPU cycles, 4-20% with one connected computer streaming a Qobuz album! Very happy this update resolved this issue.

Still experiencing the iPhone app quitting as a remote control. It’s accompanied by a hot feeling on the back of the phone. I do not have this issue on iPad OS. A restart of the phone will remedy the situation, force-quitting the app does not; until it eventually returns.

Hi @John_Hendron ,

Thanks for the update here, glad to hear there was an improvement in behavior!

Are you making use of any VPN services on the iPhone? Do you also have an IPSEC interface in your iOS logs? Please see:

Yes, I use ExpressVPN. I am happy to try with it turned off and have; but will I have to restart with it off?

A restart by itself is known to help with the crashes. You can try to disable the VPN and restart, but then the remote might have stopped crashing due to the restart.

How do you have this configured? Are you using an IPSEC tunnel? Are you using IPv6 in your VPN or router?