Roon core on one mac mini doesn't see roon bridge on another mac mini

Hi, saw a few others had a similar problem but no obvious solutions posted.
Downloaded roonbridge to second mac mini (called “LR”), connected to my marantz.
(trying to play multichannel music from my mac mini core to my home theater)
Firewallls disabled
On the same network
Computers rebooted
In roon-> setup, I don’t see the mac mini as a roon audio target.
Thoughts would be great…

Hi @Peter_Galvin1 ---- Thank you for sharing this observation you have made with us! the feedback is greatly appreciated!

Moving forward, to help aide in out evaluation of this behavior may I very kindly ask you to please provide the following:

  1. Please expand on the description of your current setup using this link as a guide.

  2. Describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the tools involved with making those connection possible.

  3. If you go into “settings” > “about” on one of your Roon remotes, is the MacMini hosting Roon Bridge listed there?

  4. If you set the MacMini up as a Roon remote devices temporarily, is it able to connect to the core machine without issue?

  5. Before loading Roon Bridge onto the MacMini was the device being used for anything else related to Roon?


Hi Eric, I think we might be on to something. It was back in the day a full roon server and still has roon installed on it. But not running of course. Do I need to remove roon or some such?

Hi @Peter_Galvin ---- Thank you for the follow up!

I would still like to have the feedback from the other questions in my previous post just so we can have those data points but let’s try testing with the MacMini in a completely “fresh state”. Kindly perform the following:

On the MacMini…

  1. Locate the following folders using these directions as they will all be in the same directory:

    • The previously used “RoonServer” folder.
    • The newly created “RoonBridge” folder from the recent install.
    • Any pre-existing or newly created “RAATServer” folder(s).
  2. Once these above folders have been located please delete them and then “empty” the trash bin. Take note that this action is permanent so please be sure that you do not need the previously used “RoonServer” folder for any reason.

  3. After the folders have been deleted, please reinstall “RoonBridge” on the MacMini and launch the app. When “RoonBridge” is active you will see a “Roon icon” being displayed at the top right hand corner of the screen, very much the same way you would see the icon when “RoonServer” was running on the device.

  4. Check on your Roon remote to see if the MacMini is now available as an audio zone.


On my mac in ~/Library removed “Roon” “RoonBridge” and “RAATServer” folders, also deleted app “roon”. Emptied trash. RE-installed Roonbridge. Rebooted. It’s running as shown via the menu bar.
Still no love from the roon server.

Roon server:
1.5 build 363
Macos 12.14.2
Mac Mini 2018
Music stored on 2 external drives “macbt” and “hires”. Macbt is where the itunes library lives and the media files that itunes plays.
In roon storage setting, “music folder” is disabled and those 2 mount points enabled.
194,000 tracks

Roonbridge system, mac mini, 10.14.1

Each mac is both on wired ethernet (same subnet, can ping and ssh each other), and on the same wifi network. I tried disabling the wifi but still the same problem.

on my iphone, settings - > remote the phone is version 1.5 (build 360), and I see both Core and Roon Bridge.

to setup the roon bridge mac as a remote, I need to install full roon, yes?

Hello @Peter_Galvin,

We have opened a ticket with the tech team about the issue you are seeing, they are investigating your report. In the meantime, they asked if you could disable WiFi on both devices, and then restart both computers. We have encountered a few instances of MacOS incorrectly routing traffic when there are two active network interfaces with IP address on the same subnet, restarting the computer has been known to resolve this issue.


Thanks. ssh etc wouldn’t have worked if routing was wrong. But I did reboot both with wifi off and still no go from roon. Thanks for working on this.

Hello @Peter_Galvin1,

We believe this may be caused by a cache issue in your Roon Database. Here are some steps to refresh your endpoint cache and restart the discovery process. This will delete saved endpoint data such as zone names and DSP configurations, so if you have a complicated setup be sure to note how you had things set up. Please also ensure that you have made a Roon database backup before continuing.

  1. Quit Roon and Roon Bridge on their respective computers.
  2. On the Mac running the Roon Core, navigate to the ‘~/Library/Roon/Database/Registry/Core’ directory.
  3. Find and delete all files beginning with “endpoint”, “raat”, and “raatserver”.
  4. On the Mac running Roon Bridge, navigate to the ‘~/Library/’ folder and delete the “Roon Bridge” and “RAATServer” folders.
  5. Restart Roon and Roon Bridge on their respective computers.


Thanks, but that didn’t seem to change anything.

What router and switch(es) and access point(s) are you using?

No access points as I’ve turned off Wifi.
Will check actual switch versions when I’m home, but scary to think Roon might have a problem because of a brand of 1Gb ethernet switch is used…

There were some network setups that did not work well for some people here, that’s why I asked. See

It’s other way round - hypothetically even if this is eventually traced to a router or switch, it’s not because Roon has a compatibility problem with it, it’s the router / switch (or a certain configuration of it) that does not support the multicast traffic required by Roon and other applications (there are other multicast based applications unrelated to Roon), even if it works fine for web browsing. It also happened several times before a faulty switch due to age does not behave well with multicast but still allows for web browsing.

Interesting. I’d think they’d all do multicast. I believe that’s part of the ethernet standard.
Anyway I have a netgear prosafe and a linksys SR2016. Connected together to form one network. I can try connecting the bridge system to the same switch as the core system and see if that solves the problem…

I plugged them both into the linksys and still no sign of the other mac mini from the settings->audio page…

Could you plug them both into the Netgear (swap the switches if necessary), then reboot both machines? And what exact model number is the ProSafe?

Yes, moved to netgear, booted up, same problem - no sign of the bridge system on the core system.
It’s a GS 116

Firewall on both Mac are disabled right?

Is your Mac Mini 2018 having a 10Gb Ethernet port?

Hello @Peter_Galvin1,

Thanks for your patience while we continue to investigate your report. I spoke with the development team yesterday, they believe they may have found the cause of the behavior you are seeing.

Roon uses a unique identifier for client installations that is generated by using some hardware information as a seed. This identifier is stored in a file in your home directory called ‘.rmembid’. What we believe is happening here is that by transferring your Roon Core from one computer to another, there is a discrepancy occurring with the unique identifiers that is causing your new Mac mini to look for the old instance of the RAATServer process.

Since the Roon client looks for the ‘~/.rmembid’ file at runtime and generates a new one if it is not found, the best way forward here is to simply delete the file on both of your Mac mini’s and have them regenerate upon restart of the Roon client. Please remember to quit Roon Server as well as Roon Bridge on their respective computers before doing this.

Once you have deleted the .rmembid file, you should also go ahead and delete the “RAATServer” folder in your ‘~/Library/’ directory.


Yay! That fixed it. Thanks much!

1 Like