Roon Core seeing PC as endpoint

Very new to all streaming issues, but have set up the following over the last week:

  1. Roonserver 64 bit on new Dell Micro PC running Windows 10, connected by Ethernet to WIFI router. It currently has a monitor on it for purposes of commissioning and setup and testing, but intend to have it sitting unattended and unused for anything except Roon.
  2. Full PC version of Roon on Dell laptop, Windows 10, usually connected by Wifi on same network as Roonserver, followed direction to only set it up as a Remote. This PC is only intended to be a comfortable place to do hardcore curating of Tidal/Roon, not for quality playback.
  3. Various Google Home devices and Google Audio devices which automatically show up as possible endpoints, a few connected to various radios and soundbars around the house for streaming background music for parties. All Wifi connected.
    4.Lumin D1 with Sbooster power supply, connected by Ethernet to my main two channel system, Herron preamp and monoblocs.
  4. Set up new Tidal account and seeded with Collection suggestions, curating and have plenty to play with for now.

Okay, pretty impressed overall that everything works well enough that everything more or less works. Have Roonserver set to sleep and using Wake on Lan app on Android to wake it up when needed, and set to have autologin when re-booting.

My admittedly not very critical issue I can’t figure out, is that when the Core wakes up, and I bring up Roon Remote PC on the laptop, everything connects, I can see and use Roon, but the PC itself doesn’t show up in Settings/Audio so that I can Enable its basic system audio function. If I reboot the PC while the Core is awake, the PC shows up as connected and available for output. I’ve read about Bridge, but don’t understand if I need that when using a Windows PC as the Remote. Why can the PC connect to Core, but Core doesn’t show the PC unless I reboot?

And sorry if I posted this in the wrong place, I find the website/Knowledge Base/Community structure pretty confusing, usually end up going to Google to type in a question and find it does a bettet job of searching the site for answers.


Hello @Tim_Fontenot,

Thanks for contacting support, I’d be happy to assist here. I have a few questions provide proper troubleshooting advice:

  • Can you please let me know the model/manufacturer of your WiFi router?

  • Do you by any chance have any Antivirus or Firewall software on the Roon Remote which could be preventing Roon from connecting until it is rebooted?

  • If you connect the Roon Remote via Ethernet as well, do you still experience the same issue when waking it up?

  • Can you please post a screenshot of your Roon Settings -> Audio tab when the issue occurs?

  • Are you still able to ping the Core from your Remote after waking it up? You can use these instructions to run a ping test using Command Prompt on Windows and I would check to see if you are able to ping the Core after waking it up.

  • Are both Roon and RAAT listed as exception on your Core & Remote Windows Defender Firewall Settings?

Please let me know the above information when possible.


I think we have seen this before…missing local devices after revival from sleeping pc and or macs

My router is an ASUS RT-AC68U
When installing Roon on the Remote PC your app popped up a message concerning Windows Defender problems and asked to allow Roon/Raat, which I approved. Before contacting you I had read about checking Defender on both machines to enable roonserver and raatserver on both public and private networks, checked both of those yesterday, and could see entries on both machines for roon and ratt checked off for both networks.

Yesterday afternoon I tried something new, loaded Roon app on a Samsung Galaxy android tablet while the Core was shutdown/sleeping. When the app came up, after using Wake On Lan app it connected to the Core and was able to play music to the tablet internal speakers. Booted up the Dell laptop I’m using for Remote, and it came up as viewable and usable by the Core. Seemed strange, so put the Core PC in sleep mode manually, woke up Core using WOL but when starting Roon again on remote PC I could see and administrate the Roon app on the Core, but NONE of the output devices were visible in the Audio section - not even the Core or the list of Google devices that always come up. Tried turning off the WIFI on the Remote PC then back on, but still not devices shown by the Core, but while searching the internet for how to do a ping and find network IP addressed, everything in Audio became visible, about 5 minutes or so.

This morning, woke up Core with WOL. Started Roon on remote PC, could not see the “Connected to this PC” section, I have not sent this screenshot, but basically the entire section for “Connected to this PC” either does or does not show at all, it does not show but trying to enable devices doesn’t work. Tried starting Roon app on the Galaxy tablet, it came up and connected, but did not show the remote PC either. But it would not really stream, kept stopping and throwing up a small red error message at the bottom saying loading slow and possible network problem.

Logged into router to get network device IP addressed, could not ping from Remote PC to Core PC, but could ping from Remote PC to the Galaxy.

Rebooted the Remote PC, “Connected to this PC” section showed up, music plays fine, no network problems apparent. But just for kicks tried pinging from Remote PC to Core PC, failed. Likewise, pinging from Core PC to Remote PC fails. Both ping the Galaxy. Shut down the Roon app on the Remote, tried pinging to the Core, still fails.

Very confused, thanks for your help,


Try not letting the Core Server go to sleep.

1 Like

Did some reading about pinging in Windows 10. Went into Windows Defender, Firewall and Network Protection, Advanced and in both Incoming and Outgoing rules enabled the rules to allow Echo. That worked, ping is working all around.

However, I noticed that in the Advanced, Incoming Rules section there were around 4-5 rules each for the roon and raat app, on both PCs, some in red showing to block/not allow. I deleted all the red do not allow rules, and then kept just one version for each app. Went back to Wiindows Defender, Firewall and Network Protection, “Allow an app through firewall” option and reset roon and raat app to allow for both public and private networks. Checked back in the Advanced, Incoming Rules and on both machines, there is only one rule, set to allow roon and ratt app access on public and private networks. But, neither PC has any rules in the Advanced section for Outgoing rules, not sure if this is necessary or how to make one, because the option to just “Allow an app through firewall” doesn’t seem to create any outgoing rule.

Somehow I’ve broke something. After rebooting all machine, on the Galaxy tablet it connects to Core and plays fine. The Remote PC connects to Core, and in Settings, Audio the “Connected to this PC” section is visible, with the System Default option enabled. But music will not play, and when selecting and album and hitting Play, Roon shows each song playing for like 2 seconds, with no sound, cycling through all the tracks on the album then stopping.

Temporarily turning off the Windows Defender firewall for the Public network allows Roon on the Remote PC to properly play and album (plays each song in full, doesn’t just cycle through each song for 2 seconds) and will play the output on the System Default on the Remote PC.

Using the Remote PC connected to Ethernet vs. WiFi does not seem to be different, still can’t play music with Windows Defender Public Network “On”. This was working previously, before I tried to clean up the Windows Defender list of Incoming Rules, which had numerous entries for the roon and raat app.

Unless you have set something up specifically, a home network should be Private . The fact that it is public could be causing issues

When installing Roon a popup asking for permission to make exceptions for the roon and raatserver in Windows Defender, and to allow those exceptions for both public and private networks. I clicked okay, just assuming both are required, maybe to allow Roon to send/receive on the public network.

I have not set up anything in particular so that I have a public network. When attempting to temporarily turn off Windows Defender to see if it was preventing Roon from playing audio on my PC and quickly cycling through songs when playing, I first only disabled the Windows Defender firewall it labels as Private, that didn’t work, so disabled the firewall for Domain, still no luck, so also disabled the firewall for the Public Network. That works, and in fact it pretty much works okay with the Private and Public firewalls on, and only the Public firewall off.

Fixed for now, not sure if the sporadic inability to have the Remote PC show up in Roon Core is fixed, but for now things are working with Windows Defender firewalls all running. In case it is of any benefit to anyone, will explain what I did.

Plenty of references on these boards to make sure that exceptions are made in Windows Defender for roon and raatserver apps which seem to be used on a full PC install. These were shown when looking at Windows Defender/Firewall and network protection/Allow an app through firewall. But when opening details for each one, the only thing I saw was “roon.exe”, without the long file name location information. So I used the buttons to add another app, browsed to their locations and added them again, clicking for public and private networks when asked.

For the Core machine running roonserver, the exe files shown in Windows Defender were raatserver.exe and roonappliance.exe. I added both of these again which saved their full filename. I also found, while browsing for those roonserver.exe, so added that. Not sure if adding them all fresh or just adding the missing roonserver.exe is what got me going.

Hello @Tim_Fontenot,

Thank you for posting your findings and I really appreciate you taking the initiative to investigate your firewall further here. The old firewall rules are possibly from previous builds of Roon, and while the firewall settings should be kept between builds, there have been other reports that Windows Defender can sometimes change these settings or remove a previously allowed application from the exceptions.

Adding them fresh was the right call here as those would be references to the current Roon and RAATServer instance. I would check to see if the initial issue has been fixed as well and make sure that Roon and RAATServer on your Remote have the same Windows Defender exceptions that you have applied to your Core. Please let me know if making this change on your Remote as well helps resolve the issue when you wake the PC over LAN and thanks again for sharing your firewall findings with us.