Roon core stopping several times a day

Roon Core Machine

Microsoft WIndows 11 pro version 10.0.22000
Dell Optiplex 7090 desktop, I5-10505, 16GB.
Latest Roon version (currently 2.0 build 1202)

Networking Gear & Setup Details

PC connected directly to Advanced Digital Broadcast router, 100Mbit ADSL line outside, but usually I get ~50Mbit.
A TPLINK deco mesh M5 (three devices) used as WIFI network and supplies an access-point to a Lumin device.

Connected Audio Devices

Lumin D2 connected by ethernet to a TPLink mesh deco 5 device which speaks with a mesh device wired to the router. A standard mesh configuration.
A Lenovo 13 gen 2 thinkpad laptop which runs as a roon endpoint, wifi.
An android SAMSUNG phone with Roon app, used to remote-control roon.
No ARC installed anywhere.

Number of Tracks in Library

0, I don’t use local files, only Tidal

Description of Issue

Everything was ok before version 2.0. Roon ran for days w/o problems.
Since the upgrade a few months ago, Roon (core) stops several times a day. It just disappears- no screenshot I can share, I have to restart it.
At some point I thought it had to do with the pc going to sleep/waking from sleep, but I think it also happens when pc is up. Not sure about it.

I thought this would be solved with updates, but this is long now and is really driving me mad.

Are there any error messages concerning Roon logged in the Windows Event Viewer?

Hi @Omer_Shibolet

I enable diagnostics and did some digging for us. In every one of your logs, I see network errors connecting to time servers, account servers, device servers, location servers, internet radio, and Tidal. These are consistent from 1-24-23 to today (that’s how far back the logs go for us). The core is somehow inhibited from getting out to the internet and it’s quite consistent.

Are there any VPNs being used?
Are there any VMs being used?
Is wifi also turned on for the core?
Are there any switches managed or otherwise?

I might recommend setting router DNS to Google or Cloudflare as well.

Google is and while Cloudflare is

Otherwise, you might want to look at cables and restart your network elements.


Thanks Geoff.

Looking at the event viewer I see about once a day a roon related reported error, in some CLR code.

It goes like this:



Thanks Wes for the help.

I use VPN for work, but none for roon and it’s not on the same computer (but is on the same network).
No VM’s involved.
No WIFI at the core machine.
There is one switch in the network, not connected to roon-related devices, but between router and MiBox + PS5.

DNS for ethernet is set as and alternate (unencrypted both).

I understand you see network errors in the logs. Network is not great, we get occasional network-downs (rarer than Roon down), but other than that, PS5, tv and hd movies work great.
I will try and look into network issues. Strange thing is this started happening when moving to 2.0 , is this version more vulnerable to these situations?

Thx, Omer.

Hi @Omer_Shibolet,

I am unaware of any changes from the 1.8 architecture to 2.0 that would cause such timeouts to happen. We do have options though. I’m going to list the instructions on how to clear the cache for your Roon instance. Below that, I will list the instructions for a fresh install across the board in case the cache clearing doesn’t work. Please note, take care to backup before you do these things! You will also need to re-enable your audio devices and if you have any custom DSP, note those settings before proceeding.

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

If this doesn’t seem to change anything, we can completely eliminate the Roon SW as a source of the problem by giving it a fresh install:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Please let me know how things go, Omer. I’ll be monitoring for responses!


I am having the same issues as well. Additionally, I am now not able to play any music through Roon as the songs time out. Might hear a few seconds of the songs and then it stops playing. This was never an issue before.

Hi @Charlie_Bettcher,

You are welcome to try the steps I have provided but it’s possible your case isn’t going to have the same conditions and therefore, might require a different course of action.

If you would, please create a post in the support category and complete the requested template so that we may address issues on a case-by-case basis.

Thank you,

Hello Wes,

I tried your suggestions above. renaming the roon and raatserver folders and reinstlling the software worked. Thank for the help.

1 Like

This is “music” to my ears! Best wishes!


Now we just need the news from, @Omer_Shibolet.

Omer, let me know!


@Wes now you got my attention!!
Hopefully I’ll try this later today.
Thx again.

1 Like

I hate to say it but having the issue again.

Hi @Charlie_Bettcher,

I’m sorry to hear that.

If you would, please open a new topic in the support category and complete the requested template. We’ll investigate your issue separately from, @Omer_Shibolet to be sure you both get the best possible care.


I have a problem. Since the initial discussion Roon has been stable like a ROK (sic).
This hasn’t been the case for months.
@Wes could this be attributed to anything you fixed here?
I postponed any change/fix until problems appear again. I will update here.
Thx everyone again.

1 Like

It still happens from time to time.
Removed the Cache contents, waiting to see if that solves it.

1 Like

If this doesn’t change anything, please let me know.


Still occurs. Can happen twice daily or once in three days.

Just called the telecom company, upgrade to fiber scheduled Mar 14. More internet downs lately, hope this solves it for Roon too, will update

Thx again.

Internet access was upgraded to fiber today. Hoping this solves it.