Roon Core stuck in "initializing" state with a red dot next to it

Roon Core Machine

Multiple i7 DELL PCs with plenty of RAM and CPU.

This is my isolated setup in trying to figure out what went wrong.

Networking Gear & Setup Details

Netgear switch → RouterOS → Internet
Set DNS on all affected pieces to 8.8.8.8 (to eliminate DNS issue).

Connected Audio Devices

Windows PC with USB DAC
RPi3 with Touch screen and USB DAC
RPi 4 with USB DAC

Speakers are JBL Active speakers

Number of Tracks in Library

65.000 songs

Description of Issue

Roon Core stuck in “initializing” state with a red dot next to it.

It worked 2 days ago, I don’t recall making any changes to my LAN.
To eliminate that possibility, I plugged my Windows endpoint and my RPi3 + touchscreen endpoint into the same switch as the Core Server.
The switch then connects directly to my Mikrotik RouterOS router which in turn goes out to the bridged ISP Modem.

All my other services and devices have no issues on my LAN or with Internet.
Internet is 1Gbit/100Mbit + Latency of less than 30ms.

My Roon Core runs Ubuntu Mint. The IP is static and the DNS is set to 8.8.8.8
My Windows machine has the latest Roon client and it has DNS set to 8.8.8.8
I also changed it back and forth to see it that would make a difference. No difference.
Nicholas

OK, so my next test was to convert my PC Roon client to a Roon Core server.
I clicked the option on the initial screen of Roon client to perform this task.
The roon symbol logo just keeps cycling through and not making any connections.
I reset my ISP modem, tested DNS and everything looks good there.
It would seem I can not connect to the Roon side servers for some reason when I click the option to turn my PC into a Roon Core server.

Can someone explain to me the workflow and how the Roon Servers interact with my local hardware?

Maybe that will shed some light on what is going on.

Nicholas

OK, one more test completed.
I installed a roon os core server VM.
I have had success with this in the past, so I figured I would see what the outcome would be.
Same issue. Included a screenshot of my PC Roon Client for reference.

roon is the VM
roon2 is a physical box.
Both on the same LAN. Both can perform basic Internet tasks such as apt upgrade without DNS issues.

Thanks in advance for what I am sure will be a really simple answer.

Nicholas

Is someone going to help me here?
Am I going about this the wrong way?
If so let me know where to try and get help from.
I’m stuck and cannot use Roon.
SOmeone please reach out.
Thanks.

Hi @Nicholas_Charalambou ,

Thanks for reaching out!

Just to confirm here, what OS was the PC using, is it still some variation of Linux or is the PC Windows/ and you had the same issue? Is the behavior the same from multiple Roon Remotes (iOS/Android too)?

Have you tried to temporarily disable the Ubuntu firewall when you performed this Core test?

Do the Roon logs show any errors? You can access them using these instructions and upload a set here for review:

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

PC runs Windows 10.
Have the same issue trying to connect to roon from my Android device as I do from my PC.

I resolved the issue.
I installed a Desktop .NET Core package (specifically 6.0.1) for a project I was working on.
It evidently was the cause of the localhost:9004 failure to connect. That is my best guess based on my review – I made no other changes (took me a minute to get there).
—//example
01/20 07:41:14 Warn: exception starting raatserver: System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 127.0.0.1:9004
—//end_example
Uninstalling it (rebooting) solved the issue.

I will mark this as solved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.