Roon Core stuck "Loggin In" on OSX 10.14.5 Mojave

Core Machine (Operating system/System info/Roon build number)

OSX 10.14.5 Mojave

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi. I can log in to the Roon website, and my other music apps (Sony HAP music transfer) is working

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Since updating to 10.14.5, Roon Core on this iMac can not log in - it is stuck with the “Loggin IN” popup window

Hi @David_Kelly1,

Can you please try connecting the Core via Ethernet to see if that has any change in this behavior?

Also, I would double check to make sure that both Roon and RAATServer have been added to your OSX firewall & any other firewalls as an exception, you can use these instructions from Apple to check the OSX aspect.

Can you give that a try and let me know if it helps?

I tried Ethernet connect, it still would not Log in

I checked firewall rules, Roon and The Service were open. I also tried turning off the firewall, which did not help.

My other Mac (which is in an older version of OSX) and it is connecting and logging in as Roon Endpoint over WiFi just fine

Hi @David_Kelly1,

Thanks for checking the firewall. Have you made any changes to your internet setup and/or DNS servers recently by any chance? I am next wondering what the Roon logs show, can I please ask you to use these instructions (<clickable link) to send them over to me as a shared Dropbox / Google Drive / link?

Very strange - so I complete uninstalled Roon, and reinstalled. Logging in took over 10 minutes, but eventually did connect. I then had to restore my database, and now it is up and running. Strangely, I was able to log into Roon via the webpage almost immediately.

I had recently reformatted my hard drive to APFS to support my upgrade to MacOS 10.14.5 Mojave from HPFS on 10.13… could there have been a permissions issue that got fixed when I reinstalled?

Hi @David_Kelly1,

Glad to hear that you are up and running again after reformatting the hard drive and reinstalling Roon!

Without the log files from the previous install it will be hard to say what exactly went wrong, so if this issue occurs again in the future please do send us logs for closer inspection.

Also, since you mentioned that the issue went away after reformatting the hard drive, you may want to run a disk check for your Mac Core.

I’m going to go ahead and mark this thread as [solved] but if you need further assistance with this issue at a later time, do let us know and we can take a closer look at the logs. Thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.