Roon Core Suddenly died

Roon Core Machine

I have a Roon nucleus.

Networking Gear & Setup Details

So it was working fine for months and then suddenly without me changing a thing, and with no wires loose or unplugged (I checked) the unit is on but nothing can connect to it. Not a roon remote on tablets, not a roon remote on iPhones, not roon app on my Mac. Nothing. The roon core is on, it is connected via ethernet and the light blinks indicating that the internet is indeed connected. Everything else connected to the router works fine. I strongly suspect that the roon core automatically upgraded and that the upgrade killed its compatibility with my network. I have no idea how to fix this and am very frustrated. I rebooted all my routers, then upgraded the firmware on all of them and rebooted again. No change. I have unplugged and replugged in the Roon nucleus, and once it is back on it makes no difference. I tried connecting the ethernet cable to a different port on my router. No change.

Connected Audio Devices

Irrelevant. Nothing can connect to the core at all.

Number of Tracks in Library

Don’t remember. Nothing changed though. It just simply stopped connecting to any devices on my network t all.

Description of Issue

Nothing to tell except that nothing can connect to the roon Nucleus. I tried saying choose a new roon core and search for roon cores on the network. Nothing can find it anymore even though it is on and connected to the internet.

Have you tried connecting a TV or monitor to the HDMI port? If so, what do you see?

I can’t offer help for your problem and don’t believe an update caused it anyway, but once you’ve got that sorted, you can make sure you’ve got better control of the update process… don’t make yourself a victim.

I tried connecting an HDMI cable. There is no apparent output from the roon core despite it being on and the lights on the back blinking as they should and all. There just appears to be no video output via HDMI port at all that the preamp or TV can see. When I plugged it in the receiving ends recognized that an HDMI connection had been made and automatically turned on. But then there was no signal.

So I work a lot which gives me very little time to troubleshoot. So far it has been a week and nothing can access my Roon Nucleus. I fear it may be bricked.

I would change this setting if I could access my nucleus at all… but I cannot.

Hey, sounds like a hardware fault if you have no output via HDMI. I assume you have tried leaving it powered down and disconnected from the mains overnight as a last resort. Sometimes NUC mainboards can get their knickers a bit twisted, especially if there’s a little burp on the mains power.

If that fails then time to get in contact with the dealer you bought it through.

@D_Andrew_White I am in the exact same situation as you, so following this thread. Came back from vacation and was not working just as you describe. I cannot get it connected to HDMI to troubleshoot, reset the network. Can’t locate the nucleus’s ip address on my network using my router’s app or the Fing app. Very frustrating. I am with two small kids so little time to troubleshoot as well.

Why would I go through the dealer and not exchange it through Roon directly? I would think that they would want to handle this themselves since they make the product. Adding the dealer in the middle seems like an inefficient waste to me. Anyhow, it is interesting that I have heard nothing from the official Roon folks on this so far. I emailed as well but no response. Ironic, because I just paid for the lifetime membership about two weeks ago. Sending this back is going to be a pain because I have an internal SSD I installed and will need to remove first. Oh well. Does anybody know how I would start the return process? Since Roon themselves are not responding to me I suppose I have to rely on the community for this.

I will try leaving it unplugged overnight to chill. I got the Nucleus from “Uncle Kevin” at so if I don’t hear from Roon on this I guess I go back to them. It’s less than a year old.

Power off the Nucleus. Like pull the plug out the back.

Plug in HDMI to TV, add keyboard if you have, verify network cable, plug in anything you normally have plugged in. Leave Nucleus off at least 60 seconds. Then…

Power on and note anything coming off the display. It should minimally post (show some bios stuff) and try to boot. If it does nothing then the next troubleshooting would be process of elimination to pull the thing apart trying to get the display to come back. But, that’s time consuming. If a full power down, connect everything (including hdmi), gives you a blank screen let Roon deal with it under warranty. :slight_smile:

Where was your music stored? It may be worth loading a Core on something else temporarily while this gets sorted so you can get back to listening.

I do apologise for trying to assist. In the UK we tend to return faulty products to the dealer first, it saves on shipping costs, and allows the dealer to confirm the fault and also carry out diagnosis before returning it to Roon themselves. I was only trying to suggest a route that may be easier for you. Rather like taking a car with a fault to your local dealership, rather that just dumping it at the factory.

I had a similar case. Diagnostics revealed that the M2 SSD controller did not work on the motherboard. The entire motherboard was replaced. Contact your dealer, do not waste time.

Hey @D_Andrew_White,

I am so sorry we only got a chance to reply on community today… :pleading_face: . It’s been too long and we apologize sincerely.

I’ve just replied over email, so I hope we can continue the conversation there :nerd_face:

1 Like

No need to apologize! And I will apologize for american spelling in response to a UK post. I am grateful for the help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.