Roon Core/UI becomes unresponsive on Mac mini M1

Roon Core Machine

Apple Mac mini (2020) with M1, 8GB RAM
MacOS 12.6 (21G115)
Roon core: Ver. 2.0 (build 1128)

Networking Gear & Setup Details

Xfinity ISP
Netgear CM600 router
Netgear Orbi RBR50 Router
Two Netgear Orbi RBS50 satellites
Ethernet from router to Satellite 1
Ethernet from Satellite 1 to TP-Link TL-SG108 switch
Ethernet from TL-SG108 switch to Mac mini
Ethernet from TL-SG108 switch to Auralic Aries mini streamer
Ethernet from TL-SG108 to WD MyCloud NAS FW: 5.23.114 (19-Jul-22) (music library)
Wifi to Allo DigiOne RPi4 end-point

Connected Audio Devices

Ethernet from TL-SG108 switch to Auralic Aries mini streamer
Auralic Aries mini streamer USB out to MyTek Brooklyn+ DAC
Wifi to Allo DigiOne RPi4 end-point (DietPi Ver. 1.8 build 1125)

Number of Tracks in Library

Music Library: 10,303 tracks - 1,641 albums
Music library on WD MyCloud: unencrypted

Description of Issue

This issue started when I moved to Mac mini M1 from Windows 10 machine.
The issue is not associated with updating to roon 2.0.

Open Roon
Start playing music (streaming from Tidal)
Sometime later… there are two likely outcomes:

    1. Music is still playing but there is no control of the app. from the MacOS UI. I have to force-stop roon and restart.
    1. I get the apple notification window telling me the application has stopped

For each occurrence, I force-stop, restart… application behaves normally until the next crash.
BTW: As an experiment, I just opened Roon and let it run without any interaction or music playing. Left for the day. Crashed sometime during the day.

Hey @Nicholas,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

I wanted to follow up on this thread to see if you were still running into freezing/crashing issues on your Mac mini core? Please update to the latest Roon build and let me know if the issue continues.

When and if Roon crashes, do you get a Mac system crash/error code?

If possible, could you please reproduce the freeze/crash issue then grab your system crash logs. There are two ways to do this:

  1. Launch Finder, press Command + Shift + G, and type ~/Library/Logs/DiagnosticReports/ in the Go to Folder dialog box.
  2. Launch Console, and look for Diagnostic Reports located under ~/Library/Logs/.

From there, zip them up, and upload them here. If you could jot down the date and time the crash occurs and share it here as well, that would be helpful!

I’ll be on standby for your reply :pray:

Just updated to 2.0 (1143). I will let you know the behavior I experience.
I will reply with the info you requested if I experience more crashes.
BTW: When I experience a crash, I get a dialog from MacOS asking if I want to report to Apple. I always click ‘Yes’.

Today 02-Nov-2022: I left roon playing overnight. I ended the Mac mini session by selecting ‘lock screen’ from the Apple system icon. This morning I can control all apps except roon. Roon does not respond when I click on the roon icon in the system tray or when I ‘command-tab’ to the app. I have to minimize the open apps to get to roon. The color wheel is spinning when I do get to roon. There is no response the any input.

There are 25 entries in the DiagnosticReports folder. I will upload the archive containing all 25.

1 Like

Hey @Nicholas,

Thank you for the above information. As a next step, I’d like to see if you experience the same issue on a fresh database. Please follow the steps below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

I will be monitoring this thread for your reply :+1:

Long time to reply… I can follow the steps you outlined. I ran ‘Find Roon OS’ from roon UI on the Mac and it never returned (spinning into infinity.). I performed a backup but the ‘snapshot’ process never finished (I let it run overnight.). So I moved all of the Roon-related folders to trash: the roon app, RAATServer, cache com.roonlabs.raat, com.roon.Roon.savedState. I then downloaded and installed a fresh copy of the app from the roon software download site. So far, so good… about 6-hours running. I’ve run a backup, setup Tidal, and configured some aspects of the UI.

@Benjamin Well, the reinstall (maybe) addressed some of the problem. But now, when roon dies (or maybe because of it) the audio device I am listening to disappears. I open the app when the music stops and see ‘Select audio zone.’ But when I do, the device is no on the list. I have to quit roon and restart the app. OK… your turn.

Hey @Nicholas,

Can you be more specific around which endpoints / audio devices are disconnecting? If possible please take note of the date and time and track name the next time this happens, and share it here :+1:

I would also investigate your network setup and give your router a reboot to refresh things to that end as well.


Thanks for your continued recommendations and support.
@benjamin I left roon playing since about 7am yesterday. I interacted with the app a few times during the day. I came in this morning and this is what I found. The 3rd device that is no listed is an Auralic Aries mini streamer. The Mac and Aries mini connect via ethernet through a TP-Link 8-port switch.

Regarding network: I did a full reset including powering off all devices that connect to the net, then bringing them back online one at a time. This was prior to re-installing roon. I am not a network expert. I can easily follow complex instructions. So if you have specific suggestions about what is likely causing this issue, I’m all ears. But I’m afraid that “investigate your network setup” is not helpful.

By the way, when roon stops functioning, JRiver and Auralic Lightning DS continue to function.

Best regards

1 Like

@Nicholas thanks for the update.

Is this a managed or unmanaged switch? Does this issue occur if you bypass the switch?

I enabled diagnostics on your account and couldn’t find anything specific to the timeframe you mentioned. If you’re able to nail down a more specific time, that may be helpful.

We’ve seen other users find success in doing a Mac OS reinstall, but I do understand how that can be time-consuming.

Let me know the specified date, time and name of the track that is playing the next time you run into this issue :+1:

unmanaged. I haven’t tried to bypass but will. I’ll do my best to watch for detailed playing info and report.

1 Like

@Benjamin Last night, sometime after 8:00pm roon became unresponsive. 44 seconds into the track Love Has No Pride by Rory Black the system became unresponsive. I came in this morning about 8:00am, clicked on the roon icon and got the macOS spinning beachball. I had to ‘force quit’ to regain control

Hey @Nicholas,

I’m seeing a large number of RAATServer-based issues, as well as some network-based errors. Do you see this issue happen if you stream audio from your system output VS any of your endpoints?

@Benjamin I shift to playing USB out of the Mac mini to a different DAC and speakers. I’ll let it run for 24+ hours and report back.

@Benjamin The system hung… not just roon. I restarted the Mac mini. I selected the USB out of the Mac mini to a different DAC and speakers. It ran for ~ 5-hrs. Stopped on ‘Mr. Groove’ by Eugene Groove. When I clicked the play icon, the message “Select an Audio Zone” flashed, then showed the same zone I was playing to. I’m playing a play list again.

I’m inclined to contact Apple support because these issues have been happening since I switched to the Mac mini… never had an issues on Win10.

1 Like

Hey @Nicholas,

Thanks for your patience while I was away on holiday. Following up on this thread, did you also test streaming audio to the system output of the Mac mini? If you could get your core back online so we can enable additional diagnostics, that would be helpful!

It seems odd that it could stream endlessly without issue for 5 hours before running into issues with your endpoints. How are the DAC and speakers connected to your router? With this specific instance, it does sound like some potential network hiccups between your audio devices could be at play.