Roon Core Will Not Update to 1182

Core Machine
• ROCK 2.0 build 1169
• NUC8i5BEH (256GB SSD; 8GB RAM)

Remotes (all build 1182)
• Windows 10 on i7 Lenovo Laptop
• Kindle Fire HD10 (modified with APK files for Play Store) with Roon app
• Samsung Galaxy S20 with Roon app

• Nokia BGW320-505 gateway (AT&T isp)
• Ethernet to NUC (music files and database BU folder on WD Passport HDD connected to NUC)
• Ethernet to Roon Bridge on Raspberry Pi
• Wifi to (2) SB Touch endpoints (w/EDO mod)

Relevant Audio Devices
• Yamaha RX-V 863 (via Topping E39 DAC from Rasberry/Roon Bridge)

Library Details
• ~45K tracks (stored on 2T external HDD connected via usb to NUC)
• ~14K tracks in Qobuz library

Description of Issue

When update for Build 1182 dropped all my remotes updated but my core did not. Download bar appeared (as viewed on laptop remote) but did not advance. After an extended period of time, an error message appeared indicating an error.

Note that Roon is currently otherwise functioning flawlessly. The update will simply not download.

Things I have already tried

  • Rebooting Router
  • Rebooting NUC
  • Switching update preference back and forth between “Automatically install updates” and “Ask before downloading updates.”

Guidance on how to solve this and update to the new build would be much appreciated. (@support) I’m really excited to see about the new content sources and looking forward to checking them out.

(Sorry about the delay in reporting this issue; I was temporarily excommunicated from the Roon Community until just before Christmas, which cut of my access to Roon Support – more about which elsewhere – and then went travelling for the holidays.)

Have you tried reinstalling Roon OS via the Web Administration page?

Thanks for the response, @Geoff_Coupe. I thought about it but wasn’t sure if that move makes sense since it is ROCK that will not update and the OS seems to be the most current version (b. 254). I also worry about doing stuff that might make matters worse since my technical skills in this domain are stretched pretty thin in this domain. Are there any tips or potential pitfalls of reinstalling the OS from the Web Administration page I should be aware of before going forward with that operation? Or should I await some word from @Support before taking that step?

Again, thanks forr the response, you guidance is appreciated.

It’s worth a try to reinstall, even if you are running the latest version of Roon OS.

The operation can take several minutes depending on your internet connection. The Reinstall button will always reinstall the latest firmware, even if you are already running the latest.

Reinstalling the software will not affect your settings or your Roon Database.


I’m going to go ahead and cross my fingers give this a try. Ill let you know what happens…

Well, that did the trick. Thanks so much, Geoff!


@Geoff_Coupe is awesome, isn’t he?

Thanks, Geoff!

Enjoy the music, @SisyphusStone.


Indeed he is! And thanks, I am!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.