Roon Core will not update to build 610. iMac

*Core Machine (Operating system/System info/Roon build number)
Core is 2017 iMac running Mohave 10.14.6.
Roon Server is installed and running

*Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Spectrum Modem Router 100mbs dload

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

only endpoint is an Oppo UDP-205 universal disk player

Description Of Issue

My RoonCore says its v1.7 build 537. Whenever I try to update to build 610, it loads the update, starts to install the update and then I get an error message saying “there was a problem with the update”.
my firewall is turned off…
I completely uninstalled Roon after backup (Roon folder and Roon Library folder) then re-downloaded and re-installed Roon, but I still;; end up with v1.7 build 537.
All other devices on my home network work perfectly.

Perplexed.
Jeff Swanson

Hi @Jeff_Swanson,

Can you please try to create a Backup of your Roon database and then install the latest version of Roon from our Downloads Page? If you are using Roon Server, please download Roon Server from the page, not the Roon All-In-One.

I created a new backup then downloaded Roon Server for MacOSX from your web page.
reinstalled. No change. Still v1.7 build 537. I get the same message which I included in photo.

This all started when I realized that I cannot add any album or artist to library. When I click “add to Library”, I get a message saying that its taking longer than normal and Roon will continue to try in the background but nothing is ever added.
I created a previous support ticket about this and the techie wanted copies of my zipped Roon/Roon Server logs which I attempted to send several times but my message(s) were rejected by the mail server, saying no such group existed or I wasn’t authorized to post.

I’m very frustrated and am perfectly willing to start completely over (including NOT using Roon Server anymore) but every time I attempt that, I end up with the same version and the same problems.
Please help,
Jeff Swanson

Use an install cleaner, this guy does the job: https://www.macupdate.com/app/mac/25276/appcleaner

Not an official Apple tool, I have used for many years now, never had any drama.
After doing the cleanup empty your trash bin, then install 610.

Other thing, isn’t it that you have separate modules? when I used my iMac as core I ran separate packages, so by instance, when installed Roon I did 3 installs: core package, bridge package and Roon package for the UI.

If you did it that way you may just download the core package and deploy it.

You will find out if you use “separate modules” when in the app cleaner you just search for Roon:

mine is greyed out as it is currently running, as always :smiley:

Hi @Jeff_Swanson,

To send files over to us on the forum, you need to use a 3rd party file uploading site, like Google Drive or Dropbox.

I can also provide you a link to our diagnostics servers to upload, I have sent the information via private message.

Can you please use these instructions to access the logs and upload to the link I sent you?

Thanks!