Roon could not find WGL functions required to initialize OpenGL

I am getting the same message. My Roon will no longer open. Thanks for the link, but it made no difference. Updated my drivers for Intel HD Graphics 4600 GPU. Roon will still not load. Appears to be a Roon malfunction.

Hi, I’ve split out your post to its own support topic…

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

My setup:

  • Windows 10 (latest update installed) 64-bit.
  • PowerSpec PC, Intel i5 processor with Intel HD Graphics 4600 GPU
    (updated GPU drivers today).
  • Network is ethernet connected, though this does not appear to be a network issue.
  • DAC is Classe CP-800 connected directly to the PC.
  • Library is stored in 10TB internal hard drive. Not sure how many songs specifically,
    but there are over 8TB worth of music in the database.

image

Im betting this is OpenGL support related on an older GFX chipset.

you could try this

https://support.esri.com/en/technical-article/000011375

or maybe this

https://www.geeks3d.com/20141121/gl-z-opengl-information-utility-extensions-viewer-for-windows-linux-and-os-x/ downloads here https://www.geeks3d.com/glz/

Use 3rd party downloaded apps at your own risk!

Not sure if this makes sense. I am not that technically sophisticated but Roon worked yesterday before I updated to the latest versions of both Windows 10 and Roon. The combination of the two at the same time is now preventing me from opening Roon at all. Not sure how the older chipset would suddenly stop working with Roon, when it worked the day before. Thoughts?

I guess it is going to depend on what release you were on before you updated. there are constantly moving updates in roon that sometimes can activate more demands on a chipset that were previously not used. OpenGL 3.0 was one of those areas that has had recent increases in functions used - this could be why.

I’ll leave to @support too chime in where this is concerned for and from now.

Hi @George_Hersh,

What version of Roon were you running prior to the update?

Can you verify how you updated your drivers? Often times automatic Windows updates aren’t the most reliable, so I’d recommend you check out Intel’s download center and download the latest drivers from there.

Well, I think I figured it out. I am using Roon 1.7 (I routinely use the Update link when it appears). My Roon server is placed on a dedicated machine PC desktop. Typically, I access this machine through Remote Desktop from my laptop in another room. This was the situation when I got the OpenGL error. So, I walked over to my Music Server, logged onto the Music Server directly and Roon opened immediately. No error. The Roon clients I have all over the house appear to work as well.

Next step is to update drivers on my laptop to find the remote problem.

I can relate to this as well. Roon core runs on a remote Win10 Lenove TS140 server for me. After I had reported the issue and I had updated the intel drivers, Roon would not open up in the remote sessions still. I had since Roon without the UI at the server and it is working. It is a challenge though and hope Roon Support, gives us a better guidance on this.

AFAIK this is a Windows Remote Desktop limitation. See also:

You might try using Teamviewer instead.

any desk is another I like to use. For Macs they have a Screen Sharing app built in too

Hi Roon people, just FYI the workaround for this issue (which affects all users of Windows 10 version 1903 who use Remote Desktop) is to disable WDDM in the group policy. The workaround is described here:

https://answers.microsoft.com/en-us/windows/forum/all/windows-10-1903-may-update-black-screen-with/23c8a740-0c79-4042-851e-9d98d0efb539

tl;dr Gpedit.msc: Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Remote Session Environment -> Use WDDM graphics display driver for Remote Desktop Connections -> DISABLE

Alternatively, it would be good if Roon could mayber not require OpenGL, so it could be used over remote desktop?

Thanks,
Jim

1 Like

That would require a complete re-write of the UI codebase. I doubt very much that it’s going to happen soon… :slightly_smiling_face:

See this comment for more information:

2 posts were split to a new topic: WGL function error