Roon could not find WGL functions to initialize OpenGL

Core Machine

PC, i-7-4790K CPU@4.00GHz, 16.0 GB RAM, Windows 10
Roon runs on ROCK, Intel Nuc NUC7i7BNH, SW Version 1.8

Network Details

Ethernet , Linksys MR9600 Router

Audio Devices

BACCH-SP DAC connected to ROCK via ethernet cable

Description of Issue

Everything worked perfectly till this morning. I am getting the “Roon could not find WGL functions required to initialize OpenGL.” I’ve tried everything mentioned in the old posts (reinstalling the Roon app, updating all drivers, etc.). The problem still persist. I can still manage via iPad and/or iPhone, but I miss my PC access a lot. Please help.

Did you update the drivers from the GPU manufacturer’s website?

Also, you are not by chance using Remote Desktop? As that error occurs with it.

Thanks Rugby!
Yes, I’ve just re-checked and Intel Driver +&Support assistant says that everything is up to date. No, I do not use Remote Desktop. I’ve only changed my monitor - it is wide 49" Samsung G9. Can this be the reason?

Sorry for the delay here, @Quixil!

Are you still seeing issues here?

Did the error start around the time you switched monitors?

Are you using any type of screen overlay software?

Roon Core Machine

PC, i-7-4790K CPU@4.00GHz, 16.0 GB RAM, Windows 10
Roon runs on ROCK, Intel Nuc NUC7i7BNH, SW Version 1.8

Networking Gear & Setup Details

Ethernet , Linksys MR9600 Router

Connected Audio Devices

BACCH-SP DAC connected to ROCK via ethernet cable

Library Size

Description of Issue

I am getting “Roon could not find WGL functions…” error since I’ve changed my monitor…

Hi @Quixil, can you see my post from above:

Cheers Dylan,

yes, I saw you’ve moved it. Thanks, I was travelling heavily and put this issue on hold. Can we pls proceed?

Cheers Dylan,

I guess you are waiting for my previous answers:

  • yes, the issue started when I switched monitors
  • I don’t use any screen overlay software

Hi Dylan,

please confirm that this discussion is still open and that you’ll come back to me when you’ll have time.

Thanks!

Thanks for the update, @Quixil. Yep, this discussion is open and we’ll continue here :slight_smile:

Are you using multiple monitors? If so, are you using Display Fusion or something along those lines to manage them?

Basically OpenGL is needed for Roon to run properly, and this error is saying it’s unable to find the proper resources on the GPU to start Roon. This might be because the drivers are bad or there is another application suppressing OpenGL support (we’ve seen some overlays do this). Anything you can think of along these lines would be helpful.

Thanks Dylan!

I used to have 4 monitors and I never got this error. I switched to this new wide single one and immediately experienced this issue. I am not very computer savvy but I think I didn’t use any Display Fusion before. However, when I switched to a single monitors I do recall having an issue seeing the lead screen. In fact when I turn on my PC (it stayed the same as with 4 monitors) my screen remains black until I insert my password and only then I get the Windows 10 front page…I am sure you’ve nailed the problem but I will need your help with my settings.

Thanks again!

Thanks for the update, @Quixil. Is this an HDR monitor? If so, can you try disabling HDR and let me know if there is any change?

Hi Dylan,

yes it is an HDR monitor. The HDR was disabled by default as I have checked.

Thanks, @Quixil. Can you send logs from this machine? We’ll want to take a look at Event Viewer logs and Roon logs. Instructions below:

Roon Logs

Use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).

Event Viewer

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log... from the context menu
  5. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  6. Right click on the Application subsection again and pick Save filtered log file as.. from the context menu
  7. Enter the log file name, for e.g. Roon_USERNAME , and press Save

Hi Dylan,

it has been a while since I sent you the requested files. Any progress on the solution?

Thanks!